%global _empty_manifest_terminate_build 0
Name: python-vectorhub
Version: 1.8.3
Release: 1
Summary: One liner to encode data into vectors with state-of-the-art models using tensorflow, pytorch and other open source libraries. Word2Vec, Image2Vec, BERT, etc
License: Apache
URL: https://github.com/vector-ai/vectorhub
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/20/d5/03f2cf02eddd67439aef3e08bd54ca36f6d663c3ed092093b07998337411/vectorhub-1.8.3.tar.gz
BuildArch: noarch
Requires: python3-PyYAML
Requires: python3-requests
Requires: python3-document-utils
Requires: python3-numpy
Requires: python3-Pillow
Requires: python3-PyYAML
Requires: python3-imageio
Requires: python3-soundfile
Requires: python3-tensorflow
Requires: python3-sphinx-rtd-theme
Requires: python3-requests
Requires: python3-sentence-transformers
Requires: python3-moviepy
Requires: python3-document-utils
Requires: python3-scikit-image
Requires: python3-PyYAML
Requires: python3-torch
Requires: python3-transformers
Requires: python3-fastai
Requires: python3-pytest
Requires: python3-torch
Requires: python3-appdirs
Requires: python3-mtcnn
Requires: python3-tf-models-official
Requires: python3-opencv-python
Requires: python3-tensorflow-text
Requires: python3-Pillow
Requires: python3-librosa
Requires: python3-tensorflow-hub
Requires: python3-fairseq
Requires: python3-numpy
Requires: python3-clip-by-openai
Requires: python3-bert-for-tf2
Requires: python3-appdirs
Requires: python3-librosa
Requires: python3-bert-for-tf2
Requires: python3-Pillow
Requires: python3-imageio
Requires: python3-scikit-image
Requires: python3-torch
Requires: python3-clip-by-openai
Requires: python3-opencv-python
Requires: python3-clip-by-openai
Requires: python3-PyYAML
Requires: python3-requests
Requires: python3-document-utils
Requires: python3-numpy
Requires: python3-document-utils
Requires: python3-fairseq
Requires: python3-torch
Requires: python3-tensorflow-hub
Requires: python3-soundfile
Requires: python3-tensorflow
Requires: python3-librosa
Requires: python3-transformers
Requires: python3-torch
Requires: python3-imageio
Requires: python3-scikit-image
Requires: python3-opencv-python
Requires: python3-fastai
Requires: python3-torch
Requires: python3-Pillow
Requires: python3-tensorflow
Requires: python3-appdirs
Requires: python3-mtcnn
Requires: python3-opencv-python
Requires: python3-imageio
Requires: python3-scikit-image
Requires: python3-tensorflow
Requires: python3-tensorflow-hub
Requires: python3-torch
Requires: python3-sentence-transformers
Requires: python3-transformers
Requires: python3-tensorflow
Requires: python3-tensorflow-text
Requires: python3-tensorflow
Requires: python3-tensorflow-hub
Requires: python3-tf-models-official
Requires: python3-bert-for-tf2
Requires: python3-tf-models-official
Requires: python3-tensorflow-hub
Requires: python3-tensorflow
Requires: python3-bert-for-tf2
Requires: python3-transformers
Requires: python3-torch
Requires: python3-moviepy
Requires: python3-opencv-python
Requires: python3-fairseq
Requires: python3-fastai
Requires: python3-imageio
Requires: python3-librosa
Requires: python3-moviepy
Requires: python3-mtcnn
Requires: python3-numpy
Requires: python3-opencv-python
Requires: python3-pytest
Requires: python3-requests
Requires: python3-scikit-image
Requires: python3-sentence-transformers
Requires: python3-soundfile
Requires: python3-sphinx-rtd-theme
Requires: python3-tensorflow-hub
Requires: python3-tensorflow-text
Requires: python3-tensorflow
Requires: python3-sphinx-rtd-theme
Requires: python3-pytest
Requires: python3-tf-models-official
Requires: python3-torch
Requires: python3-torch
Requires: python3-transformers
%description
There are many ways to extract vectors from data. This library aims to bring in all the state of the art models in a simple manner to vectorise your data easily.
Vector Hub provides:
- A low barrier of entry for practitioners (using common methods)
- Vectorise rich and complex data types like: text, image, audio, etc in 3 lines of code
- Retrieve and find information about a model
- An easy way to handle dependencies easily for different models
- Universal format of installation and encoding (using a simple `encode` method).
In order to provide an easy way for practitioners to quickly experiment, research and build new models and feature vectors, we provide a streamlined way to obtain vectors through our universal `encode` API.
Every model has the following:
- `encode` allows you to turn raw data into a vector
- `bulk_encode` allows you to turn multiple objects into multiple vectors
- `encode_documents` returns a list of dictionaries with with an encoded field
For bi-modal models:
Question Answering encoders will have:
- `encode_question`
- `encode_answer`
- `bulk_encode_question`
- `bulk_encode_answer`
Text Image Bi-encoders will have:
- `encode_image`
- `encode_text`
- `bulk_encode_image`
- `bulk_encode_text`
%package -n python3-vectorhub
Summary: One liner to encode data into vectors with state-of-the-art models using tensorflow, pytorch and other open source libraries. Word2Vec, Image2Vec, BERT, etc
Provides: python-vectorhub
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-vectorhub
There are many ways to extract vectors from data. This library aims to bring in all the state of the art models in a simple manner to vectorise your data easily.
Vector Hub provides:
- A low barrier of entry for practitioners (using common methods)
- Vectorise rich and complex data types like: text, image, audio, etc in 3 lines of code
- Retrieve and find information about a model
- An easy way to handle dependencies easily for different models
- Universal format of installation and encoding (using a simple `encode` method).
In order to provide an easy way for practitioners to quickly experiment, research and build new models and feature vectors, we provide a streamlined way to obtain vectors through our universal `encode` API.
Every model has the following:
- `encode` allows you to turn raw data into a vector
- `bulk_encode` allows you to turn multiple objects into multiple vectors
- `encode_documents` returns a list of dictionaries with with an encoded field
For bi-modal models:
Question Answering encoders will have:
- `encode_question`
- `encode_answer`
- `bulk_encode_question`
- `bulk_encode_answer`
Text Image Bi-encoders will have:
- `encode_image`
- `encode_text`
- `bulk_encode_image`
- `bulk_encode_text`
%package help
Summary: Development documents and examples for vectorhub
Provides: python3-vectorhub-doc
%description help
There are many ways to extract vectors from data. This library aims to bring in all the state of the art models in a simple manner to vectorise your data easily.
Vector Hub provides:
- A low barrier of entry for practitioners (using common methods)
- Vectorise rich and complex data types like: text, image, audio, etc in 3 lines of code
- Retrieve and find information about a model
- An easy way to handle dependencies easily for different models
- Universal format of installation and encoding (using a simple `encode` method).
In order to provide an easy way for practitioners to quickly experiment, research and build new models and feature vectors, we provide a streamlined way to obtain vectors through our universal `encode` API.
Every model has the following:
- `encode` allows you to turn raw data into a vector
- `bulk_encode` allows you to turn multiple objects into multiple vectors
- `encode_documents` returns a list of dictionaries with with an encoded field
For bi-modal models:
Question Answering encoders will have:
- `encode_question`
- `encode_answer`
- `bulk_encode_question`
- `bulk_encode_answer`
Text Image Bi-encoders will have:
- `encode_image`
- `encode_text`
- `bulk_encode_image`
- `bulk_encode_text`
%prep
%autosetup -n vectorhub-1.8.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-vectorhub -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 1.8.3-1
- Package Spec generated