%global _empty_manifest_terminate_build 0
Name: python-fbchat-asyncio
Version: 0.6.21
Release: 1
Summary: Facebook Messenger library for Python/Asyncio.
License: BSD License
URL: https://github.com/tulir/fbchat-asyncio
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/10/09/e2ebacd51d9f7bbe0d218520d9d4f6596f38f6f2803a35e1e7139a4135a6/fbchat-asyncio-0.6.21.tar.gz
BuildArch: noarch
Requires: python3-aiohttp
Requires: python3-attrs
Requires: python3-beautifulsoup4
Requires: python3-paho-mqtt
Requires: python3-yarl
Requires: python3-aiohttp-socks
Requires: python3-pysocks
%description
A powerful and efficient library to interact with
`Facebook's Messenger `__, using just your email and password.
This is an asyncio fork of the `fbchat `__ library.
This is *not* an official API, Facebook has that `over here `__ for chat bots. This library differs by using a normal Facebook account instead.
``fbchat`` currently support:
- Sending many types of messages, with files, stickers, mentions, etc.
- Fetching all messages, threads and images in threads.
- Searching for messages and threads.
- Creating groups, setting the group emoji, changing nicknames, creating polls, etc.
- Listening for, an reacting to messages and other events in real-time.
- Type hints, and it has a modern codebase (e.g. only Python 3.5 and upwards).
- ``async``/``await`` (COMING).
Essentially, everything you need to make an amazing Facebook bot!
%package -n python3-fbchat-asyncio
Summary: Facebook Messenger library for Python/Asyncio.
Provides: python-fbchat-asyncio
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-fbchat-asyncio
A powerful and efficient library to interact with
`Facebook's Messenger `__, using just your email and password.
This is an asyncio fork of the `fbchat `__ library.
This is *not* an official API, Facebook has that `over here `__ for chat bots. This library differs by using a normal Facebook account instead.
``fbchat`` currently support:
- Sending many types of messages, with files, stickers, mentions, etc.
- Fetching all messages, threads and images in threads.
- Searching for messages and threads.
- Creating groups, setting the group emoji, changing nicknames, creating polls, etc.
- Listening for, an reacting to messages and other events in real-time.
- Type hints, and it has a modern codebase (e.g. only Python 3.5 and upwards).
- ``async``/``await`` (COMING).
Essentially, everything you need to make an amazing Facebook bot!
%package help
Summary: Development documents and examples for fbchat-asyncio
Provides: python3-fbchat-asyncio-doc
%description help
A powerful and efficient library to interact with
`Facebook's Messenger `__, using just your email and password.
This is an asyncio fork of the `fbchat `__ library.
This is *not* an official API, Facebook has that `over here `__ for chat bots. This library differs by using a normal Facebook account instead.
``fbchat`` currently support:
- Sending many types of messages, with files, stickers, mentions, etc.
- Fetching all messages, threads and images in threads.
- Searching for messages and threads.
- Creating groups, setting the group emoji, changing nicknames, creating polls, etc.
- Listening for, an reacting to messages and other events in real-time.
- Type hints, and it has a modern codebase (e.g. only Python 3.5 and upwards).
- ``async``/``await`` (COMING).
Essentially, everything you need to make an amazing Facebook bot!
%prep
%autosetup -n fbchat-asyncio-0.6.21
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-fbchat-asyncio -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 31 2023 Python_Bot - 0.6.21-1
- Package Spec generated