%global _empty_manifest_terminate_build 0
Name: python-FuzzingTool
Version: 3.14.0
Release: 1
Summary: Software for fuzzing, used on web application pentestings.
License: MIT
URL: https://github.com/NESCAU-UFLA/FuzzingTool/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/66/05/a26248a0908ba83651ef148466d74b1860152b4203fcdbe58f2a790e9695/FuzzingTool-3.14.0.tar.gz
BuildArch: noarch
Requires: python3-beautifulsoup4
Requires: python3-dnspython
Requires: python3-Wappalyzer
Requires: python3-requests
Requires: python3-pytest
Requires: python3-pytest-cov
%description
FuzzingTool is a web penetration testing tool, that handles with fuzzing. After the test is completed, all possible vulnerable entries (and the response data) are saved on a report file.
## Disclaimer
We're not responsible for the misuse of this tool. This project was created for educational purposes and should not be used in environments without legal authorization.
## Screenshot
![screenshot](https://user-images.githubusercontent.com/43549176/166966746-b4e8f130-eeb7-4ba4-a7b0-b385a81bb16e.png)
## Getting Started
Before we start the *penetration testings*, take a look at the **installing** and **prerequisites**.
### Installing from Pypi
FuzzingTool is now on Pypi! You can install with:
```
$ pip install FuzzingTool
```
### Installing from source
If you want to install it manually, download the last release or clone this repository, and also follow the next prerequisites.
#### Prerequisites
* Go to the project source folder, and run:
```
$ pip install -r requirements.txt
```
### User's Manual
Reach out the user's manual (command list and usage examples) on our [wiki page](https://github.com/NESCAU-UFLA/FuzzingTool/wiki).
## Versioning
We use [SemVer](https://semver.org/) for versioning. For the versions available, see the [tags on this repository](https://github.com/NESCAU-UFLA/FuzzingTool/releases).
## Authors
* **Vitor Oriel**
* [GitHub](https://github.com/VitorOriel)
* [Linkedin](https://www.linkedin.com/in/vitor-oriel-borges)
* Email: vitorwixmix@gmail.com
## Contributing
If you want to contribute to FuzzingTool project, please read [CONTRIBUTING.md](https://github.com/NESCAU-UFLA/FuzzingTool/blob/master/.github/CONTRIBUTING.md).
## License
This project is licensed under the MIT License - see the [LICENSE](https://github.com/NESCAU-UFLA/FuzzingTool/blob/master/LICENSE) for details.
%package -n python3-FuzzingTool
Summary: Software for fuzzing, used on web application pentestings.
Provides: python-FuzzingTool
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-FuzzingTool
FuzzingTool is a web penetration testing tool, that handles with fuzzing. After the test is completed, all possible vulnerable entries (and the response data) are saved on a report file.
## Disclaimer
We're not responsible for the misuse of this tool. This project was created for educational purposes and should not be used in environments without legal authorization.
## Screenshot
![screenshot](https://user-images.githubusercontent.com/43549176/166966746-b4e8f130-eeb7-4ba4-a7b0-b385a81bb16e.png)
## Getting Started
Before we start the *penetration testings*, take a look at the **installing** and **prerequisites**.
### Installing from Pypi
FuzzingTool is now on Pypi! You can install with:
```
$ pip install FuzzingTool
```
### Installing from source
If you want to install it manually, download the last release or clone this repository, and also follow the next prerequisites.
#### Prerequisites
* Go to the project source folder, and run:
```
$ pip install -r requirements.txt
```
### User's Manual
Reach out the user's manual (command list and usage examples) on our [wiki page](https://github.com/NESCAU-UFLA/FuzzingTool/wiki).
## Versioning
We use [SemVer](https://semver.org/) for versioning. For the versions available, see the [tags on this repository](https://github.com/NESCAU-UFLA/FuzzingTool/releases).
## Authors
* **Vitor Oriel**
* [GitHub](https://github.com/VitorOriel)
* [Linkedin](https://www.linkedin.com/in/vitor-oriel-borges)
* Email: vitorwixmix@gmail.com
## Contributing
If you want to contribute to FuzzingTool project, please read [CONTRIBUTING.md](https://github.com/NESCAU-UFLA/FuzzingTool/blob/master/.github/CONTRIBUTING.md).
## License
This project is licensed under the MIT License - see the [LICENSE](https://github.com/NESCAU-UFLA/FuzzingTool/blob/master/LICENSE) for details.
%package help
Summary: Development documents and examples for FuzzingTool
Provides: python3-FuzzingTool-doc
%description help
FuzzingTool is a web penetration testing tool, that handles with fuzzing. After the test is completed, all possible vulnerable entries (and the response data) are saved on a report file.
## Disclaimer
We're not responsible for the misuse of this tool. This project was created for educational purposes and should not be used in environments without legal authorization.
## Screenshot
![screenshot](https://user-images.githubusercontent.com/43549176/166966746-b4e8f130-eeb7-4ba4-a7b0-b385a81bb16e.png)
## Getting Started
Before we start the *penetration testings*, take a look at the **installing** and **prerequisites**.
### Installing from Pypi
FuzzingTool is now on Pypi! You can install with:
```
$ pip install FuzzingTool
```
### Installing from source
If you want to install it manually, download the last release or clone this repository, and also follow the next prerequisites.
#### Prerequisites
* Go to the project source folder, and run:
```
$ pip install -r requirements.txt
```
### User's Manual
Reach out the user's manual (command list and usage examples) on our [wiki page](https://github.com/NESCAU-UFLA/FuzzingTool/wiki).
## Versioning
We use [SemVer](https://semver.org/) for versioning. For the versions available, see the [tags on this repository](https://github.com/NESCAU-UFLA/FuzzingTool/releases).
## Authors
* **Vitor Oriel**
* [GitHub](https://github.com/VitorOriel)
* [Linkedin](https://www.linkedin.com/in/vitor-oriel-borges)
* Email: vitorwixmix@gmail.com
## Contributing
If you want to contribute to FuzzingTool project, please read [CONTRIBUTING.md](https://github.com/NESCAU-UFLA/FuzzingTool/blob/master/.github/CONTRIBUTING.md).
## License
This project is licensed under the MIT License - see the [LICENSE](https://github.com/NESCAU-UFLA/FuzzingTool/blob/master/LICENSE) for details.
%prep
%autosetup -n FuzzingTool-3.14.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-FuzzingTool -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 31 2023 Python_Bot - 3.14.0-1
- Package Spec generated