%global _empty_manifest_terminate_build 0
Name: python-universal-build
Version: 0.6.18
Release: 1
Summary: Universal build utilities for containerized build pipelines.
License: MIT
URL: https://github.com/ml-tooling/universal-build
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/3d/35/066f9a2d865148757bfb31f6594ae1c27ee84fa5bf4564b97c68c76b2b5b/universal-build-0.6.18.tar.gz
BuildArch: noarch
Requires: python3-setuptools
Requires: python3-pipenv
Requires: python3-wheel
Requires: python3-twine
Requires: python3-flake8
Requires: python3-pytest
Requires: python3-pytest-mock
Requires: python3-pytest-cov
Requires: python3-mypy
Requires: python3-black
Requires: python3-pydocstyle
Requires: python3-isort
Requires: python3-lazydocs
%description
## Support & Feedback
This project is maintained by [Benjamin Räthlein](https://twitter.com/raethlein), [Lukas Masuch](https://twitter.com/LukasMasuch), and [Jan Kalkan](https://www.linkedin.com/in/jan-kalkan-b5390284/). Please understand that we won't be able to provide individual support via email. We also believe that help is much more valuable if it's shared publicly so that more people can benefit from it.
| Type | Channel |
| ------------------------------ | ---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------- |
| 🚨 **Bug Reports** | |
| 🎁 **Feature Requests** | |
| 👩💻 **Usage Questions** | |
| 🗯 **General Discussion** | |
%package -n python3-universal-build
Summary: Universal build utilities for containerized build pipelines.
Provides: python-universal-build
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-universal-build
## Support & Feedback
This project is maintained by [Benjamin Räthlein](https://twitter.com/raethlein), [Lukas Masuch](https://twitter.com/LukasMasuch), and [Jan Kalkan](https://www.linkedin.com/in/jan-kalkan-b5390284/). Please understand that we won't be able to provide individual support via email. We also believe that help is much more valuable if it's shared publicly so that more people can benefit from it.
| Type | Channel |
| ------------------------------ | ---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------- |
| 🚨 **Bug Reports** | |
| 🎁 **Feature Requests** | |
| 👩💻 **Usage Questions** | |
| 🗯 **General Discussion** | |
%package help
Summary: Development documents and examples for universal-build
Provides: python3-universal-build-doc
%description help
## Support & Feedback
This project is maintained by [Benjamin Räthlein](https://twitter.com/raethlein), [Lukas Masuch](https://twitter.com/LukasMasuch), and [Jan Kalkan](https://www.linkedin.com/in/jan-kalkan-b5390284/). Please understand that we won't be able to provide individual support via email. We also believe that help is much more valuable if it's shared publicly so that more people can benefit from it.
| Type | Channel |
| ------------------------------ | ---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------- |
| 🚨 **Bug Reports** | |
| 🎁 **Feature Requests** | |
| 👩💻 **Usage Questions** | |
| 🗯 **General Discussion** | |
%prep
%autosetup -n universal-build-0.6.18
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-universal-build -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 31 2023 Python_Bot - 0.6.18-1
- Package Spec generated