%global _empty_manifest_terminate_build 0
Name: python-flowtorch
Version: 0.8
Release: 1
Summary: Normalizing Flows for PyTorch
License: MIT
URL: https://flowtorch.ai/users
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/5a/ac/c6527619b342a8d7bf5dd82c1d49c750946c2512ebe66187c81c143fcfa0/flowtorch-0.8.tar.gz
BuildArch: noarch
Requires: python3-torch
Requires: python3-numpy
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-scipy
Requires: python3-black
Requires: python3-flake8
Requires: python3-flake8-bugbear
Requires: python3-mypy
Requires: python3-toml
Requires: python3-usort
Requires: python3-numpy
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-scipy
%description
![](https://github.com/facebookincubator/flowtorch/raw/main/website/static/img/logo.svg)
[![](https://github.com/facebookincubator/flowtorch/workflows/Python%20package/badge.svg)](https://github.com/facebookincubator/flowtorch/actions?query=workflow%3A%22Python+package%22)
Copyright © Meta Platforms, Inc
This source code is licensed under the MIT license found in the
[LICENSE.txt](https://github.com/facebookincubator/flowtorch/blob/main/LICENSE.txt) file in the root directory of this source tree.
# Overview
FlowTorch is a PyTorch library for learning and sampling from complex probability distributions using a class of methods called [Normalizing Flows](https://arxiv.org/abs/1908.09257).
# Installing
An easy way to get started is to install from source:
git clone https://github.com/facebookincubator/flowtorch.git
cd flowtorch
pip install -e .
# Further Information
We refer you to the [FlowTorch website](https://flowtorch.ai) for more information about installation, using the library, and becoming a contributor. Here is a handy guide:
* [What are normalizing flows?](https://flowtorch.ai/users)
* [How do I install FlowTorch?](https://flowtorch.ai/users/installation)
* [How do I construct and train a distribution?](https://flowtorch.ai/users/start)
* [How do I contribute new normalizing flow methods?](https://flowtorch.ai/dev)
* [Where can I report bugs?](https://github.com/facebookincubator/flowtorch/issues)
* [Where can I ask general questions and make feature requests?](https://github.com/facebookincubator/flowtorch/discussions)
* [What features are planned for the near future?](https://github.com/facebookincubator/flowtorch/projects)
%package -n python3-flowtorch
Summary: Normalizing Flows for PyTorch
Provides: python-flowtorch
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-flowtorch
![](https://github.com/facebookincubator/flowtorch/raw/main/website/static/img/logo.svg)
[![](https://github.com/facebookincubator/flowtorch/workflows/Python%20package/badge.svg)](https://github.com/facebookincubator/flowtorch/actions?query=workflow%3A%22Python+package%22)
Copyright © Meta Platforms, Inc
This source code is licensed under the MIT license found in the
[LICENSE.txt](https://github.com/facebookincubator/flowtorch/blob/main/LICENSE.txt) file in the root directory of this source tree.
# Overview
FlowTorch is a PyTorch library for learning and sampling from complex probability distributions using a class of methods called [Normalizing Flows](https://arxiv.org/abs/1908.09257).
# Installing
An easy way to get started is to install from source:
git clone https://github.com/facebookincubator/flowtorch.git
cd flowtorch
pip install -e .
# Further Information
We refer you to the [FlowTorch website](https://flowtorch.ai) for more information about installation, using the library, and becoming a contributor. Here is a handy guide:
* [What are normalizing flows?](https://flowtorch.ai/users)
* [How do I install FlowTorch?](https://flowtorch.ai/users/installation)
* [How do I construct and train a distribution?](https://flowtorch.ai/users/start)
* [How do I contribute new normalizing flow methods?](https://flowtorch.ai/dev)
* [Where can I report bugs?](https://github.com/facebookincubator/flowtorch/issues)
* [Where can I ask general questions and make feature requests?](https://github.com/facebookincubator/flowtorch/discussions)
* [What features are planned for the near future?](https://github.com/facebookincubator/flowtorch/projects)
%package help
Summary: Development documents and examples for flowtorch
Provides: python3-flowtorch-doc
%description help
![](https://github.com/facebookincubator/flowtorch/raw/main/website/static/img/logo.svg)
[![](https://github.com/facebookincubator/flowtorch/workflows/Python%20package/badge.svg)](https://github.com/facebookincubator/flowtorch/actions?query=workflow%3A%22Python+package%22)
Copyright © Meta Platforms, Inc
This source code is licensed under the MIT license found in the
[LICENSE.txt](https://github.com/facebookincubator/flowtorch/blob/main/LICENSE.txt) file in the root directory of this source tree.
# Overview
FlowTorch is a PyTorch library for learning and sampling from complex probability distributions using a class of methods called [Normalizing Flows](https://arxiv.org/abs/1908.09257).
# Installing
An easy way to get started is to install from source:
git clone https://github.com/facebookincubator/flowtorch.git
cd flowtorch
pip install -e .
# Further Information
We refer you to the [FlowTorch website](https://flowtorch.ai) for more information about installation, using the library, and becoming a contributor. Here is a handy guide:
* [What are normalizing flows?](https://flowtorch.ai/users)
* [How do I install FlowTorch?](https://flowtorch.ai/users/installation)
* [How do I construct and train a distribution?](https://flowtorch.ai/users/start)
* [How do I contribute new normalizing flow methods?](https://flowtorch.ai/dev)
* [Where can I report bugs?](https://github.com/facebookincubator/flowtorch/issues)
* [Where can I ask general questions and make feature requests?](https://github.com/facebookincubator/flowtorch/discussions)
* [What features are planned for the near future?](https://github.com/facebookincubator/flowtorch/projects)
%prep
%autosetup -n flowtorch-0.8
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-flowtorch -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 31 2023 Python_Bot - 0.8-1
- Package Spec generated