%global _empty_manifest_terminate_build 0
Name: python-vivintpy
Version: 2023.3.3
Release: 1
Summary: Python library for interacting with a Vivint security and smart home system.
License: MIT
URL: https://github.com/natekspencer/vivintpy
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/d5/21/14c9773b61f865729923d666ef13fbdb9c685014ae0975351af37a0683d6/vivintpy-2023.3.3.tar.gz
BuildArch: noarch
Requires: python3-aiohttp
Requires: python3-certifi
Requires: python3-pubnub
Requires: python3-grpcio
Requires: python3-protobuf
%description
## Support Me
I'm not employed by Vivint, and provide this python package as-is.
If you don't already own a Vivint system, please consider using [my referal code (kaf164)](https://www.vivint.com/get?refCode=kaf164&exid=165211vivint.com/get?refCode=kaf164&exid=165211) to get $50 off your bill (as well as a tip to me in appreciation)!
If you already own a Vivint system and still want to donate, consider buying me a coffee ☕ (or beer 🍺) instead by using the link below:
%package -n python3-vivintpy
Summary: Python library for interacting with a Vivint security and smart home system.
Provides: python-vivintpy
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-vivintpy
## Support Me
I'm not employed by Vivint, and provide this python package as-is.
If you don't already own a Vivint system, please consider using [my referal code (kaf164)](https://www.vivint.com/get?refCode=kaf164&exid=165211vivint.com/get?refCode=kaf164&exid=165211) to get $50 off your bill (as well as a tip to me in appreciation)!
If you already own a Vivint system and still want to donate, consider buying me a coffee ☕ (or beer 🍺) instead by using the link below:
%package help
Summary: Development documents and examples for vivintpy
Provides: python3-vivintpy-doc
%description help
## Support Me
I'm not employed by Vivint, and provide this python package as-is.
If you don't already own a Vivint system, please consider using [my referal code (kaf164)](https://www.vivint.com/get?refCode=kaf164&exid=165211vivint.com/get?refCode=kaf164&exid=165211) to get $50 off your bill (as well as a tip to me in appreciation)!
If you already own a Vivint system and still want to donate, consider buying me a coffee ☕ (or beer 🍺) instead by using the link below:
%prep
%autosetup -n vivintpy-2023.3.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-vivintpy -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 31 2023 Python_Bot - 2023.3.3-1
- Package Spec generated