%global _empty_manifest_terminate_build 0
Name: python-picharsso
Version: 2.0.1
Release: 1
Summary: A utility for converting images to text art.
License: MIT
URL: https://pypi.org/project/picharsso/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ca/50/550f3ef989e6dfc4346422569508ea46e11c3046d05ed08b2708d963b48e/picharsso-2.0.1.tar.gz
BuildArch: noarch
Requires: python3-click
Requires: python3-numpy
Requires: python3-pillow
Requires: python3-sty
%description
# Picharsso
A utility for converting images to text art.
Installation
|
Documentation
|
Examples
|
Contributing
## Installation
Run the following command:
```bash
pip install picharsso
```
This will:
- download and install the [`picharsso` Python package](https://pypi.org/project/picharsso/)
(along with its dependencies).
- create an executable, `picharsso`, for the CLI (command line interface).
> **Verification**
>
> To verify that Picharsso is installed, run:
>
> ```bash
> python -c "import picharsso"
> ```
## Commands
Picharsso ships with a CLI that provides some basic functionality from the terminal.
> **Usage**
>
> Run the following command to display a helpful message:
>
> ```bash
> picharsso -h
> ```
>
> ```
> Usage: picharsso [options] [args]
>
> A utility for converting images to text art.
>
> Options:
> -h, --help Show this message and exit.
>
> Commands:
> draw Generate text art from an image.
> info Displays package information.
> ```
Consider the following image:
Apple Computer [Rob Janoff, 1977]
To convert an image to text art, run:
```bash
picharsso draw -c -H 32 gradient
```
Here's what it should look like:
> **Breakdown**
>
> | Argument | Effect |
> | :--------: | :------------------------------------------------------------------------------------ |
> | `-c` | Apply **image colors** to the output text. |
> | `-H 32` | Sets the **number of lines** of the output text to `32`. |
> | `gradient` | Use the [gradient style](https://kelvindecosta.github.io/picharsso/styles/gradient/). |
>
> Don't forget to replace ``.
Refer to the [CLI documentation](https://kelvindecosta.github.io/picharsso/commands/) to learn about the various **commands** and **arguments**.
## Library
The example from the previous section can be implemented in just a few lines of Python:
```python
from PIL import Image
from picharsso import new_drawer
if __name__ == "__main__":
# Open image
image = Image.open("")
# Define drawer
drawer = new_drawer("braille", height=32, colorize=True)
# Print drawer output
print(drawer(image))
```
Here's what it should look like:
> **Styles**
>
> Refer to the [Styles documentation](https://kelvindecosta.github.io/picharsso/styles/) for an in-depth guide to the **image processing behind Picharsso**.
Now consider this animated GIF:
Nyan Cat
With some more lines of code, you can animate GIFs in text!
```python
import time
from PIL import Image
from picharsso import new_drawer
from picharsso.utils import clear_screen, terminal_size
if __name__ == "__main__":
# Open image
image = Image.open("")
# Get terminal height
height, _ = terminal_size()
# Define drawer
drawer = new_drawer("braille", height=height, colorize=True, threshold=0)
# Iterate over frames
texts = []
for frame_id in range(image.n_frames):
# Select frame
image.seek(frame_id)
# Save output for frame
texts.append(drawer(image))
# Iterate over saved outputs in a circular manner
num_frames = len(texts)
counter = 0
while True:
# Refresh
clear_screen()
# Print output
print(texts[counter])
# Set a delay between frames
time.sleep(1 / num_frames)
# Circular increment
counter = (counter + 1) % num_frames
```
Here's what it should look like:
Refer to the [API documentation](https://kelvindecosta.github.io/picharsso/library/draw/) to learn about the various **classes** and **functions**.
> **Examples**
>
> Check out some more [examples](https://kelvindecosta.github.io/picharsso/examples/01-image/).
>
> You can use an image [directly from the web](https://kelvindecosta.github.io/picharsso/examples/03-web/) too!
## Contributing
Do you have a feature request, bug report, or patch? Great!
Check out the [contributing guidelines](https://github.com/kelvindecosta/picharsso/blob/master/CONTRIBUTING.md)!
## License
Copyright (c) 2019 Kelvin DeCosta.
Released under the MIT License.
See [LICENSE](https://github.com/kelvindecosta/picharsso/blob/master/LICENSE) for details.
%package -n python3-picharsso
Summary: A utility for converting images to text art.
Provides: python-picharsso
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-picharsso
# Picharsso
A utility for converting images to text art.
Installation
|
Documentation
|
Examples
|
Contributing
## Installation
Run the following command:
```bash
pip install picharsso
```
This will:
- download and install the [`picharsso` Python package](https://pypi.org/project/picharsso/)
(along with its dependencies).
- create an executable, `picharsso`, for the CLI (command line interface).
> **Verification**
>
> To verify that Picharsso is installed, run:
>
> ```bash
> python -c "import picharsso"
> ```
## Commands
Picharsso ships with a CLI that provides some basic functionality from the terminal.
> **Usage**
>
> Run the following command to display a helpful message:
>
> ```bash
> picharsso -h
> ```
>
> ```
> Usage: picharsso [options] [args]
>
> A utility for converting images to text art.
>
> Options:
> -h, --help Show this message and exit.
>
> Commands:
> draw Generate text art from an image.
> info Displays package information.
> ```
Consider the following image:
Apple Computer [Rob Janoff, 1977]
To convert an image to text art, run:
```bash
picharsso draw -c -H 32 gradient
```
Here's what it should look like:
> **Breakdown**
>
> | Argument | Effect |
> | :--------: | :------------------------------------------------------------------------------------ |
> | `-c` | Apply **image colors** to the output text. |
> | `-H 32` | Sets the **number of lines** of the output text to `32`. |
> | `gradient` | Use the [gradient style](https://kelvindecosta.github.io/picharsso/styles/gradient/). |
>
> Don't forget to replace ``.
Refer to the [CLI documentation](https://kelvindecosta.github.io/picharsso/commands/) to learn about the various **commands** and **arguments**.
## Library
The example from the previous section can be implemented in just a few lines of Python:
```python
from PIL import Image
from picharsso import new_drawer
if __name__ == "__main__":
# Open image
image = Image.open("")
# Define drawer
drawer = new_drawer("braille", height=32, colorize=True)
# Print drawer output
print(drawer(image))
```
Here's what it should look like:
> **Styles**
>
> Refer to the [Styles documentation](https://kelvindecosta.github.io/picharsso/styles/) for an in-depth guide to the **image processing behind Picharsso**.
Now consider this animated GIF:
Nyan Cat
With some more lines of code, you can animate GIFs in text!
```python
import time
from PIL import Image
from picharsso import new_drawer
from picharsso.utils import clear_screen, terminal_size
if __name__ == "__main__":
# Open image
image = Image.open("")
# Get terminal height
height, _ = terminal_size()
# Define drawer
drawer = new_drawer("braille", height=height, colorize=True, threshold=0)
# Iterate over frames
texts = []
for frame_id in range(image.n_frames):
# Select frame
image.seek(frame_id)
# Save output for frame
texts.append(drawer(image))
# Iterate over saved outputs in a circular manner
num_frames = len(texts)
counter = 0
while True:
# Refresh
clear_screen()
# Print output
print(texts[counter])
# Set a delay between frames
time.sleep(1 / num_frames)
# Circular increment
counter = (counter + 1) % num_frames
```
Here's what it should look like:
Refer to the [API documentation](https://kelvindecosta.github.io/picharsso/library/draw/) to learn about the various **classes** and **functions**.
> **Examples**
>
> Check out some more [examples](https://kelvindecosta.github.io/picharsso/examples/01-image/).
>
> You can use an image [directly from the web](https://kelvindecosta.github.io/picharsso/examples/03-web/) too!
## Contributing
Do you have a feature request, bug report, or patch? Great!
Check out the [contributing guidelines](https://github.com/kelvindecosta/picharsso/blob/master/CONTRIBUTING.md)!
## License
Copyright (c) 2019 Kelvin DeCosta.
Released under the MIT License.
See [LICENSE](https://github.com/kelvindecosta/picharsso/blob/master/LICENSE) for details.
%package help
Summary: Development documents and examples for picharsso
Provides: python3-picharsso-doc
%description help
# Picharsso
A utility for converting images to text art.
Installation
|
Documentation
|
Examples
|
Contributing
## Installation
Run the following command:
```bash
pip install picharsso
```
This will:
- download and install the [`picharsso` Python package](https://pypi.org/project/picharsso/)
(along with its dependencies).
- create an executable, `picharsso`, for the CLI (command line interface).
> **Verification**
>
> To verify that Picharsso is installed, run:
>
> ```bash
> python -c "import picharsso"
> ```
## Commands
Picharsso ships with a CLI that provides some basic functionality from the terminal.
> **Usage**
>
> Run the following command to display a helpful message:
>
> ```bash
> picharsso -h
> ```
>
> ```
> Usage: picharsso [options] [args]
>
> A utility for converting images to text art.
>
> Options:
> -h, --help Show this message and exit.
>
> Commands:
> draw Generate text art from an image.
> info Displays package information.
> ```
Consider the following image:
Apple Computer [Rob Janoff, 1977]
To convert an image to text art, run:
```bash
picharsso draw -c -H 32 gradient
```
Here's what it should look like:
> **Breakdown**
>
> | Argument | Effect |
> | :--------: | :------------------------------------------------------------------------------------ |
> | `-c` | Apply **image colors** to the output text. |
> | `-H 32` | Sets the **number of lines** of the output text to `32`. |
> | `gradient` | Use the [gradient style](https://kelvindecosta.github.io/picharsso/styles/gradient/). |
>
> Don't forget to replace ``.
Refer to the [CLI documentation](https://kelvindecosta.github.io/picharsso/commands/) to learn about the various **commands** and **arguments**.
## Library
The example from the previous section can be implemented in just a few lines of Python:
```python
from PIL import Image
from picharsso import new_drawer
if __name__ == "__main__":
# Open image
image = Image.open("")
# Define drawer
drawer = new_drawer("braille", height=32, colorize=True)
# Print drawer output
print(drawer(image))
```
Here's what it should look like:
> **Styles**
>
> Refer to the [Styles documentation](https://kelvindecosta.github.io/picharsso/styles/) for an in-depth guide to the **image processing behind Picharsso**.
Now consider this animated GIF:
Nyan Cat
With some more lines of code, you can animate GIFs in text!
```python
import time
from PIL import Image
from picharsso import new_drawer
from picharsso.utils import clear_screen, terminal_size
if __name__ == "__main__":
# Open image
image = Image.open("")
# Get terminal height
height, _ = terminal_size()
# Define drawer
drawer = new_drawer("braille", height=height, colorize=True, threshold=0)
# Iterate over frames
texts = []
for frame_id in range(image.n_frames):
# Select frame
image.seek(frame_id)
# Save output for frame
texts.append(drawer(image))
# Iterate over saved outputs in a circular manner
num_frames = len(texts)
counter = 0
while True:
# Refresh
clear_screen()
# Print output
print(texts[counter])
# Set a delay between frames
time.sleep(1 / num_frames)
# Circular increment
counter = (counter + 1) % num_frames
```
Here's what it should look like:
Refer to the [API documentation](https://kelvindecosta.github.io/picharsso/library/draw/) to learn about the various **classes** and **functions**.
> **Examples**
>
> Check out some more [examples](https://kelvindecosta.github.io/picharsso/examples/01-image/).
>
> You can use an image [directly from the web](https://kelvindecosta.github.io/picharsso/examples/03-web/) too!
## Contributing
Do you have a feature request, bug report, or patch? Great!
Check out the [contributing guidelines](https://github.com/kelvindecosta/picharsso/blob/master/CONTRIBUTING.md)!
## License
Copyright (c) 2019 Kelvin DeCosta.
Released under the MIT License.
See [LICENSE](https://github.com/kelvindecosta/picharsso/blob/master/LICENSE) for details.
%prep
%autosetup -n picharsso-2.0.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-picharsso -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 31 2023 Python_Bot - 2.0.1-1
- Package Spec generated