%global _empty_manifest_terminate_build 0
Name: python-juniperSNMPv3crypt
Version: 0.0.5
Release: 1
Summary: Encrypt/decrypts juniper $9$ secrets
License: MIT License
URL: https://github.com/zach-bray/junipercrypt
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/72/b2/c0bd10c010d46518083106353c1c8682d29b6e2ab96030445f2b38bafaa2/juniperSNMPv3crypt-0.0.5.tar.gz
BuildArch: noarch
%description
# juniper SNMPv3 crypt
This is python library to deal with hashing (md5 or sha1) and then encrypting SNMPv3 user profiles for Juniper devices. The hashing follows RFC 3414 for snmpv3 profiles.
The $9$ encryption is a port from Perl from https://metacpan.org/pod/Crypt::Juniper
The encrypt function supports a seed in order to have idempotent encryption.
### Install
This package works in both python 2 and 3
`pip install juniperSNMPv3crypt`
%package -n python3-juniperSNMPv3crypt
Summary: Encrypt/decrypts juniper $9$ secrets
Provides: python-juniperSNMPv3crypt
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-juniperSNMPv3crypt
# juniper SNMPv3 crypt
This is python library to deal with hashing (md5 or sha1) and then encrypting SNMPv3 user profiles for Juniper devices. The hashing follows RFC 3414 for snmpv3 profiles.
The $9$ encryption is a port from Perl from https://metacpan.org/pod/Crypt::Juniper
The encrypt function supports a seed in order to have idempotent encryption.
### Install
This package works in both python 2 and 3
`pip install juniperSNMPv3crypt`
%package help
Summary: Development documents and examples for juniperSNMPv3crypt
Provides: python3-juniperSNMPv3crypt-doc
%description help
# juniper SNMPv3 crypt
This is python library to deal with hashing (md5 or sha1) and then encrypting SNMPv3 user profiles for Juniper devices. The hashing follows RFC 3414 for snmpv3 profiles.
The $9$ encryption is a port from Perl from https://metacpan.org/pod/Crypt::Juniper
The encrypt function supports a seed in order to have idempotent encryption.
### Install
This package works in both python 2 and 3
`pip install juniperSNMPv3crypt`
%prep
%autosetup -n juniperSNMPv3crypt-0.0.5
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-juniperSNMPv3crypt -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 31 2023 Python_Bot - 0.0.5-1
- Package Spec generated