%global _empty_manifest_terminate_build 0 Name: python-BMPM Version: 3.2.1 Release: 1 Summary: A program for bulk replacement of BYML map file parameters. License: MIT License URL: https://github.com/SDarkMagic/BMPM-BOTWMapTool Source0: https://mirrors.nju.edu.cn/pypi/web/packages/c9/ef/c4bcb4363b5cb93e18da0ef73589f4e774661c450f74ef6f809e9f8ea61b/BMPM-3.2.1.tar.gz BuildArch: noarch %description # BMPM (Botw Map Parameter Manipulator) A script for manipulating parameters contained within BotW's map files in bulk. # Installation Copy the ".exe" file to C:/Users/(username)/AppData/local/Programs/Python/scripts/ OR add the directory containing the compiled script to your PATH (Please note that the exe is not up to date)
OR
Use the command "pip install bmpm" from the cli to automatically install the and setup necessarry files
OR
Download a zip of the code and run "python setup.py install" from the cli within the directory containing the files to install and setup the files # Usage The batch (currently outdated) file included is for recursively going through directories and editing all "LevelSensorMode" parameters to 1 To delete an actor or set of actors, use `bmpm delete`; for editing paramaters, use `bmpm edit`. For more information on how to use the script, type "bmpm -h" or "bmpm --help" # To-Do Create UI
~~Implement recursive file handling~~
Option to delete all actors linked to one being deleted.
~~Add option for big endian so that the wiiU/Cemu plebs can also use the tool~~ %package -n python3-BMPM Summary: A program for bulk replacement of BYML map file parameters. Provides: python-BMPM BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-BMPM # BMPM (Botw Map Parameter Manipulator) A script for manipulating parameters contained within BotW's map files in bulk. # Installation Copy the ".exe" file to C:/Users/(username)/AppData/local/Programs/Python/scripts/ OR add the directory containing the compiled script to your PATH (Please note that the exe is not up to date)
OR
Use the command "pip install bmpm" from the cli to automatically install the and setup necessarry files
OR
Download a zip of the code and run "python setup.py install" from the cli within the directory containing the files to install and setup the files # Usage The batch (currently outdated) file included is for recursively going through directories and editing all "LevelSensorMode" parameters to 1 To delete an actor or set of actors, use `bmpm delete`; for editing paramaters, use `bmpm edit`. For more information on how to use the script, type "bmpm -h" or "bmpm --help" # To-Do Create UI
~~Implement recursive file handling~~
Option to delete all actors linked to one being deleted.
~~Add option for big endian so that the wiiU/Cemu plebs can also use the tool~~ %package help Summary: Development documents and examples for BMPM Provides: python3-BMPM-doc %description help # BMPM (Botw Map Parameter Manipulator) A script for manipulating parameters contained within BotW's map files in bulk. # Installation Copy the ".exe" file to C:/Users/(username)/AppData/local/Programs/Python/scripts/ OR add the directory containing the compiled script to your PATH (Please note that the exe is not up to date)
OR
Use the command "pip install bmpm" from the cli to automatically install the and setup necessarry files
OR
Download a zip of the code and run "python setup.py install" from the cli within the directory containing the files to install and setup the files # Usage The batch (currently outdated) file included is for recursively going through directories and editing all "LevelSensorMode" parameters to 1 To delete an actor or set of actors, use `bmpm delete`; for editing paramaters, use `bmpm edit`. For more information on how to use the script, type "bmpm -h" or "bmpm --help" # To-Do Create UI
~~Implement recursive file handling~~
Option to delete all actors linked to one being deleted.
~~Add option for big endian so that the wiiU/Cemu plebs can also use the tool~~ %prep %autosetup -n BMPM-3.2.1 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-BMPM -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Wed May 31 2023 Python_Bot - 3.2.1-1 - Package Spec generated