%global _empty_manifest_terminate_build 0
Name: python-JuliaLintBear
Version: 0.10.0
Release: 1
Summary: 'JuliaLintBear' bear for coala (http://coala.rtfd.org/)
License: AGPL-3.0
URL: https://pypi.org/project/JuliaLintBear/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/3c/48/cff11f491b694009458b526a67016662a0fee91381618a293b8d7a260144/JuliaLintBear-0.10.0.tar.gz
BuildArch: noarch
%description
Provide analysis related to common bugs and potential issues in Julia like
dead code, undefined variable usage, duplicate keys in dicts, incorrect
ADT usage, wrongfully using ellipsis, and much more.
See for more information
on the analysis provided.
%package -n python3-JuliaLintBear
Summary: 'JuliaLintBear' bear for coala (http://coala.rtfd.org/)
Provides: python-JuliaLintBear
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-JuliaLintBear
Provide analysis related to common bugs and potential issues in Julia like
dead code, undefined variable usage, duplicate keys in dicts, incorrect
ADT usage, wrongfully using ellipsis, and much more.
See for more information
on the analysis provided.
%package help
Summary: Development documents and examples for JuliaLintBear
Provides: python3-JuliaLintBear-doc
%description help
Provide analysis related to common bugs and potential issues in Julia like
dead code, undefined variable usage, duplicate keys in dicts, incorrect
ADT usage, wrongfully using ellipsis, and much more.
See for more information
on the analysis provided.
%prep
%autosetup -n JuliaLintBear-0.10.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-JuliaLintBear -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 31 2023 Python_Bot - 0.10.0-1
- Package Spec generated