%global _empty_manifest_terminate_build 0
Name: python-brainstat
Version: 0.4.2
Release: 1
Summary: A toolbox for statistical analysis of neuroimaging data
License: BSD 3-Clause License
URL: https://github.com/MICA-LAB/BrainStat
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/3d/f2/5579782e88d8356a96533d8db693b46c073423ca702140aa61c01b5d1211/brainstat-0.4.2.tar.gz
BuildArch: noarch
Requires: python3-abagen
Requires: python3-brainspace
Requires: python3-h5py
Requires: python3-netneurotools
Requires: python3-neurosynth
Requires: python3-nibabel
Requires: python3-nilearn
Requires: python3-nimare
Requires: python3-numpy
Requires: python3-pandas
Requires: python3-scikit-learn
Requires: python3-scipy
Requires: python3-templateflow
Requires: python3-trimesh
Requires: python3-gitpython
Requires: python3-hcp-utils
Requires: python3-mypy
Requires: python3-plotly
Requires: python3-pytest
%description
Welcome to BrainStat's documentation!
BrainStat is a toolbox for the statistical analysis and context decoding of
neuroimaging data. It implements both univariate and multivariate linear models
and interfaces with the BigBrain Atlas, Allen Human Brain Atlas and Nimare
databases. BrainStat flexibly handles common surface, volume, and parcel level
data formats, and provides a series of interactive visualization functions. The
toolbox has been implemented in both Python and MATLAB, the two most widely
adopted programming languages in the neuroimaging and neuroinformatics
communities. It is openly available, and documented `here
`_.
For some reason referencing the BrainStat image locally doesn't work, so
just linking to the image on Github instead.
%package -n python3-brainstat
Summary: A toolbox for statistical analysis of neuroimaging data
Provides: python-brainstat
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-brainstat
Welcome to BrainStat's documentation!
BrainStat is a toolbox for the statistical analysis and context decoding of
neuroimaging data. It implements both univariate and multivariate linear models
and interfaces with the BigBrain Atlas, Allen Human Brain Atlas and Nimare
databases. BrainStat flexibly handles common surface, volume, and parcel level
data formats, and provides a series of interactive visualization functions. The
toolbox has been implemented in both Python and MATLAB, the two most widely
adopted programming languages in the neuroimaging and neuroinformatics
communities. It is openly available, and documented `here
`_.
For some reason referencing the BrainStat image locally doesn't work, so
just linking to the image on Github instead.
%package help
Summary: Development documents and examples for brainstat
Provides: python3-brainstat-doc
%description help
Welcome to BrainStat's documentation!
BrainStat is a toolbox for the statistical analysis and context decoding of
neuroimaging data. It implements both univariate and multivariate linear models
and interfaces with the BigBrain Atlas, Allen Human Brain Atlas and Nimare
databases. BrainStat flexibly handles common surface, volume, and parcel level
data formats, and provides a series of interactive visualization functions. The
toolbox has been implemented in both Python and MATLAB, the two most widely
adopted programming languages in the neuroimaging and neuroinformatics
communities. It is openly available, and documented `here
`_.
For some reason referencing the BrainStat image locally doesn't work, so
just linking to the image on Github instead.
%prep
%autosetup -n brainstat-0.4.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-brainstat -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 31 2023 Python_Bot - 0.4.2-1
- Package Spec generated