%global _empty_manifest_terminate_build 0
Name: python-vk-botting
Version: 0.11.4
Release: 1
Summary: A basic package for building async VK bots
License: MIT
URL: https://github.com/MrDandycorn/vk-botting
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/f4/21/eb5f98d013cc08db865934c3245e742d5930688506f650bf46a6dba524c2/vk-botting-0.11.4.tar.gz
BuildArch: noarch
Requires: python3-aiohttp
Requires: python3-sphinx
Requires: python3-sphinxcontrib-websupport
Requires: python3-sphinxcontrib-trio
%description
# VK-Botting
[![Documentation Status](https://readthedocs.org/projects/vk-botting/badge/?version=latest)](https://vk-botting.readthedocs.io/en/latest/?badge=latest)
vk_botting is a package for building async VK bots.
It is in development so it can be buggy or not implement all latest features of VK API.
That is also why it does not have full documentation atm.
Partial docs: [Russian](https://vk-botting.readthedocs.io/ru/latest) or [English](https://vk-botting.readthedocs.io/en/latest).
For any questions, suggestions or reports, use either [Telegram chat](https://t.me/vk_botting) or [GitHub Issues](https://github.com/MrDandycorn/vk-botting/issues).
vk_botting - библиотека для создания асинхронных ботов для ВК.
Она все еще в разработке, так что в некоторых местах может содержать баги, или же не полностью реализовывать все последние возможности VK API.
По той же причине у нее на данный момент может не быть исчерпывающей документации.
Частичная документация: [На русском](https://vk-botting.readthedocs.io/ru/latest) или [На английском](https://vk-botting.readthedocs.io/en/latest).
Со всеми вопросами, предложениями и проблемами можете обращаться либо в [Чат Telegram](https://t.me/vk_botting), либо в [Раздел Issues на GitHub](https://github.com/MrDandycorn/vk-botting/issues).
%package -n python3-vk-botting
Summary: A basic package for building async VK bots
Provides: python-vk-botting
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-vk-botting
# VK-Botting
[![Documentation Status](https://readthedocs.org/projects/vk-botting/badge/?version=latest)](https://vk-botting.readthedocs.io/en/latest/?badge=latest)
vk_botting is a package for building async VK bots.
It is in development so it can be buggy or not implement all latest features of VK API.
That is also why it does not have full documentation atm.
Partial docs: [Russian](https://vk-botting.readthedocs.io/ru/latest) or [English](https://vk-botting.readthedocs.io/en/latest).
For any questions, suggestions or reports, use either [Telegram chat](https://t.me/vk_botting) or [GitHub Issues](https://github.com/MrDandycorn/vk-botting/issues).
vk_botting - библиотека для создания асинхронных ботов для ВК.
Она все еще в разработке, так что в некоторых местах может содержать баги, или же не полностью реализовывать все последние возможности VK API.
По той же причине у нее на данный момент может не быть исчерпывающей документации.
Частичная документация: [На русском](https://vk-botting.readthedocs.io/ru/latest) или [На английском](https://vk-botting.readthedocs.io/en/latest).
Со всеми вопросами, предложениями и проблемами можете обращаться либо в [Чат Telegram](https://t.me/vk_botting), либо в [Раздел Issues на GitHub](https://github.com/MrDandycorn/vk-botting/issues).
%package help
Summary: Development documents and examples for vk-botting
Provides: python3-vk-botting-doc
%description help
# VK-Botting
[![Documentation Status](https://readthedocs.org/projects/vk-botting/badge/?version=latest)](https://vk-botting.readthedocs.io/en/latest/?badge=latest)
vk_botting is a package for building async VK bots.
It is in development so it can be buggy or not implement all latest features of VK API.
That is also why it does not have full documentation atm.
Partial docs: [Russian](https://vk-botting.readthedocs.io/ru/latest) or [English](https://vk-botting.readthedocs.io/en/latest).
For any questions, suggestions or reports, use either [Telegram chat](https://t.me/vk_botting) or [GitHub Issues](https://github.com/MrDandycorn/vk-botting/issues).
vk_botting - библиотека для создания асинхронных ботов для ВК.
Она все еще в разработке, так что в некоторых местах может содержать баги, или же не полностью реализовывать все последние возможности VK API.
По той же причине у нее на данный момент может не быть исчерпывающей документации.
Частичная документация: [На русском](https://vk-botting.readthedocs.io/ru/latest) или [На английском](https://vk-botting.readthedocs.io/en/latest).
Со всеми вопросами, предложениями и проблемами можете обращаться либо в [Чат Telegram](https://t.me/vk_botting), либо в [Раздел Issues на GitHub](https://github.com/MrDandycorn/vk-botting/issues).
%prep
%autosetup -n vk-botting-0.11.4
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-vk-botting -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 31 2023 Python_Bot - 0.11.4-1
- Package Spec generated