%global _empty_manifest_terminate_build 0
Name: python-pipetools
Version: 1.1.0
Release: 1
Summary: A library that enables function composition similar to using Unix pipes.
License: MIT
URL: https://0101.github.io/pipetools/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/19/04/88ecb4bdb72760929ebcb48d0ab5016f123d7cfa73564d83841bcc0114b6/pipetools-1.1.0.tar.gz
BuildArch: noarch
%description
|tests-badge| |coverage-badge| |pypi-badge|
`Complete documentation `_
``pipetools`` enables function composition similar to using Unix pipes.
It allows forward-composition and piping of arbitrary functions - no need to decorate them or do anything extra.
It also packs a bunch of utils that make common operations more convenient and readable.
Source is on github_.
%package -n python3-pipetools
Summary: A library that enables function composition similar to using Unix pipes.
Provides: python-pipetools
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pipetools
|tests-badge| |coverage-badge| |pypi-badge|
`Complete documentation `_
``pipetools`` enables function composition similar to using Unix pipes.
It allows forward-composition and piping of arbitrary functions - no need to decorate them or do anything extra.
It also packs a bunch of utils that make common operations more convenient and readable.
Source is on github_.
%package help
Summary: Development documents and examples for pipetools
Provides: python3-pipetools-doc
%description help
|tests-badge| |coverage-badge| |pypi-badge|
`Complete documentation `_
``pipetools`` enables function composition similar to using Unix pipes.
It allows forward-composition and piping of arbitrary functions - no need to decorate them or do anything extra.
It also packs a bunch of utils that make common operations more convenient and readable.
Source is on github_.
%prep
%autosetup -n pipetools-1.1.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pipetools -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 1.1.0-1
- Package Spec generated