%global _empty_manifest_terminate_build 0
Name: python-logging-gelf
Version: 0.0.26
Release: 1
Summary: Logging bundle to send logs using GELF
License: BSD
URL: https://github.com/ovh/python-logging-gelf
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/a6/72/b42f95515f80febce3c126624e9fd92b5430bd9097dcef204b8b7ab3f99d/logging-gelf-0.0.26.tar.gz
BuildArch: noarch
%description
First, install logging-gelf using `pip `_::
pip install -U logging-gelf
The following example shows how to send log in Graylog TCP input
import logging
from logging_gelf.formatters import GELFFormatter
from logging_gelf.handlers import GELFTCPSocketHandler
logger = logging.getLogger("gelf")
logger.setLevel(logging.DEBUG)
handler = GELFTCPSocketHandler(host="127.0.0.1", port=12201)
handler.setFormatter(GELFFormatter(null_character=True))
logger.addHandler(handler)
logger.debug("hello !")
%package -n python3-logging-gelf
Summary: Logging bundle to send logs using GELF
Provides: python-logging-gelf
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-logging-gelf
First, install logging-gelf using `pip `_::
pip install -U logging-gelf
The following example shows how to send log in Graylog TCP input
import logging
from logging_gelf.formatters import GELFFormatter
from logging_gelf.handlers import GELFTCPSocketHandler
logger = logging.getLogger("gelf")
logger.setLevel(logging.DEBUG)
handler = GELFTCPSocketHandler(host="127.0.0.1", port=12201)
handler.setFormatter(GELFFormatter(null_character=True))
logger.addHandler(handler)
logger.debug("hello !")
%package help
Summary: Development documents and examples for logging-gelf
Provides: python3-logging-gelf-doc
%description help
First, install logging-gelf using `pip `_::
pip install -U logging-gelf
The following example shows how to send log in Graylog TCP input
import logging
from logging_gelf.formatters import GELFFormatter
from logging_gelf.handlers import GELFTCPSocketHandler
logger = logging.getLogger("gelf")
logger.setLevel(logging.DEBUG)
handler = GELFTCPSocketHandler(host="127.0.0.1", port=12201)
handler.setFormatter(GELFFormatter(null_character=True))
logger.addHandler(handler)
logger.debug("hello !")
%prep
%autosetup -n logging-gelf-0.0.26
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-logging-gelf -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 0.0.26-1
- Package Spec generated