%global _empty_manifest_terminate_build 0
Name: python-gengo
Version: 1.0.0
Release: 1
Summary: Official Python library for interfacing with the Gengo API.
License: New BSD License
URL: https://github.com/gengo/gengo-python
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/36/be/a1afdaf33dc613076f14d175ec59bf6d7a43ce25ac81086dc695b2e04790/gengo-1.0.0.tar.gz
BuildArch: noarch
%description
Translating your tools and products helps people all over the world access them; this is, of course, a
somewhat tricky problem to solve. `Gengo `_ is a service that offers human-translation
(which is often of higher quality than machine translation), and an API to manage sending in work and watching
jobs. This is a Python interface to make using the API simpler.
`CHANGELOG is here `_
%package -n python3-gengo
Summary: Official Python library for interfacing with the Gengo API.
Provides: python-gengo
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-gengo
Translating your tools and products helps people all over the world access them; this is, of course, a
somewhat tricky problem to solve. `Gengo `_ is a service that offers human-translation
(which is often of higher quality than machine translation), and an API to manage sending in work and watching
jobs. This is a Python interface to make using the API simpler.
`CHANGELOG is here `_
%package help
Summary: Development documents and examples for gengo
Provides: python3-gengo-doc
%description help
Translating your tools and products helps people all over the world access them; this is, of course, a
somewhat tricky problem to solve. `Gengo `_ is a service that offers human-translation
(which is often of higher quality than machine translation), and an API to manage sending in work and watching
jobs. This is a Python interface to make using the API simpler.
`CHANGELOG is here `_
%prep
%autosetup -n gengo-1.0.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-gengo -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 1.0.0-1
- Package Spec generated