%global _empty_manifest_terminate_build 0
Name: python-telectron
Version: 2.0.70.1
Release: 1
Summary: Telegram MTProto API Client Library and Framework for Python
License: LGPLv3+
URL: https://github.com/telectron
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/4b/34/673057733fd7ab305104850d621b793b02287fd219e2292f8a2f5a18eaae/telectron-2.0.70.1.tar.gz
BuildArch: noarch
Requires: python3-pyaes
Requires: python3-pysocks
%description
Telegram MTProto API Framework for Python
Documentation
•
Releases
•
Community
## telectron
``` python
from telectron import Client, filters
app = Client("my_account")
@app.on_message(filters.private)
async def hello(client, message):
await message.reply_text(f"Hello {message.from_user.mention}")
app.run()
```
**telectron** is a modern, elegant and easy-to-use [Telegram](https://telegram.org/) client library framework written
from the ground up in Python and C. It enables you to easily create custom Telegram client applications for both user
and bot identities (bot API alternative) via the [MTProto API](https://docs.telectron.org/topics/mtproto-vs-botapi).
### Features
- **Easy**: You can install telectron with pip and start building your applications right away.
- **Elegant**: Low-level details are abstracted and re-presented in a much nicer and easier way.
- **Fast**: Crypto parts are boosted up by [TgCrypto](https://github.com/telectron/tgcrypto), a high-performance library
written in pure C.
- **Asynchronous**: Allows both synchronous and asynchronous models to fit all usage needs.
- **Documented**: API methods, types and public interfaces are all [well documented](https://docs.telectron.org).
- **Type-hinted**: Types and methods are all type-hinted, enabling excellent editor support.
- **Updated**, to make use of the latest Telegram API version and features.
- **Bot API-like**: Similar to the Bot API in its simplicity, but much more powerful and detailed.
- **Pluggable**: The Smart Plugin system allows to write components with minimal boilerplate code.
- **Comprehensive**: Execute any advanced action an official client is able to do, and even more.
### Requirements
- Python 3.6 or higher.
- A [Telegram API key](https://docs.telectron.org/intro/setup#api-keys).
### Installing
``` bash
pip3 install telectron
```
### Resources
- The docs contain lots of resources to help you get started with telectron: https://docs.telectron.org.
- Seeking extra help? Come join and ask our community: https://t.me/telectron.
- For other kind of inquiries, you can send a [message](https://t.me/haskell) or an [e-mail](mailto:dan@telectron.org).
### Copyright & License
- Copyright (C) 2017-2021 Dan <>
- Licensed under the terms of the [GNU Lesser General Public License v3 or later (LGPLv3+)](COPYING.lesser)
%package -n python3-telectron
Summary: Telegram MTProto API Client Library and Framework for Python
Provides: python-telectron
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-telectron
Telegram MTProto API Framework for Python
Documentation
•
Releases
•
Community
## telectron
``` python
from telectron import Client, filters
app = Client("my_account")
@app.on_message(filters.private)
async def hello(client, message):
await message.reply_text(f"Hello {message.from_user.mention}")
app.run()
```
**telectron** is a modern, elegant and easy-to-use [Telegram](https://telegram.org/) client library framework written
from the ground up in Python and C. It enables you to easily create custom Telegram client applications for both user
and bot identities (bot API alternative) via the [MTProto API](https://docs.telectron.org/topics/mtproto-vs-botapi).
### Features
- **Easy**: You can install telectron with pip and start building your applications right away.
- **Elegant**: Low-level details are abstracted and re-presented in a much nicer and easier way.
- **Fast**: Crypto parts are boosted up by [TgCrypto](https://github.com/telectron/tgcrypto), a high-performance library
written in pure C.
- **Asynchronous**: Allows both synchronous and asynchronous models to fit all usage needs.
- **Documented**: API methods, types and public interfaces are all [well documented](https://docs.telectron.org).
- **Type-hinted**: Types and methods are all type-hinted, enabling excellent editor support.
- **Updated**, to make use of the latest Telegram API version and features.
- **Bot API-like**: Similar to the Bot API in its simplicity, but much more powerful and detailed.
- **Pluggable**: The Smart Plugin system allows to write components with minimal boilerplate code.
- **Comprehensive**: Execute any advanced action an official client is able to do, and even more.
### Requirements
- Python 3.6 or higher.
- A [Telegram API key](https://docs.telectron.org/intro/setup#api-keys).
### Installing
``` bash
pip3 install telectron
```
### Resources
- The docs contain lots of resources to help you get started with telectron: https://docs.telectron.org.
- Seeking extra help? Come join and ask our community: https://t.me/telectron.
- For other kind of inquiries, you can send a [message](https://t.me/haskell) or an [e-mail](mailto:dan@telectron.org).
### Copyright & License
- Copyright (C) 2017-2021 Dan <>
- Licensed under the terms of the [GNU Lesser General Public License v3 or later (LGPLv3+)](COPYING.lesser)
%package help
Summary: Development documents and examples for telectron
Provides: python3-telectron-doc
%description help
Telegram MTProto API Framework for Python
Documentation
•
Releases
•
Community
## telectron
``` python
from telectron import Client, filters
app = Client("my_account")
@app.on_message(filters.private)
async def hello(client, message):
await message.reply_text(f"Hello {message.from_user.mention}")
app.run()
```
**telectron** is a modern, elegant and easy-to-use [Telegram](https://telegram.org/) client library framework written
from the ground up in Python and C. It enables you to easily create custom Telegram client applications for both user
and bot identities (bot API alternative) via the [MTProto API](https://docs.telectron.org/topics/mtproto-vs-botapi).
### Features
- **Easy**: You can install telectron with pip and start building your applications right away.
- **Elegant**: Low-level details are abstracted and re-presented in a much nicer and easier way.
- **Fast**: Crypto parts are boosted up by [TgCrypto](https://github.com/telectron/tgcrypto), a high-performance library
written in pure C.
- **Asynchronous**: Allows both synchronous and asynchronous models to fit all usage needs.
- **Documented**: API methods, types and public interfaces are all [well documented](https://docs.telectron.org).
- **Type-hinted**: Types and methods are all type-hinted, enabling excellent editor support.
- **Updated**, to make use of the latest Telegram API version and features.
- **Bot API-like**: Similar to the Bot API in its simplicity, but much more powerful and detailed.
- **Pluggable**: The Smart Plugin system allows to write components with minimal boilerplate code.
- **Comprehensive**: Execute any advanced action an official client is able to do, and even more.
### Requirements
- Python 3.6 or higher.
- A [Telegram API key](https://docs.telectron.org/intro/setup#api-keys).
### Installing
``` bash
pip3 install telectron
```
### Resources
- The docs contain lots of resources to help you get started with telectron: https://docs.telectron.org.
- Seeking extra help? Come join and ask our community: https://t.me/telectron.
- For other kind of inquiries, you can send a [message](https://t.me/haskell) or an [e-mail](mailto:dan@telectron.org).
### Copyright & License
- Copyright (C) 2017-2021 Dan <>
- Licensed under the terms of the [GNU Lesser General Public License v3 or later (LGPLv3+)](COPYING.lesser)
%prep
%autosetup -n telectron-2.0.70.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-telectron -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 2.0.70.1-1
- Package Spec generated