%global _empty_manifest_terminate_build 0
Name: python-neural-compressor
Version: 2.1.1
Release: 1
Summary: Repository of IntelĀ® Neural Compressor
License: Apache 2.0
URL: https://github.com/intel/neural-compressor
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/2b/b8/263f4a2b3f373e6cd31d56d9c8a1cb437c4b91b91b978f9c20d10feb2c26/neural_compressor-2.1.1.tar.gz
BuildArch: noarch
Requires: python3-numpy
Requires: python3-pyyaml
Requires: python3-scikit-learn
Requires: python3-schema
Requires: python3-py-cpuinfo
Requires: python3-pandas
Requires: python3-pycocotools
Requires: python3-opencv-python
Requires: python3-requests
Requires: python3-psutil
Requires: python3-Pillow
Requires: python3-prettytable
Requires: python3-deprecated
%description
An open-source Python library supporting popular model compression techniques on all mainstream deep learning frameworks (TensorFlow, PyTorch, ONNX Runtime, and MXNet)
[![python](https://img.shields.io/badge/python-3.7%2B-blue)](https://github.com/intel/neural-compressor)
[![version](https://img.shields.io/badge/release-2.1-green)](https://github.com/intel/neural-compressor/releases)
[![license](https://img.shields.io/badge/license-Apache%202-blue)](https://github.com/intel/neural-compressor/blob/master/LICENSE)
[![coverage](https://img.shields.io/badge/coverage-85%25-green)](https://github.com/intel/neural-compressor)
[![Downloads](https://static.pepy.tech/personalized-badge/neural-compressor?period=total&units=international_system&left_color=grey&right_color=green&left_text=downloads)](https://pepy.tech/project/neural-compressor)
[Architecture](./docs/source/design.md#architecture) | [Workflow](./docs/source/design.md#workflow) | [Results](./docs/source/validated_model_list.md) | [Examples](./examples/README.md) | [Documentations](https://intel.github.io/neural-compressor)
%package -n python3-neural-compressor
Summary: Repository of IntelĀ® Neural Compressor
Provides: python-neural-compressor
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-neural-compressor
An open-source Python library supporting popular model compression techniques on all mainstream deep learning frameworks (TensorFlow, PyTorch, ONNX Runtime, and MXNet)
[![python](https://img.shields.io/badge/python-3.7%2B-blue)](https://github.com/intel/neural-compressor)
[![version](https://img.shields.io/badge/release-2.1-green)](https://github.com/intel/neural-compressor/releases)
[![license](https://img.shields.io/badge/license-Apache%202-blue)](https://github.com/intel/neural-compressor/blob/master/LICENSE)
[![coverage](https://img.shields.io/badge/coverage-85%25-green)](https://github.com/intel/neural-compressor)
[![Downloads](https://static.pepy.tech/personalized-badge/neural-compressor?period=total&units=international_system&left_color=grey&right_color=green&left_text=downloads)](https://pepy.tech/project/neural-compressor)
[Architecture](./docs/source/design.md#architecture) | [Workflow](./docs/source/design.md#workflow) | [Results](./docs/source/validated_model_list.md) | [Examples](./examples/README.md) | [Documentations](https://intel.github.io/neural-compressor)
%package help
Summary: Development documents and examples for neural-compressor
Provides: python3-neural-compressor-doc
%description help
An open-source Python library supporting popular model compression techniques on all mainstream deep learning frameworks (TensorFlow, PyTorch, ONNX Runtime, and MXNet)
[![python](https://img.shields.io/badge/python-3.7%2B-blue)](https://github.com/intel/neural-compressor)
[![version](https://img.shields.io/badge/release-2.1-green)](https://github.com/intel/neural-compressor/releases)
[![license](https://img.shields.io/badge/license-Apache%202-blue)](https://github.com/intel/neural-compressor/blob/master/LICENSE)
[![coverage](https://img.shields.io/badge/coverage-85%25-green)](https://github.com/intel/neural-compressor)
[![Downloads](https://static.pepy.tech/personalized-badge/neural-compressor?period=total&units=international_system&left_color=grey&right_color=green&left_text=downloads)](https://pepy.tech/project/neural-compressor)
[Architecture](./docs/source/design.md#architecture) | [Workflow](./docs/source/design.md#workflow) | [Results](./docs/source/validated_model_list.md) | [Examples](./examples/README.md) | [Documentations](https://intel.github.io/neural-compressor)
%prep
%autosetup -n neural_compressor-2.1.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-neural-compressor -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 2.1.1-1
- Package Spec generated