%global _empty_manifest_terminate_build 0
Name: python-pylint-report
Version: 2.4.0
Release: 1
Summary: Generates an html report summarizing the results of pylint.
License: Apache 2.0
URL: https://pypi.org/project/pylint-report/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/d2/77/d7cb6b091b54e2ebc98e8b140756ccf2fe2c942befc2bca2fee17620ecfe/pylint_report-2.4.0.tar.gz
BuildArch: noarch
Requires: python3-pylint
Requires: python3-Jinja2
Requires: python3-pandas
Requires: python3-argcomplete
Requires: python3-black
Requires: python3-isort
Requires: python3-pre-commit
Requires: python3-pylint-report[code,docs,test]
Requires: python3-Sphinx
Requires: python3-sphinx-rtd-theme
Requires: python3-sphinxcontrib-jsmath
Requires: python3-sphinxcontrib-websupport
Requires: python3-sphinx-copybutton
Requires: python3-sphinx-inline-tabs
Requires: python3-sphinx-argparse
Requires: python3-furo
Requires: python3-pytest
Requires: python3-coverage
Requires: python3-pytest-reportlog
Requires: python3-pytest-html
%description
Generates an HTML report summarizing the results of `pylint `_.
%package -n python3-pylint-report
Summary: Generates an html report summarizing the results of pylint.
Provides: python-pylint-report
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pylint-report
Generates an HTML report summarizing the results of `pylint `_.
%package help
Summary: Development documents and examples for pylint-report
Provides: python3-pylint-report-doc
%description help
Generates an HTML report summarizing the results of `pylint `_.
%prep
%autosetup -n pylint_report-2.4.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pylint-report -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 2.4.0-1
- Package Spec generated