%global _empty_manifest_terminate_build 0
Name: python-mpl-interactions
Version: 0.23.0
Release: 1
Summary: Matplotlib aware interact functions
License: BSD
URL: https://pypi.org/project/mpl-interactions/
Source0: https://mirrors.aliyun.com/pypi/web/packages/58/b8/f069a5a72d172589b11f11cde88f2f95eee829e76c1c71ee031f68531c25/mpl_interactions-0.23.0.tar.gz
BuildArch: noarch
Requires: python3-matplotlib
Requires: python3-ipywidgets
Requires: python3-ipympl
Requires: python3-jupyter-sphinx
Requires: python3-mpl-playback
Requires: python3-myst-nb
Requires: python3-numpydoc
Requires: python3-Sphinx
Requires: python3-sphinx-book-theme
Requires: python3-sphinx-copybutton
Requires: python3-sphinx-gallery
Requires: python3-sphinx-panels
Requires: python3-sphinx-thebe
Requires: python3-sphinx-togglebutton
Requires: python3-xarray
Requires: python3-black
Requires: python3-isort
Requires: python3-nbval
Requires: python3-pandas
Requires: python3-PyQt5
Requires: python3-pytest
Requires: python3-pytest-mpl
Requires: python3-requests
Requires: python3-scipy
Requires: python3-pre-commit
Requires: python3-sphinx-autobuild
Requires: python3-tox
Requires: python3-ipywidgets
Requires: python3-ipympl
Requires: python3-jupyter-sphinx
Requires: python3-mpl-playback
Requires: python3-myst-nb
Requires: python3-numpydoc
Requires: python3-Sphinx
Requires: python3-sphinx-book-theme
Requires: python3-sphinx-copybutton
Requires: python3-sphinx-gallery
Requires: python3-sphinx-panels
Requires: python3-sphinx-thebe
Requires: python3-sphinx-togglebutton
Requires: python3-xarray
Requires: python3-ipywidgets
Requires: python3-ipympl
Requires: python3-black
Requires: python3-isort
Requires: python3-nbval
Requires: python3-pandas
Requires: python3-PyQt5
Requires: python3-pytest
Requires: python3-pytest-mpl
Requires: python3-requests
Requires: python3-scipy
Requires: python3-xarray
%description
# mpl_interactions
[![All Contributors](https://img.shields.io/badge/all_contributors-10-orange.svg?style=flat-square)](#contributors-)
[![PyPI package](https://badge.fury.io/py/mpl-interactions.svg)](https://pypi.org/project/mpl-interactions)
[![Supported Python versions](https://img.shields.io/pypi/pyversions/mpl-interactions)](https://pypi.org/project/mpl-interactions)
[![Documentation Status](https://readthedocs.org/projects/mpl-interactions/badge/?version=stable)](https://mpl-interactions.readthedocs.io/en/stable/?badge=stable)
[![Binder](https://mybinder.org/badge_logo.svg)](https://mybinder.org/v2/gh/ianhi/mpl-interactions/master?urlpath=lab)
[![Test](https://github.com/ianhi/mpl-interactions/actions/workflows/test.yml/badge.svg)](https://github.com/ianhi/mpl-interactions/actions/workflows/test.yml)
[![pre-commit.ci status](https://results.pre-commit.ci/badge/github/ianhi/mpl-interactions/master.svg)](https://results.pre-commit.ci/latest/github/ianhi/mpl-interactions/master)
[![Code style: Prettier](https://img.shields.io/badge/code_style-prettier-ff69b4.svg?style=flat-square)](https://prettier.io)
[![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black)
[![Imports: isort](https://img.shields.io/badge/%20imports-isort-%231674b1?style=flat&labelColor=ef8336)](https://pycqa.github.io/isort)
## Welcome!
mpl_interactions' library provides helpful ways to interact with [Matplotlib](https://matplotlib.org/) plots. Full narrative documentation and example can be found on [Read the Docs](https://mpl-interactions.readthedocs.io).
## Installation
```bash
pip install mpl_interactions["jupyter"] # will install necessary deps for using in jupyter
# for use only outside of jupyter:
pip install mpl_interactions
```
If you use JupyterLab, make sure you follow the full instructions in the ipympl [readme](https://github.com/matplotlib/ipympl#install-the-jupyterlab-extension) in particular installing jupyterlab-manager.
## Contributing / feature requests / roadmap
I use the GitHub [issues](https://github.com/ianhi/mpl-interactions/issues) to keep track of ideas I have, so looking through those should serve as a roadmap of sorts. For the most part I add to the library when I create a function that is useful for the science I am doing. If you create something that seems useful a PR would be most welcome so we can share it easily with more people. I'm also open to feature requests if you have an idea.
## Documentation
The fuller narrative documentation can be found on [ReadTheDocs](https://mpl-interactions.readthedocs.io/en/latest/). You may also find it helpful to check out the [examples directory](docs/examples).
## Contributors ✨
Thanks goes to these wonderful people ([emoji key](https://allcontributors.org/docs/en/emoji-key)):
Ian Hunt-Isaak 💻 |
Sam 📖 |
Jenny Coulter 📓 |
Sabina Haque 📖 📓 💻 |
John Russell 💻 📓 📖 |
Max Shinn 💻 📓 |
Kevin Dalton 📓 |
Remco de Boer 💻 📓 📖 |
samwelborn 📓 |
Matthew Feickert 💻 |
Ian Hunt-Isaak 💻 |
Sam 📖 |
Jenny Coulter 📓 |
Sabina Haque 📖 📓 💻 |
John Russell 💻 📓 📖 |
Max Shinn 💻 📓 |
Kevin Dalton 📓 |
Remco de Boer 💻 📓 📖 |
samwelborn 📓 |
Matthew Feickert 💻 |
Ian Hunt-Isaak 💻 |
Sam 📖 |
Jenny Coulter 📓 |
Sabina Haque 📖 📓 💻 |
John Russell 💻 📓 📖 |
Max Shinn 💻 📓 |
Kevin Dalton 📓 |
Remco de Boer 💻 📓 📖 |
samwelborn 📓 |
Matthew Feickert 💻 |