%global _empty_manifest_terminate_build 0
Name: python-WSocket
Version: 2.1.0
Release: 1
Summary: Simple WSGI Websocket Server, Framework, Middleware And App
License: MIT
URL: https://github.com/Ksengine/wsocket/
Source0: https://mirrors.aliyun.com/pypi/web/packages/30/f4/cf572069caecbb7c05465a1a70a877e3ce40059be42535ecd0a637418540/WSocket-2.1.0.tar.gz
BuildArch: noarch
%description
# WSocket
**Simple WSGI HTTP + Websocket Server, Framework, Middleware And App.**
[![Downloads](https://pepy.tech/badge/wsocket)](https://pepy.tech/project/wsocket)
**Note:**
I am a 16 years old student.I have no enough knowledge. So can anyone [help me](https://github.com/Ksengine/WSocket/issues/2) to develop this library?
## Server
Server([WSGI](http://www.wsgi.org/)) creates and listens at the HTTPsocket, dispatching the requests to a handler. WSGIRef server but uses threads to handle requests by using the ThreadingMixIn. This is useful to handle web browsers pre-opening sockets, on which Server would wait indefinitely.
**can used with any WSGI compatible web framework**
## Middleware
convert any WSGI compatible web framework to Websocket+HTTP framework
using middleware.
**works with many WSGI compatible servers**
**can used with any WSGI compatible web framework**
> Flask, Django, Pyramid, Bottle, ... supported
## Handler
`wsgiref.simple_server.WSGIRequestHandler` like class named `FixedHandler` that always wrap WSGI app using Middleware.
changes from `WSGIRequestHandler` :
- Prevents reverse DNS lookups
- errorless logger
- use `ServerHandler` to make it WSGI
> You can convert wsgiref to a websocket+HTTP server using this handler
### ServerHandler
`wsgiref.simple_server.ServerHandler`(inherited from `wsgiref.handlers.ServerHandler` like handler named `FixedServerHandler` .
changes from `ServerHandler` :
- set HTTP version to `1.1` because versions below `1.1` are not supported some clients like Firefox.
- removed hop-by-hop headers checker because it raise errors on `Upgrade` and `Connection` headers
- check that all headers are strings
## Framework
basic WSGI web application framework that uses Middleware.
- simple routes handler
- auto description to status code
- headers checker
- send data as soon as possible
- send strings, bytes, lists(even bytes and strings mixed) or files directly
- error catcher and error logger
**works with many WSGI compatible servers**
## App
Event based app for websocket communication. this is app that uses Framework
if not events handled by developer. this app works like demo(echo) app.
## Features
all Middleware, Handler, Framework and App has following features.
- websocket sub protocol supported
- websocket message compression supported (works if client asks)
- receive and send pong and ping messages(with automatic pong sender)
- receive and send binary or text messages
- works for messages with or without mask
- closing messages supported
- auto and manual close
**View Documentaion** - https://wsocket.gitbook.io/
**Report Bugs** - https://github.com/Ksengine/WSocket/issues/new/
### License
Code and documentation are available according to the MIT License (see [LICENSE](https://github.com/Ksengine/WSocket/blob/master/LICENSE)).
%package -n python3-WSocket
Summary: Simple WSGI Websocket Server, Framework, Middleware And App
Provides: python-WSocket
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-WSocket
# WSocket
**Simple WSGI HTTP + Websocket Server, Framework, Middleware And App.**
[![Downloads](https://pepy.tech/badge/wsocket)](https://pepy.tech/project/wsocket)
**Note:**
I am a 16 years old student.I have no enough knowledge. So can anyone [help me](https://github.com/Ksengine/WSocket/issues/2) to develop this library?
## Server
Server([WSGI](http://www.wsgi.org/)) creates and listens at the HTTPsocket, dispatching the requests to a handler. WSGIRef server but uses threads to handle requests by using the ThreadingMixIn. This is useful to handle web browsers pre-opening sockets, on which Server would wait indefinitely.
**can used with any WSGI compatible web framework**
## Middleware
convert any WSGI compatible web framework to Websocket+HTTP framework
using middleware.
**works with many WSGI compatible servers**
**can used with any WSGI compatible web framework**
> Flask, Django, Pyramid, Bottle, ... supported
## Handler
`wsgiref.simple_server.WSGIRequestHandler` like class named `FixedHandler` that always wrap WSGI app using Middleware.
changes from `WSGIRequestHandler` :
- Prevents reverse DNS lookups
- errorless logger
- use `ServerHandler` to make it WSGI
> You can convert wsgiref to a websocket+HTTP server using this handler
### ServerHandler
`wsgiref.simple_server.ServerHandler`(inherited from `wsgiref.handlers.ServerHandler` like handler named `FixedServerHandler` .
changes from `ServerHandler` :
- set HTTP version to `1.1` because versions below `1.1` are not supported some clients like Firefox.
- removed hop-by-hop headers checker because it raise errors on `Upgrade` and `Connection` headers
- check that all headers are strings
## Framework
basic WSGI web application framework that uses Middleware.
- simple routes handler
- auto description to status code
- headers checker
- send data as soon as possible
- send strings, bytes, lists(even bytes and strings mixed) or files directly
- error catcher and error logger
**works with many WSGI compatible servers**
## App
Event based app for websocket communication. this is app that uses Framework
if not events handled by developer. this app works like demo(echo) app.
## Features
all Middleware, Handler, Framework and App has following features.
- websocket sub protocol supported
- websocket message compression supported (works if client asks)
- receive and send pong and ping messages(with automatic pong sender)
- receive and send binary or text messages
- works for messages with or without mask
- closing messages supported
- auto and manual close
**View Documentaion** - https://wsocket.gitbook.io/
**Report Bugs** - https://github.com/Ksengine/WSocket/issues/new/
### License
Code and documentation are available according to the MIT License (see [LICENSE](https://github.com/Ksengine/WSocket/blob/master/LICENSE)).
%package help
Summary: Development documents and examples for WSocket
Provides: python3-WSocket-doc
%description help
# WSocket
**Simple WSGI HTTP + Websocket Server, Framework, Middleware And App.**
[![Downloads](https://pepy.tech/badge/wsocket)](https://pepy.tech/project/wsocket)
**Note:**
I am a 16 years old student.I have no enough knowledge. So can anyone [help me](https://github.com/Ksengine/WSocket/issues/2) to develop this library?
## Server
Server([WSGI](http://www.wsgi.org/)) creates and listens at the HTTPsocket, dispatching the requests to a handler. WSGIRef server but uses threads to handle requests by using the ThreadingMixIn. This is useful to handle web browsers pre-opening sockets, on which Server would wait indefinitely.
**can used with any WSGI compatible web framework**
## Middleware
convert any WSGI compatible web framework to Websocket+HTTP framework
using middleware.
**works with many WSGI compatible servers**
**can used with any WSGI compatible web framework**
> Flask, Django, Pyramid, Bottle, ... supported
## Handler
`wsgiref.simple_server.WSGIRequestHandler` like class named `FixedHandler` that always wrap WSGI app using Middleware.
changes from `WSGIRequestHandler` :
- Prevents reverse DNS lookups
- errorless logger
- use `ServerHandler` to make it WSGI
> You can convert wsgiref to a websocket+HTTP server using this handler
### ServerHandler
`wsgiref.simple_server.ServerHandler`(inherited from `wsgiref.handlers.ServerHandler` like handler named `FixedServerHandler` .
changes from `ServerHandler` :
- set HTTP version to `1.1` because versions below `1.1` are not supported some clients like Firefox.
- removed hop-by-hop headers checker because it raise errors on `Upgrade` and `Connection` headers
- check that all headers are strings
## Framework
basic WSGI web application framework that uses Middleware.
- simple routes handler
- auto description to status code
- headers checker
- send data as soon as possible
- send strings, bytes, lists(even bytes and strings mixed) or files directly
- error catcher and error logger
**works with many WSGI compatible servers**
## App
Event based app for websocket communication. this is app that uses Framework
if not events handled by developer. this app works like demo(echo) app.
## Features
all Middleware, Handler, Framework and App has following features.
- websocket sub protocol supported
- websocket message compression supported (works if client asks)
- receive and send pong and ping messages(with automatic pong sender)
- receive and send binary or text messages
- works for messages with or without mask
- closing messages supported
- auto and manual close
**View Documentaion** - https://wsocket.gitbook.io/
**Report Bugs** - https://github.com/Ksengine/WSocket/issues/new/
### License
Code and documentation are available according to the MIT License (see [LICENSE](https://github.com/Ksengine/WSocket/blob/master/LICENSE)).
%prep
%autosetup -n WSocket-2.1.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-WSocket -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 2.1.0-1
- Package Spec generated