%global _empty_manifest_terminate_build 0
Name: python-standard
Version: 1.0.3
Release: 1
Summary: Standard Library for Python
License: MIT License
URL: https://yoginth.gitlab.io
Source0: https://mirrors.aliyun.com/pypi/web/packages/88/75/f18bb49b5df87d6bdeba734e62b2bcd0cb9df74e969b2876c958cc9fd870/standard-1.0.3.tar.gz
BuildArch: noarch
%description
## Standard
> Standard Library for Python
## Screenshot
## Inspired by
- [CS50 Library](https://github.com/cs50/python-cs50)
## Install
```
$ pip install standard
```
## Usage
```python
import standard
# from standard import gets, getc, getf, geti
string = standard.gets("Enter the String: ")
print(string)
char = standard.getc("Enter the Character: ")
print(char)
flo = standard.getf("Enter the Value: ")
print(flo)
integer = standard.geti("Enter the Number: ")
print(integer)
```
## Get Help
There are few ways to get help:
1. Please [post questions on Stack Overflow](https://stackoverflow.com/questions/ask). You can open issues with questions, as long you add a link to your Stack Overflow question.
2. For bug reports and feature requests, open issues.
3. For direct and quick help, you can [email me](mailto://yoginth@zoho.com).
## How to contribute
Have an idea? Found a bug? See [how to contribute][contributing].
Thanks!
## License
[MIT][license]
[LICENSE]: https://yoginth.mit-license.org/
[contributing]: /CONTRIBUTING.md
%package -n python3-standard
Summary: Standard Library for Python
Provides: python-standard
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-standard
## Standard
> Standard Library for Python
## Screenshot
## Inspired by
- [CS50 Library](https://github.com/cs50/python-cs50)
## Install
```
$ pip install standard
```
## Usage
```python
import standard
# from standard import gets, getc, getf, geti
string = standard.gets("Enter the String: ")
print(string)
char = standard.getc("Enter the Character: ")
print(char)
flo = standard.getf("Enter the Value: ")
print(flo)
integer = standard.geti("Enter the Number: ")
print(integer)
```
## Get Help
There are few ways to get help:
1. Please [post questions on Stack Overflow](https://stackoverflow.com/questions/ask). You can open issues with questions, as long you add a link to your Stack Overflow question.
2. For bug reports and feature requests, open issues.
3. For direct and quick help, you can [email me](mailto://yoginth@zoho.com).
## How to contribute
Have an idea? Found a bug? See [how to contribute][contributing].
Thanks!
## License
[MIT][license]
[LICENSE]: https://yoginth.mit-license.org/
[contributing]: /CONTRIBUTING.md
%package help
Summary: Development documents and examples for standard
Provides: python3-standard-doc
%description help
## Standard
> Standard Library for Python
## Screenshot
## Inspired by
- [CS50 Library](https://github.com/cs50/python-cs50)
## Install
```
$ pip install standard
```
## Usage
```python
import standard
# from standard import gets, getc, getf, geti
string = standard.gets("Enter the String: ")
print(string)
char = standard.getc("Enter the Character: ")
print(char)
flo = standard.getf("Enter the Value: ")
print(flo)
integer = standard.geti("Enter the Number: ")
print(integer)
```
## Get Help
There are few ways to get help:
1. Please [post questions on Stack Overflow](https://stackoverflow.com/questions/ask). You can open issues with questions, as long you add a link to your Stack Overflow question.
2. For bug reports and feature requests, open issues.
3. For direct and quick help, you can [email me](mailto://yoginth@zoho.com).
## How to contribute
Have an idea? Found a bug? See [how to contribute][contributing].
Thanks!
## License
[MIT][license]
[LICENSE]: https://yoginth.mit-license.org/
[contributing]: /CONTRIBUTING.md
%prep
%autosetup -n standard-1.0.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-standard -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 1.0.3-1
- Package Spec generated