%global _empty_manifest_terminate_build 0
Name: python-glglue
Version: 2.0.0
Release: 1
Summary: The glue code which mediates between OpenGL and some GUI
License: MIT License
URL: https://ousttrue.github.io/glglue/
Source0: https://mirrors.aliyun.com/pypi/web/packages/c7/31/a1d122edc23c1627242639785d7610f8e19b05007c20316f13d970256caa/glglue-2.0.0.tar.gz
BuildArch: noarch
Requires: python3-pyopengl
Requires: python3-PyGLM
%description
# glglue
The glue code which mediates between OpenGL and some GUI.
GUI イベント(resize, mouse, keyboard, repaint) を OpenGL に橋渡しする。
```
GUI OpenGL controller
+--------+ +------------+
| win32 |--window resize--->| Update |
| glut |--mouse input----->| Update |
| sdl |--keyboard input-->| Update |
| pyside6| | |
| gtk3 |--repaint--------->| Draw |
| gtk4 | +------------+
+--------+
```
And OpenGL utilities.
## Requirements
* Python 3.10
## Site
*
*
%package -n python3-glglue
Summary: The glue code which mediates between OpenGL and some GUI
Provides: python-glglue
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-glglue
# glglue
The glue code which mediates between OpenGL and some GUI.
GUI イベント(resize, mouse, keyboard, repaint) を OpenGL に橋渡しする。
```
GUI OpenGL controller
+--------+ +------------+
| win32 |--window resize--->| Update |
| glut |--mouse input----->| Update |
| sdl |--keyboard input-->| Update |
| pyside6| | |
| gtk3 |--repaint--------->| Draw |
| gtk4 | +------------+
+--------+
```
And OpenGL utilities.
## Requirements
* Python 3.10
## Site
*
*
%package help
Summary: Development documents and examples for glglue
Provides: python3-glglue-doc
%description help
# glglue
The glue code which mediates between OpenGL and some GUI.
GUI イベント(resize, mouse, keyboard, repaint) を OpenGL に橋渡しする。
```
GUI OpenGL controller
+--------+ +------------+
| win32 |--window resize--->| Update |
| glut |--mouse input----->| Update |
| sdl |--keyboard input-->| Update |
| pyside6| | |
| gtk3 |--repaint--------->| Draw |
| gtk4 | +------------+
+--------+
```
And OpenGL utilities.
## Requirements
* Python 3.10
## Site
*
*
%prep
%autosetup -n glglue-2.0.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-glglue -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 2.0.0-1
- Package Spec generated