%global _empty_manifest_terminate_build 0
Name:		python-pylgnetcast
Version:	0.3.7
Release:	1
Summary:	Client for the LG Smart TV running NetCast 3 or 4.
License:	MIT
URL:		https://github.com/Drafteed/python-lgnetcast
Source0:	https://mirrors.aliyun.com/pypi/web/packages/ed/f8/a299d998161cb7fa3e5262425dc735740e094f6f30012faa3a71a9dbcac4/pylgnetcast-0.3.7.tar.gz
BuildArch:	noarch

Requires:	python3-requests

%description
# Python LG Netcast

A Python 3 library and command line tool to control LG Smart TV running NetCast 3.0 (LG Smart TV models released in 2012) and NetCast 4.0 (LG Smart TV models released in 2013) via TCP/IP.

This library was forked from [wokar/pylgnetcast](https://github.com/wokar/pylgnetcast) and is primarily being developed with the intent of supporting [home-assistant](https://github.com/home-assistant/home-assistant).

## Dependencies

 * Python 3
 * [requests](https://pypi.python.org/pypi/requests) package.

## API Usage

```python
from xml.etree import ElementTree
from pylgnetcast import LgNetCastClient, LG_COMMAND, LG_QUERY

with LgNetCastClient('192.168.1.5', '889955') as client:
    client.send_command(LG_COMMAND.MUTE_TOGGLE)
    data = client.query_data(LG_QUERY.VOLUME_INFO)
    if data:
        print(ElementTree.tostring(data[0], encoding='unicode'))
```

## Command Line Tool
PyLgNetCast also provides a simple command line tool to remote control a TV.

The tool needs a pairing key to be allowed to send commands to your TV.
To get the pairing key just start the tool while your TV is on:
```sh
python -m pylgnetcast --host <IP of your TV>
```
This will display the pairing key on your TV.

To retrieve status information from your TV start the tool like:
```sh
python -m pylgnetcast --host <IP of your TV>  --pairing_key <pairing key of your TV>
```
This will display information about the current channel, volume, 3D mode, etc. retrieved from your TV.

If you want to send a command to your TV, for instance to turn the volume up, check the list of available commands in the pylgnetcast.py file.
The class LG_COMMAND defines all supported commands and volume up would be defined as 24.
```sh
python -m pylgnetcast --host <IP of your TV>  --pairing_key <pairing key of your TV> --command 24
```






%package -n python3-pylgnetcast
Summary:	Client for the LG Smart TV running NetCast 3 or 4.
Provides:	python-pylgnetcast
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pylgnetcast
# Python LG Netcast

A Python 3 library and command line tool to control LG Smart TV running NetCast 3.0 (LG Smart TV models released in 2012) and NetCast 4.0 (LG Smart TV models released in 2013) via TCP/IP.

This library was forked from [wokar/pylgnetcast](https://github.com/wokar/pylgnetcast) and is primarily being developed with the intent of supporting [home-assistant](https://github.com/home-assistant/home-assistant).

## Dependencies

 * Python 3
 * [requests](https://pypi.python.org/pypi/requests) package.

## API Usage

```python
from xml.etree import ElementTree
from pylgnetcast import LgNetCastClient, LG_COMMAND, LG_QUERY

with LgNetCastClient('192.168.1.5', '889955') as client:
    client.send_command(LG_COMMAND.MUTE_TOGGLE)
    data = client.query_data(LG_QUERY.VOLUME_INFO)
    if data:
        print(ElementTree.tostring(data[0], encoding='unicode'))
```

## Command Line Tool
PyLgNetCast also provides a simple command line tool to remote control a TV.

The tool needs a pairing key to be allowed to send commands to your TV.
To get the pairing key just start the tool while your TV is on:
```sh
python -m pylgnetcast --host <IP of your TV>
```
This will display the pairing key on your TV.

To retrieve status information from your TV start the tool like:
```sh
python -m pylgnetcast --host <IP of your TV>  --pairing_key <pairing key of your TV>
```
This will display information about the current channel, volume, 3D mode, etc. retrieved from your TV.

If you want to send a command to your TV, for instance to turn the volume up, check the list of available commands in the pylgnetcast.py file.
The class LG_COMMAND defines all supported commands and volume up would be defined as 24.
```sh
python -m pylgnetcast --host <IP of your TV>  --pairing_key <pairing key of your TV> --command 24
```






%package help
Summary:	Development documents and examples for pylgnetcast
Provides:	python3-pylgnetcast-doc
%description help
# Python LG Netcast

A Python 3 library and command line tool to control LG Smart TV running NetCast 3.0 (LG Smart TV models released in 2012) and NetCast 4.0 (LG Smart TV models released in 2013) via TCP/IP.

This library was forked from [wokar/pylgnetcast](https://github.com/wokar/pylgnetcast) and is primarily being developed with the intent of supporting [home-assistant](https://github.com/home-assistant/home-assistant).

## Dependencies

 * Python 3
 * [requests](https://pypi.python.org/pypi/requests) package.

## API Usage

```python
from xml.etree import ElementTree
from pylgnetcast import LgNetCastClient, LG_COMMAND, LG_QUERY

with LgNetCastClient('192.168.1.5', '889955') as client:
    client.send_command(LG_COMMAND.MUTE_TOGGLE)
    data = client.query_data(LG_QUERY.VOLUME_INFO)
    if data:
        print(ElementTree.tostring(data[0], encoding='unicode'))
```

## Command Line Tool
PyLgNetCast also provides a simple command line tool to remote control a TV.

The tool needs a pairing key to be allowed to send commands to your TV.
To get the pairing key just start the tool while your TV is on:
```sh
python -m pylgnetcast --host <IP of your TV>
```
This will display the pairing key on your TV.

To retrieve status information from your TV start the tool like:
```sh
python -m pylgnetcast --host <IP of your TV>  --pairing_key <pairing key of your TV>
```
This will display information about the current channel, volume, 3D mode, etc. retrieved from your TV.

If you want to send a command to your TV, for instance to turn the volume up, check the list of available commands in the pylgnetcast.py file.
The class LG_COMMAND defines all supported commands and volume up would be defined as 24.
```sh
python -m pylgnetcast --host <IP of your TV>  --pairing_key <pairing key of your TV> --command 24
```






%prep
%autosetup -n pylgnetcast-0.3.7

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pylgnetcast -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.7-1
- Package Spec generated