%global _empty_manifest_terminate_build 0 Name: python-pocard Version: 0.0.7 Release: 1 Summary: PokemonCard Generator License: MIT URL: https://github.com/krypton-byte/pocard Source0: https://mirrors.aliyun.com/pypi/web/packages/56/a4/827dfe19afa8b4cff39677ed3b3eb03230083ec517ae60c380ebbefa7423/pocard-0.0.7.tar.gz BuildArch: noarch %description
# Pokemon Card # Install This Library ``` $ git clone https://github.com/krypton-byte/pocard $ cd pocard && python3 setup.py build && python3 setup.py install --user ``` # Use
CommandLine
```bash $ pocard index[0-3] "title" "desc" input_image output_image method:[scale, crop, auto] example: $ pocard 0 "Title" "desc" in.png out.jpg scale ```
Python Interpreter
```python >>> from pocard import CARDS >>> CARDS[0].maker("Title", "image_input.png", "Desk", font_color=(0, 0, 0), image_method="auto").show() >>> CARDS[0].maker("Title", "image_input.png", "Desk", font_color=(0, 0, 0), image_method="auto").save("out.png) # image_input type: BytesIO, Image.open Object, string(path+filename) # image_merhod: scale, auto, crop ``` # Preview # Donasi%package -n python3-pocard Summary: PokemonCard Generator Provides: python-pocard BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-pocard
# Pokemon Card # Install This Library ``` $ git clone https://github.com/krypton-byte/pocard $ cd pocard && python3 setup.py build && python3 setup.py install --user ``` # Use
CommandLine
```bash $ pocard index[0-3] "title" "desc" input_image output_image method:[scale, crop, auto] example: $ pocard 0 "Title" "desc" in.png out.jpg scale ```
Python Interpreter
```python >>> from pocard import CARDS >>> CARDS[0].maker("Title", "image_input.png", "Desk", font_color=(0, 0, 0), image_method="auto").show() >>> CARDS[0].maker("Title", "image_input.png", "Desk", font_color=(0, 0, 0), image_method="auto").save("out.png) # image_input type: BytesIO, Image.open Object, string(path+filename) # image_merhod: scale, auto, crop ``` # Preview # Donasi%package help Summary: Development documents and examples for pocard Provides: python3-pocard-doc %description help
# Pokemon Card # Install This Library ``` $ git clone https://github.com/krypton-byte/pocard $ cd pocard && python3 setup.py build && python3 setup.py install --user ``` # Use
CommandLine
```bash $ pocard index[0-3] "title" "desc" input_image output_image method:[scale, crop, auto] example: $ pocard 0 "Title" "desc" in.png out.jpg scale ```
Python Interpreter
```python >>> from pocard import CARDS >>> CARDS[0].maker("Title", "image_input.png", "Desk", font_color=(0, 0, 0), image_method="auto").show() >>> CARDS[0].maker("Title", "image_input.png", "Desk", font_color=(0, 0, 0), image_method="auto").save("out.png) # image_input type: BytesIO, Image.open Object, string(path+filename) # image_merhod: scale, auto, crop ``` # Preview # Donasi%prep %autosetup -n pocard-0.0.7 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-pocard -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Thu Jun 08 2023 Python_Bot