%global _empty_manifest_terminate_build 0
Name: python-airavata-django-portal-sdk
Version: 1.8.3
Release: 1
Summary: The Airavata Django Portal SDK is a library that makes it easier to develop Airavata Django Portal customizations.
License: Apache License 2.0
URL: https://github.com/apache/airavata-django-portal-sdk
Source0: https://mirrors.aliyun.com/pypi/web/packages/20/e3/6dd0f5106b3afa9c10cc6807684d776601b732fa58dc5aa042d2264517fe/airavata-django-portal-sdk-1.8.3.tar.gz
BuildArch: noarch
Requires: python3-django
Requires: python3-djangorestframework
Requires: python3-airavata-python-sdk
Requires: python3-requests
Requires: python3-zipstream-new
%description
# Airavata Django Portal SDK
[![Build Status](https://travis-ci.com/apache/airavata-django-portal-sdk.svg?branch=master)](https://travis-ci.com/apache/airavata-django-portal-sdk)
The Airavata Django Portal SDK provides libraries that assist in developing
custom Django app extensions to the
[Airavata Django Portal](https://github.com/apache/airavata-django-portal).
See the documentation at https://airavata-django-portal-sdk.readthedocs.io/ for
more details.
## Getting Started
To integrate the SDK with an Airavata Django Portal custom app, add
```
airavata-django-portal-sdk
```
to the `install_requires` list in your setup.cfg or setup.py file. Then
reinstall the Django app with
```
pip install -e .
```
(see your Airavata Django custom app's README for details)
You can also just install the library with:
```
pip install airavata-django-portal-sdk
```
## Migrations
```
django-admin makemigrations --settings=airavata_django_portal_sdk.tests.test_settings airavata_django_portal_sdk
```
## Developing
### Setting up dev environment
To generate the documentation,
[create a virtual environment](https://docs.python.org/3/tutorial/venv.html) and
then:
```
source venv/bin/activate
pip install --upgrade pip setuptools wheel
pip install -r requirements-dev.txt
```
### Documentation
```
mkdocs serve
```
### Running tests
```
pytest
```
or
```
django-admin test --settings airavata_django_portal_sdk.tests.test_settings
```
or use tox to run the tests in all supported Python environments
```
tox
```
### Running flake8
```
flake8 .
```
### Automatically formatting Python code
```
autopep8 -i -aaa -r .
isort .
```
### Making a new release
1. Update the version in setup.py
2. Tag the repo with the same version, with the format `v${version_number}`. For
example, if the version number in setup.py is "1.2" then tag the repo with
"v1.2".
```
VERSION=...
git tag -m $VERSION $VERSION
git push --follow-tags
```
3. In a clean checkout
```
cd /tmp/
git clone /path/to/airavata-django-portal-sdk/ -b $VERSION
cd airavata-django-portal-sdk
python3 -m venv venv
source venv/bin/activate
python3 -m pip install --upgrade build
python3 -m build
```
4. Push to pypi.org. Optionally can push to test.pypi.org. See
for more info.
```
python3 -m pip install --upgrade twine
python3 -m twine upload dist/*
```
%package -n python3-airavata-django-portal-sdk
Summary: The Airavata Django Portal SDK is a library that makes it easier to develop Airavata Django Portal customizations.
Provides: python-airavata-django-portal-sdk
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-airavata-django-portal-sdk
# Airavata Django Portal SDK
[![Build Status](https://travis-ci.com/apache/airavata-django-portal-sdk.svg?branch=master)](https://travis-ci.com/apache/airavata-django-portal-sdk)
The Airavata Django Portal SDK provides libraries that assist in developing
custom Django app extensions to the
[Airavata Django Portal](https://github.com/apache/airavata-django-portal).
See the documentation at https://airavata-django-portal-sdk.readthedocs.io/ for
more details.
## Getting Started
To integrate the SDK with an Airavata Django Portal custom app, add
```
airavata-django-portal-sdk
```
to the `install_requires` list in your setup.cfg or setup.py file. Then
reinstall the Django app with
```
pip install -e .
```
(see your Airavata Django custom app's README for details)
You can also just install the library with:
```
pip install airavata-django-portal-sdk
```
## Migrations
```
django-admin makemigrations --settings=airavata_django_portal_sdk.tests.test_settings airavata_django_portal_sdk
```
## Developing
### Setting up dev environment
To generate the documentation,
[create a virtual environment](https://docs.python.org/3/tutorial/venv.html) and
then:
```
source venv/bin/activate
pip install --upgrade pip setuptools wheel
pip install -r requirements-dev.txt
```
### Documentation
```
mkdocs serve
```
### Running tests
```
pytest
```
or
```
django-admin test --settings airavata_django_portal_sdk.tests.test_settings
```
or use tox to run the tests in all supported Python environments
```
tox
```
### Running flake8
```
flake8 .
```
### Automatically formatting Python code
```
autopep8 -i -aaa -r .
isort .
```
### Making a new release
1. Update the version in setup.py
2. Tag the repo with the same version, with the format `v${version_number}`. For
example, if the version number in setup.py is "1.2" then tag the repo with
"v1.2".
```
VERSION=...
git tag -m $VERSION $VERSION
git push --follow-tags
```
3. In a clean checkout
```
cd /tmp/
git clone /path/to/airavata-django-portal-sdk/ -b $VERSION
cd airavata-django-portal-sdk
python3 -m venv venv
source venv/bin/activate
python3 -m pip install --upgrade build
python3 -m build
```
4. Push to pypi.org. Optionally can push to test.pypi.org. See
for more info.
```
python3 -m pip install --upgrade twine
python3 -m twine upload dist/*
```
%package help
Summary: Development documents and examples for airavata-django-portal-sdk
Provides: python3-airavata-django-portal-sdk-doc
%description help
# Airavata Django Portal SDK
[![Build Status](https://travis-ci.com/apache/airavata-django-portal-sdk.svg?branch=master)](https://travis-ci.com/apache/airavata-django-portal-sdk)
The Airavata Django Portal SDK provides libraries that assist in developing
custom Django app extensions to the
[Airavata Django Portal](https://github.com/apache/airavata-django-portal).
See the documentation at https://airavata-django-portal-sdk.readthedocs.io/ for
more details.
## Getting Started
To integrate the SDK with an Airavata Django Portal custom app, add
```
airavata-django-portal-sdk
```
to the `install_requires` list in your setup.cfg or setup.py file. Then
reinstall the Django app with
```
pip install -e .
```
(see your Airavata Django custom app's README for details)
You can also just install the library with:
```
pip install airavata-django-portal-sdk
```
## Migrations
```
django-admin makemigrations --settings=airavata_django_portal_sdk.tests.test_settings airavata_django_portal_sdk
```
## Developing
### Setting up dev environment
To generate the documentation,
[create a virtual environment](https://docs.python.org/3/tutorial/venv.html) and
then:
```
source venv/bin/activate
pip install --upgrade pip setuptools wheel
pip install -r requirements-dev.txt
```
### Documentation
```
mkdocs serve
```
### Running tests
```
pytest
```
or
```
django-admin test --settings airavata_django_portal_sdk.tests.test_settings
```
or use tox to run the tests in all supported Python environments
```
tox
```
### Running flake8
```
flake8 .
```
### Automatically formatting Python code
```
autopep8 -i -aaa -r .
isort .
```
### Making a new release
1. Update the version in setup.py
2. Tag the repo with the same version, with the format `v${version_number}`. For
example, if the version number in setup.py is "1.2" then tag the repo with
"v1.2".
```
VERSION=...
git tag -m $VERSION $VERSION
git push --follow-tags
```
3. In a clean checkout
```
cd /tmp/
git clone /path/to/airavata-django-portal-sdk/ -b $VERSION
cd airavata-django-portal-sdk
python3 -m venv venv
source venv/bin/activate
python3 -m pip install --upgrade build
python3 -m build
```
4. Push to pypi.org. Optionally can push to test.pypi.org. See
for more info.
```
python3 -m pip install --upgrade twine
python3 -m twine upload dist/*
```
%prep
%autosetup -n airavata-django-portal-sdk-1.8.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-airavata-django-portal-sdk -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 1.8.3-1
- Package Spec generated