%global _empty_manifest_terminate_build 0
Name: python-dict2colander
Version: 0.2
Release: 1
Summary: Dictionary to Colander schema conversion library
License: MIT Licence (http://opensource.org/licenses/MIT)
URL: https://bitbucket.org/pfacka/dict2colander
Source0: https://mirrors.aliyun.com/pypi/web/packages/aa/7e/5ed2ba3dc2f06457b76d4bc8c93559179472bf87e6982f9a9e5cea30e84e/dict2colander-0.2.tar.gz
BuildArch: noarch
%description
*Convert python dict (YAML, JSON) to colander schema.*
`Colander `_
is library, which enables you to validate and convert YAML, JSON
and HTML form data. Colander schema as it is could be defined only
in Python declaratively for example like this:
import colander
class Person(colander.MappingSchema):
name = colander.SchemaNode(colander.String())
age = colander.SchemaNode(colander.Int(),
validator=colander.Range(0, 200))
@colander.instantiate()
class phones(colander.SequenceSchema):
@colander.instantiate()
class phone(colander.MappingSchema):
location = colander.SchemaNode(colander.String(),
validator=colander.OneOf(['home', 'work']))
number = colander.SchemaNode(colander.String())
With dict2colander you can define the same colander schema in
dictionary and convert it to colader.MappingSchema object.
%package -n python3-dict2colander
Summary: Dictionary to Colander schema conversion library
Provides: python-dict2colander
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-dict2colander
*Convert python dict (YAML, JSON) to colander schema.*
`Colander `_
is library, which enables you to validate and convert YAML, JSON
and HTML form data. Colander schema as it is could be defined only
in Python declaratively for example like this:
import colander
class Person(colander.MappingSchema):
name = colander.SchemaNode(colander.String())
age = colander.SchemaNode(colander.Int(),
validator=colander.Range(0, 200))
@colander.instantiate()
class phones(colander.SequenceSchema):
@colander.instantiate()
class phone(colander.MappingSchema):
location = colander.SchemaNode(colander.String(),
validator=colander.OneOf(['home', 'work']))
number = colander.SchemaNode(colander.String())
With dict2colander you can define the same colander schema in
dictionary and convert it to colader.MappingSchema object.
%package help
Summary: Development documents and examples for dict2colander
Provides: python3-dict2colander-doc
%description help
*Convert python dict (YAML, JSON) to colander schema.*
`Colander `_
is library, which enables you to validate and convert YAML, JSON
and HTML form data. Colander schema as it is could be defined only
in Python declaratively for example like this:
import colander
class Person(colander.MappingSchema):
name = colander.SchemaNode(colander.String())
age = colander.SchemaNode(colander.Int(),
validator=colander.Range(0, 200))
@colander.instantiate()
class phones(colander.SequenceSchema):
@colander.instantiate()
class phone(colander.MappingSchema):
location = colander.SchemaNode(colander.String(),
validator=colander.OneOf(['home', 'work']))
number = colander.SchemaNode(colander.String())
With dict2colander you can define the same colander schema in
dictionary and convert it to colader.MappingSchema object.
%prep
%autosetup -n dict2colander-0.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-dict2colander -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 0.2-1
- Package Spec generated