%global _empty_manifest_terminate_build 0
Name:		python-Gutenberg
Version:	0.8.2
Release:	1
Summary:	Library to interface with Project Gutenberg
License:	Apache Software License
URL:		https://github.com/c-w/Gutenberg
Source0:	https://mirrors.aliyun.com/pypi/web/packages/da/73/2d2e1b34d50b9d6023d7ee8b643ed325e0e447d5f07460c93ff370643d41/Gutenberg-0.8.2.tar.gz
BuildArch:	noarch

Requires:	python3-SPARQLWrapper
Requires:	python3-bsddb3
Requires:	python3-future
Requires:	python3-pyparsing
Requires:	python3-rdflib-sqlalchemy
Requires:	python3-rdflib
Requires:	python3-requests
Requires:	python3-setuptools
Requires:	python3-six

%description
This package contains a variety of scripts to make working with the `Project
Gutenberg <http://www.gutenberg.org>`_ body of public domain texts easier.
The functionality provided by this package includes:
* Downloading texts from Project Gutenberg.
* Cleaning the texts: removing all the crud, leaving just the text behind.
* Making meta-data about the texts easily accessible.
The package has been tested with Python 2.7 and 3.5+.
An HTTP interface to this package exists too.
`Try it out! <https://github.com/c-w/gutenberg-http>`_

%package -n python3-Gutenberg
Summary:	Library to interface with Project Gutenberg
Provides:	python-Gutenberg
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-Gutenberg
This package contains a variety of scripts to make working with the `Project
Gutenberg <http://www.gutenberg.org>`_ body of public domain texts easier.
The functionality provided by this package includes:
* Downloading texts from Project Gutenberg.
* Cleaning the texts: removing all the crud, leaving just the text behind.
* Making meta-data about the texts easily accessible.
The package has been tested with Python 2.7 and 3.5+.
An HTTP interface to this package exists too.
`Try it out! <https://github.com/c-w/gutenberg-http>`_

%package help
Summary:	Development documents and examples for Gutenberg
Provides:	python3-Gutenberg-doc
%description help
This package contains a variety of scripts to make working with the `Project
Gutenberg <http://www.gutenberg.org>`_ body of public domain texts easier.
The functionality provided by this package includes:
* Downloading texts from Project Gutenberg.
* Cleaning the texts: removing all the crud, leaving just the text behind.
* Making meta-data about the texts easily accessible.
The package has been tested with Python 2.7 and 3.5+.
An HTTP interface to this package exists too.
`Try it out! <https://github.com/c-w/gutenberg-http>`_

%prep
%autosetup -n Gutenberg-0.8.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-Gutenberg -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.8.2-1
- Package Spec generated