%global _empty_manifest_terminate_build 0
Name: python-th2-grpc-data-provider
Version: 1.3.0
Release: 1
Summary: th2_grpc_data_provider
License: Apache License 2.0
URL: https://github.com/th2-net/th2-data-provider
Source0: https://mirrors.aliyun.com/pypi/web/packages/e7/73/7579702a79be89d05deb69c1f9b4b302a12aa47a14633a82e1a7af6979a2/th2_grpc_data_provider-1.3.0.tar.gz
BuildArch: noarch
%description
# th2 gRPC Data Provider library (1.3.0)
This library contains proto messages and `DataProvider` service with RPC methods that are used in [th2 data provider](https://github.com/th2-net/th2-rpt-data-provider "th2-rpt-data-provider"). See [data_provider.proto](src/main/proto/th2_grpc_data_provider/data_provider.proto "data_provider_template.proto") file for details.
Tool generates code from `.proto` files and uploads built packages (`.proto` files and generated code) to specified repositories.
## How to maintain project
1. Make your changes.
2. Up version of Java package in `gradle.properties` file.
3. Up version of Python package in `package_info.json` file.
4. Commit everything.
## How to run project
### Java
If you wish to manually create and publish a package for Java, run the following command:
```
gradle --no-daemon clean build publish artifactoryPublish \
-Purl=${URL} \
-Puser=${USER} \
-Ppassword=${PASSWORD}
```
`URL`, `USER` and `PASSWORD` are parameters for publishing.
### Python
If you wish to manually create and publish a package for Python:
1. Generate services with `Gradle`:
```
gradle --no-daemon clean generateProto
```
You can find the generated files by following path: `src/gen/main/services/python`
2. Generate code from `.proto` files and publish everything using `twine`:
```
pip install -r requirements.txt
pip install twine
python setup.py generate
python setup.py sdist
twine upload --repository-url ${PYPI_REPOSITORY_URL} --username ${PYPI_USER} --password ${PYPI_PASSWORD} dist/*
```
`PYPI_REPOSITORY_URL`, `PYPI_USER` and `PYPI_PASSWORD` are parameters for publishing.
%package -n python3-th2-grpc-data-provider
Summary: th2_grpc_data_provider
Provides: python-th2-grpc-data-provider
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-th2-grpc-data-provider
# th2 gRPC Data Provider library (1.3.0)
This library contains proto messages and `DataProvider` service with RPC methods that are used in [th2 data provider](https://github.com/th2-net/th2-rpt-data-provider "th2-rpt-data-provider"). See [data_provider.proto](src/main/proto/th2_grpc_data_provider/data_provider.proto "data_provider_template.proto") file for details.
Tool generates code from `.proto` files and uploads built packages (`.proto` files and generated code) to specified repositories.
## How to maintain project
1. Make your changes.
2. Up version of Java package in `gradle.properties` file.
3. Up version of Python package in `package_info.json` file.
4. Commit everything.
## How to run project
### Java
If you wish to manually create and publish a package for Java, run the following command:
```
gradle --no-daemon clean build publish artifactoryPublish \
-Purl=${URL} \
-Puser=${USER} \
-Ppassword=${PASSWORD}
```
`URL`, `USER` and `PASSWORD` are parameters for publishing.
### Python
If you wish to manually create and publish a package for Python:
1. Generate services with `Gradle`:
```
gradle --no-daemon clean generateProto
```
You can find the generated files by following path: `src/gen/main/services/python`
2. Generate code from `.proto` files and publish everything using `twine`:
```
pip install -r requirements.txt
pip install twine
python setup.py generate
python setup.py sdist
twine upload --repository-url ${PYPI_REPOSITORY_URL} --username ${PYPI_USER} --password ${PYPI_PASSWORD} dist/*
```
`PYPI_REPOSITORY_URL`, `PYPI_USER` and `PYPI_PASSWORD` are parameters for publishing.
%package help
Summary: Development documents and examples for th2-grpc-data-provider
Provides: python3-th2-grpc-data-provider-doc
%description help
# th2 gRPC Data Provider library (1.3.0)
This library contains proto messages and `DataProvider` service with RPC methods that are used in [th2 data provider](https://github.com/th2-net/th2-rpt-data-provider "th2-rpt-data-provider"). See [data_provider.proto](src/main/proto/th2_grpc_data_provider/data_provider.proto "data_provider_template.proto") file for details.
Tool generates code from `.proto` files and uploads built packages (`.proto` files and generated code) to specified repositories.
## How to maintain project
1. Make your changes.
2. Up version of Java package in `gradle.properties` file.
3. Up version of Python package in `package_info.json` file.
4. Commit everything.
## How to run project
### Java
If you wish to manually create and publish a package for Java, run the following command:
```
gradle --no-daemon clean build publish artifactoryPublish \
-Purl=${URL} \
-Puser=${USER} \
-Ppassword=${PASSWORD}
```
`URL`, `USER` and `PASSWORD` are parameters for publishing.
### Python
If you wish to manually create and publish a package for Python:
1. Generate services with `Gradle`:
```
gradle --no-daemon clean generateProto
```
You can find the generated files by following path: `src/gen/main/services/python`
2. Generate code from `.proto` files and publish everything using `twine`:
```
pip install -r requirements.txt
pip install twine
python setup.py generate
python setup.py sdist
twine upload --repository-url ${PYPI_REPOSITORY_URL} --username ${PYPI_USER} --password ${PYPI_PASSWORD} dist/*
```
`PYPI_REPOSITORY_URL`, `PYPI_USER` and `PYPI_PASSWORD` are parameters for publishing.
%prep
%autosetup -n th2_grpc_data_provider-1.3.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-th2-grpc-data-provider -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 1.3.0-1
- Package Spec generated