%global _empty_manifest_terminate_build 0
Name: python-stompest.async
Version: 2.3.0
Release: 1
Summary: Twisted STOMP client based upon the stompest API.
License: Apache License 2.0
URL: https://github.com/nikipore/stompest
Source0: https://mirrors.aliyun.com/pypi/web/packages/49/6c/c65e4997374bf2196c90379751e85aaed66ac8aecdb2732ee2bb479ff550/stompest.async-2.3.0.tar.gz
BuildArch: noarch
%description
This package provides the asynchronous STOMP client based upon the `stompest `_ library. It leverages the power of `Twisted `_, a very mature and powerful asynchronous programming framework. The client supports
- destination-specific message and error handlers (with default "poison pill" error handling)
- concurrent message processing
- graceful shutdown, and connect, receipt, and disconnect timeouts
- optional TLS/SSL support (TLS support in Twisted must be activated via ``pip install 'twisted[tls]'``)
%package -n python3-stompest.async
Summary: Twisted STOMP client based upon the stompest API.
Provides: python-stompest.async
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-stompest.async
This package provides the asynchronous STOMP client based upon the `stompest `_ library. It leverages the power of `Twisted `_, a very mature and powerful asynchronous programming framework. The client supports
- destination-specific message and error handlers (with default "poison pill" error handling)
- concurrent message processing
- graceful shutdown, and connect, receipt, and disconnect timeouts
- optional TLS/SSL support (TLS support in Twisted must be activated via ``pip install 'twisted[tls]'``)
%package help
Summary: Development documents and examples for stompest.async
Provides: python3-stompest.async-doc
%description help
This package provides the asynchronous STOMP client based upon the `stompest `_ library. It leverages the power of `Twisted `_, a very mature and powerful asynchronous programming framework. The client supports
- destination-specific message and error handlers (with default "poison pill" error handling)
- concurrent message processing
- graceful shutdown, and connect, receipt, and disconnect timeouts
- optional TLS/SSL support (TLS support in Twisted must be activated via ``pip install 'twisted[tls]'``)
%prep
%autosetup -n stompest.async-2.3.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-stompest.async -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 2.3.0-1
- Package Spec generated