%global _empty_manifest_terminate_build 0
Name: python-checkPy
Version: 0.4.11
Release: 1
Summary: A simple python testing framework for educational purposes
License: MIT
URL: https://github.com/Jelleas/CheckPy
Source0: https://mirrors.aliyun.com/pypi/web/packages/ed/82/d4038a085c76b4665eb8a7a5371d366581aaa5c2252078ddfd17af79e0a9/checkPy-0.4.11.tar.gz
BuildArch: noarch
%description
A Python tool for running tests on Python source files. Intended to be
used by students whom are taking courses in the `Minor
Programming `__ at the
`UvA `__.
`CheckPy docs `__
%package -n python3-checkPy
Summary: A simple python testing framework for educational purposes
Provides: python-checkPy
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-checkPy
A Python tool for running tests on Python source files. Intended to be
used by students whom are taking courses in the `Minor
Programming `__ at the
`UvA `__.
`CheckPy docs `__
%package help
Summary: Development documents and examples for checkPy
Provides: python3-checkPy-doc
%description help
A Python tool for running tests on Python source files. Intended to be
used by students whom are taking courses in the `Minor
Programming `__ at the
`UvA `__.
`CheckPy docs `__
%prep
%autosetup -n checkPy-0.4.11
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-checkPy -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 0.4.11-1
- Package Spec generated