%global _empty_manifest_terminate_build 0
Name: python-pystiebeleltron
Version: 0.0.1.dev2
Release: 1
Summary: Python API for interacting with the Stiebel Eltron ISG web gateway via Modbus for controlling integral ventilation units and heat pumps.
License: MIT
URL: https://github.com/fucm/python-stiebel-eltron
Source0: https://mirrors.aliyun.com/pypi/web/packages/8e/19/c28441128c64a1a9eab5bb61561b4f3391333670ad21585bceb1d9f398a5/pystiebeleltron-0.0.1.dev2.tar.gz
BuildArch: noarch
Requires: python3-pymodbus
%description
# python-stiebel-eltron
Python API for interacting with the STIEBEL ELTRON ISG web gateway via modbus for controlling integral ventilation units and heat pumps.
This module is based on the STIEBEL ELTRON [modbus user manual](https://www.stiebel-eltron.ch/content/dam/ste/ch/de/downloads/kundenservice/smart-home/Modbus/Modbus%20Bedienungsanleitung.pdf), but is not official, developed, supported or endorsed by Stiebel Eltron GmbH & Co. KG. For questions and other inquiries, use the issue tracker in this repo please.
## Requirements
You need to have [Python](https://www.python.org) installed.
* STIEBEL ELTRON Internet-Service Gateway [ISG WEB](https://www.stiebel-eltron.com/en/home/products-solutions/renewables/controller_energymanagement/internet_servicegateway/isg_web.html) with enabled [modbus module](https://www.stiebel-eltron.ch/de/home/service/smart-home/modbus.html)
* You can call the STIEBEL ELTRON support, if your ISG does not have the modbus module enabled. They upgraded mine for free.
* STIEBEL ELTRON heatpumpt (compatible). Successfully used devices:
* LWZ504e
* LWZ304
* Network connection to the ISG WEB
## Installation
The package is available in the [Python Package Index](https://pypi.python.org/).
```bash
$ pip install python-stiebel-eltron
```
## Example usage of the module
The sample below shows how to use this Python module.
```python
from pystiebeleltron import pystiebeleltron as pyse
from pymodbus.client.sync import ModbusTcpClient as ModbusClient
client = ModbusClient(host='IP_ADDRESS_ISG', port=502, timeout=2)
client.connect()
unit = pyse.StiebelEltronAPI(client, 1)
unit.update()
print("get_target_temp: {}".format(unit.get_target_temp))
client.close()
```
## License
``python-stiebel-eltron`` is licensed under MIT, for more details check LICENSE.
%package -n python3-pystiebeleltron
Summary: Python API for interacting with the Stiebel Eltron ISG web gateway via Modbus for controlling integral ventilation units and heat pumps.
Provides: python-pystiebeleltron
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pystiebeleltron
# python-stiebel-eltron
Python API for interacting with the STIEBEL ELTRON ISG web gateway via modbus for controlling integral ventilation units and heat pumps.
This module is based on the STIEBEL ELTRON [modbus user manual](https://www.stiebel-eltron.ch/content/dam/ste/ch/de/downloads/kundenservice/smart-home/Modbus/Modbus%20Bedienungsanleitung.pdf), but is not official, developed, supported or endorsed by Stiebel Eltron GmbH & Co. KG. For questions and other inquiries, use the issue tracker in this repo please.
## Requirements
You need to have [Python](https://www.python.org) installed.
* STIEBEL ELTRON Internet-Service Gateway [ISG WEB](https://www.stiebel-eltron.com/en/home/products-solutions/renewables/controller_energymanagement/internet_servicegateway/isg_web.html) with enabled [modbus module](https://www.stiebel-eltron.ch/de/home/service/smart-home/modbus.html)
* You can call the STIEBEL ELTRON support, if your ISG does not have the modbus module enabled. They upgraded mine for free.
* STIEBEL ELTRON heatpumpt (compatible). Successfully used devices:
* LWZ504e
* LWZ304
* Network connection to the ISG WEB
## Installation
The package is available in the [Python Package Index](https://pypi.python.org/).
```bash
$ pip install python-stiebel-eltron
```
## Example usage of the module
The sample below shows how to use this Python module.
```python
from pystiebeleltron import pystiebeleltron as pyse
from pymodbus.client.sync import ModbusTcpClient as ModbusClient
client = ModbusClient(host='IP_ADDRESS_ISG', port=502, timeout=2)
client.connect()
unit = pyse.StiebelEltronAPI(client, 1)
unit.update()
print("get_target_temp: {}".format(unit.get_target_temp))
client.close()
```
## License
``python-stiebel-eltron`` is licensed under MIT, for more details check LICENSE.
%package help
Summary: Development documents and examples for pystiebeleltron
Provides: python3-pystiebeleltron-doc
%description help
# python-stiebel-eltron
Python API for interacting with the STIEBEL ELTRON ISG web gateway via modbus for controlling integral ventilation units and heat pumps.
This module is based on the STIEBEL ELTRON [modbus user manual](https://www.stiebel-eltron.ch/content/dam/ste/ch/de/downloads/kundenservice/smart-home/Modbus/Modbus%20Bedienungsanleitung.pdf), but is not official, developed, supported or endorsed by Stiebel Eltron GmbH & Co. KG. For questions and other inquiries, use the issue tracker in this repo please.
## Requirements
You need to have [Python](https://www.python.org) installed.
* STIEBEL ELTRON Internet-Service Gateway [ISG WEB](https://www.stiebel-eltron.com/en/home/products-solutions/renewables/controller_energymanagement/internet_servicegateway/isg_web.html) with enabled [modbus module](https://www.stiebel-eltron.ch/de/home/service/smart-home/modbus.html)
* You can call the STIEBEL ELTRON support, if your ISG does not have the modbus module enabled. They upgraded mine for free.
* STIEBEL ELTRON heatpumpt (compatible). Successfully used devices:
* LWZ504e
* LWZ304
* Network connection to the ISG WEB
## Installation
The package is available in the [Python Package Index](https://pypi.python.org/).
```bash
$ pip install python-stiebel-eltron
```
## Example usage of the module
The sample below shows how to use this Python module.
```python
from pystiebeleltron import pystiebeleltron as pyse
from pymodbus.client.sync import ModbusTcpClient as ModbusClient
client = ModbusClient(host='IP_ADDRESS_ISG', port=502, timeout=2)
client.connect()
unit = pyse.StiebelEltronAPI(client, 1)
unit.update()
print("get_target_temp: {}".format(unit.get_target_temp))
client.close()
```
## License
``python-stiebel-eltron`` is licensed under MIT, for more details check LICENSE.
%prep
%autosetup -n pystiebeleltron-0.0.1.dev2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pystiebeleltron -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 0.0.1.dev2-1
- Package Spec generated