%global _empty_manifest_terminate_build 0
Name: python-qtwidgets
Version: 1.1
Release: 1
Summary: Custom widget library for PyQt6, PyQt5, PySide6 and PySide2 (Qt for Python). Free to use in your own applications.
License: MIT
URL: http://github.com/learnpyqt/python-qtwidgets
Source0: https://mirrors.aliyun.com/pypi/web/packages/cd/eb/e4e5e238b8d570d748ac09dd81f057a32866b517fbf92b5d71a5c86e5e39/qtwidgets-1.1.tar.gz
BuildArch: noarch
%description
# Custom Qt5 Python Widgets
Qt5 comes with a huge number of widgets built-in, from simple text boxes to digital displays, vector graphics canvas and a full-blown web browser. While you can build perfectly functional applications with the built-in widgets, sometimes your applications will need a *more*.
This repo contains a library of [custom Python Qt5 widgets](https://www.learnpyqt.com/widgets/) which are free to use in your own applications. Widgets are compatible with both PyQt5 and PySide2 (Qt for Python). Currently the repository includes -
| Widgets | Library |
| :---: | :---: |
| ![Graphical Equalizer](https://i.imgur.com/0F2ZgqE.gif)
**Graphical Equalizer**
Visualize audio frequency changes with configurable styles and decay
`from qtwidgets import EqualizerBar`
[Documentation](https://www.learnpyqt.com/widgets/equalizerbar/) | ![Power Meter](https://i.imgur.com/0dpZIMV.gif)
**Power Bar**
Rotary control with amplitude display
`from qtwidgets import PowerBar`
[Documentation](https://www.learnpyqt.com/courses/custom-widgets/creating-your-own-custom-widgets/) |
| ![Palette](https://cdn.learnpyqt.com/media/images/Screenshot_2019-06-15_at_15.18.14.max-500x500.png)
**Palette**
Select colours from a configurable linear or grid palette.
`from qtwidgets import PaletteHorizontal`
`from qtwidgets import PaletteGrid`
[Documentation](https://www.learnpyqt.com/widgets/palette/) | ![Gradient Editor](https://cdn.learnpyqt.com/media/images/Screenshot_2019-06-15_at_18.32.52.max-500x500.png)
**Linear Gradient Editor**
Design custom linear gradients with multiple stops and colours.
`from qtwidgets import Gradient`
[Documentation](https://www.learnpyqt.com/widgets/gradient/)|
| **Color Button**
Simple button that displays and selects colours.
`from qtwidgets import ColorButton` | **Paint**
Draw pictures with a custom bitmap canvas, with colour and pen control.
`from qtwidgets import Paint` |
| **Password Edit**
A password line editor with toggleable visibility action.
`from qtwidgets import PasswordEdit` |![Toggle Widget](https://i.imgur.com/rHrkkG3.gif)
Replace checkboxes with this handy toggle widget, with custom colors and optional animations
`from qtwidgets import Toggle`
`from qtwidgets import AnimatedToggle`
[Documentation](https://www.learnpyqt.com/widgets/toggle/)|
For a more detailed introduction to each widget and a walkthrough of their APIs
see [the custom widget library on LearnPyQt](https://www.learnpyqt.com/widgets/).
More custom widgets will follow, *if you have ideas just let me know!*
**Licensed MIT/BSDv2** feel free to use in your own projects.
%package -n python3-qtwidgets
Summary: Custom widget library for PyQt6, PyQt5, PySide6 and PySide2 (Qt for Python). Free to use in your own applications.
Provides: python-qtwidgets
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-qtwidgets
# Custom Qt5 Python Widgets
Qt5 comes with a huge number of widgets built-in, from simple text boxes to digital displays, vector graphics canvas and a full-blown web browser. While you can build perfectly functional applications with the built-in widgets, sometimes your applications will need a *more*.
This repo contains a library of [custom Python Qt5 widgets](https://www.learnpyqt.com/widgets/) which are free to use in your own applications. Widgets are compatible with both PyQt5 and PySide2 (Qt for Python). Currently the repository includes -
| Widgets | Library |
| :---: | :---: |
| ![Graphical Equalizer](https://i.imgur.com/0F2ZgqE.gif)
**Graphical Equalizer**
Visualize audio frequency changes with configurable styles and decay
`from qtwidgets import EqualizerBar`
[Documentation](https://www.learnpyqt.com/widgets/equalizerbar/) | ![Power Meter](https://i.imgur.com/0dpZIMV.gif)
**Power Bar**
Rotary control with amplitude display
`from qtwidgets import PowerBar`
[Documentation](https://www.learnpyqt.com/courses/custom-widgets/creating-your-own-custom-widgets/) |
| ![Palette](https://cdn.learnpyqt.com/media/images/Screenshot_2019-06-15_at_15.18.14.max-500x500.png)
**Palette**
Select colours from a configurable linear or grid palette.
`from qtwidgets import PaletteHorizontal`
`from qtwidgets import PaletteGrid`
[Documentation](https://www.learnpyqt.com/widgets/palette/) | ![Gradient Editor](https://cdn.learnpyqt.com/media/images/Screenshot_2019-06-15_at_18.32.52.max-500x500.png)
**Linear Gradient Editor**
Design custom linear gradients with multiple stops and colours.
`from qtwidgets import Gradient`
[Documentation](https://www.learnpyqt.com/widgets/gradient/)|
| **Color Button**
Simple button that displays and selects colours.
`from qtwidgets import ColorButton` | **Paint**
Draw pictures with a custom bitmap canvas, with colour and pen control.
`from qtwidgets import Paint` |
| **Password Edit**
A password line editor with toggleable visibility action.
`from qtwidgets import PasswordEdit` |![Toggle Widget](https://i.imgur.com/rHrkkG3.gif)
Replace checkboxes with this handy toggle widget, with custom colors and optional animations
`from qtwidgets import Toggle`
`from qtwidgets import AnimatedToggle`
[Documentation](https://www.learnpyqt.com/widgets/toggle/)|
For a more detailed introduction to each widget and a walkthrough of their APIs
see [the custom widget library on LearnPyQt](https://www.learnpyqt.com/widgets/).
More custom widgets will follow, *if you have ideas just let me know!*
**Licensed MIT/BSDv2** feel free to use in your own projects.
%package help
Summary: Development documents and examples for qtwidgets
Provides: python3-qtwidgets-doc
%description help
# Custom Qt5 Python Widgets
Qt5 comes with a huge number of widgets built-in, from simple text boxes to digital displays, vector graphics canvas and a full-blown web browser. While you can build perfectly functional applications with the built-in widgets, sometimes your applications will need a *more*.
This repo contains a library of [custom Python Qt5 widgets](https://www.learnpyqt.com/widgets/) which are free to use in your own applications. Widgets are compatible with both PyQt5 and PySide2 (Qt for Python). Currently the repository includes -
| Widgets | Library |
| :---: | :---: |
| ![Graphical Equalizer](https://i.imgur.com/0F2ZgqE.gif)
**Graphical Equalizer**
Visualize audio frequency changes with configurable styles and decay
`from qtwidgets import EqualizerBar`
[Documentation](https://www.learnpyqt.com/widgets/equalizerbar/) | ![Power Meter](https://i.imgur.com/0dpZIMV.gif)
**Power Bar**
Rotary control with amplitude display
`from qtwidgets import PowerBar`
[Documentation](https://www.learnpyqt.com/courses/custom-widgets/creating-your-own-custom-widgets/) |
| ![Palette](https://cdn.learnpyqt.com/media/images/Screenshot_2019-06-15_at_15.18.14.max-500x500.png)
**Palette**
Select colours from a configurable linear or grid palette.
`from qtwidgets import PaletteHorizontal`
`from qtwidgets import PaletteGrid`
[Documentation](https://www.learnpyqt.com/widgets/palette/) | ![Gradient Editor](https://cdn.learnpyqt.com/media/images/Screenshot_2019-06-15_at_18.32.52.max-500x500.png)
**Linear Gradient Editor**
Design custom linear gradients with multiple stops and colours.
`from qtwidgets import Gradient`
[Documentation](https://www.learnpyqt.com/widgets/gradient/)|
| **Color Button**
Simple button that displays and selects colours.
`from qtwidgets import ColorButton` | **Paint**
Draw pictures with a custom bitmap canvas, with colour and pen control.
`from qtwidgets import Paint` |
| **Password Edit**
A password line editor with toggleable visibility action.
`from qtwidgets import PasswordEdit` |![Toggle Widget](https://i.imgur.com/rHrkkG3.gif)
Replace checkboxes with this handy toggle widget, with custom colors and optional animations
`from qtwidgets import Toggle`
`from qtwidgets import AnimatedToggle`
[Documentation](https://www.learnpyqt.com/widgets/toggle/)|
For a more detailed introduction to each widget and a walkthrough of their APIs
see [the custom widget library on LearnPyQt](https://www.learnpyqt.com/widgets/).
More custom widgets will follow, *if you have ideas just let me know!*
**Licensed MIT/BSDv2** feel free to use in your own projects.
%prep
%autosetup -n qtwidgets-1.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-qtwidgets -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 1.1-1
- Package Spec generated