%global _empty_manifest_terminate_build 0
Name: python-fretraj
Version: 0.2.6
Release: 1
Summary: Predicting FRET with accessible-contact volumes
License: GPL-3.0-or-later
URL: https://rna-fretools.github.io/
Source0: https://mirrors.aliyun.com/pypi/web/packages/37/2e/9fc1a8e0e6fbbcaadd877700090ae5e957788ca62e1992d1681e40f6e8ba/fretraj-0.2.6.tar.gz
Requires: python3-numpy
Requires: python3-pandas
Requires: python3-numba
Requires: python3-importlib-metadata
Requires: python3-mdtraj
Requires: python3-PyQt5
Requires: python3-tqdm
Requires: python3-jsonschema
%description
1 PyMOL is a trademark of Schrödinger, LLC.
%package -n python3-fretraj
Summary: Predicting FRET with accessible-contact volumes
Provides: python-fretraj
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
BuildRequires: python3-cffi
BuildRequires: gcc
BuildRequires: gdb
%description -n python3-fretraj
1 PyMOL is a trademark of Schrödinger, LLC.
%package help
Summary: Development documents and examples for fretraj
Provides: python3-fretraj-doc
%description help
1 PyMOL is a trademark of Schrödinger, LLC.
%prep
%autosetup -n fretraj-0.2.6
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-fretraj -f filelist.lst
%dir %{python3_sitearch}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 0.2.6-1
- Package Spec generated