%global _empty_manifest_terminate_build 0
Name: python-flask-oidc-ex
Version: 0.6.2
Release: 1
Summary: OpenID Connect extension for Flask - Extended
License: BSD License
URL: https://github.com/larsw/flask-oidc-ex
Source0: https://mirrors.aliyun.com/pypi/web/packages/80/25/70454a61472cb0da5cd483629f8484f1a9f5ad2ed17b7f8aa4f30ed5f7f3/flask-oidc-ex-0.6.2.tar.gz
BuildArch: noarch
Requires: python3-Flask
Requires: python3-itsdangerous
Requires: python3-oauth2client
Requires: python3-six
Requires: python3-jwt
Requires: python3-jwcrypto
Requires: python3-cachetools
Requires: python3-twine
Requires: python3-tox
Requires: python3-bumpversion
Requires: python3-nose
Requires: python3-nosy
%description
`OpenID Connect `_ support for `Flask `_.
This library is a fork of the `flask-oidc ` library, and should work with any standards compliant OpenID Connect provider.
The main contribution that this library provides compared to _flask_oidc_ is the option to locally validate JWT-based access tokens
(based on python-jwt and jwcrypto) instead of calling the OP's userinfo endpoint for validation.
It also provides a way of providing a factory function for _httplib2.Http_ instances, so that SSL certificate validation etc. can be customized properly.
It has been tested with:
* `Keycloak `_
%package -n python3-flask-oidc-ex
Summary: OpenID Connect extension for Flask - Extended
Provides: python-flask-oidc-ex
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-flask-oidc-ex
`OpenID Connect `_ support for `Flask `_.
This library is a fork of the `flask-oidc ` library, and should work with any standards compliant OpenID Connect provider.
The main contribution that this library provides compared to _flask_oidc_ is the option to locally validate JWT-based access tokens
(based on python-jwt and jwcrypto) instead of calling the OP's userinfo endpoint for validation.
It also provides a way of providing a factory function for _httplib2.Http_ instances, so that SSL certificate validation etc. can be customized properly.
It has been tested with:
* `Keycloak `_
%package help
Summary: Development documents and examples for flask-oidc-ex
Provides: python3-flask-oidc-ex-doc
%description help
`OpenID Connect `_ support for `Flask `_.
This library is a fork of the `flask-oidc ` library, and should work with any standards compliant OpenID Connect provider.
The main contribution that this library provides compared to _flask_oidc_ is the option to locally validate JWT-based access tokens
(based on python-jwt and jwcrypto) instead of calling the OP's userinfo endpoint for validation.
It also provides a way of providing a factory function for _httplib2.Http_ instances, so that SSL certificate validation etc. can be customized properly.
It has been tested with:
* `Keycloak `_
%prep
%autosetup -n flask-oidc-ex-0.6.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-flask-oidc-ex -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 0.6.2-1
- Package Spec generated