%global _empty_manifest_terminate_build 0
Name: python-dataplate
Version: 1.0.1
Release: 1
Summary: DataPlate Python API - interact with Dataplate webserver
License: Apache 2.0
URL: https://github.com/Dataplate/dataplate
Source0: https://mirrors.aliyun.com/pypi/web/packages/38/d7/459c630400265367a549b28de06f52c848c6aac80b9e222e3d02a46ea844/dataplate-1.0.1.tar.gz
BuildArch: noarch
Requires: python3-boto3
Requires: python3-awswrangler
Requires: python3-requests
Requires: python3-scrapbook
%description
## Installation
pip install dataplate
## Description
This client communicates with DataPlate platform servers from within your Data-Science development environment
For more info: [DataPlate](http://dataplate.io)
See also our JupyterLab extension: [DataPlate-Lab](https://pypi.org/project/dataplate-lab/)
## Usage using our open-source
First:
Install [DataPlate Portal Web service](./../webapp/README.md) and navigate to "API Documentation" for usage instructions
**More details:**
DataPlate() constructor accepts the following parameters:
env - Environment to retrieve the Data from ('dev' or 'prd').
access_key - Alternative method for supplying your access key.
dataplate_ur - Alternative method for supplying DataPlate Portal URI.
Get the access key from Dataplate Web-service portal (Navigate in Menu to "Private access key"):
This example shows how to run a query, and return results as Pandas DataFrame object:
```
from dataplate.client import DataPlate
dataplate = DataPlate()
df = dataplate.query_to_df('''
SELECT * FROM myTable WHERE `date`='20200218' AND hour=12
''')
```
For more instructions, please refer to the [DataPlate Github](https://github.com/Dataplate)
%package -n python3-dataplate
Summary: DataPlate Python API - interact with Dataplate webserver
Provides: python-dataplate
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-dataplate
## Installation
pip install dataplate
## Description
This client communicates with DataPlate platform servers from within your Data-Science development environment
For more info: [DataPlate](http://dataplate.io)
See also our JupyterLab extension: [DataPlate-Lab](https://pypi.org/project/dataplate-lab/)
## Usage using our open-source
First:
Install [DataPlate Portal Web service](./../webapp/README.md) and navigate to "API Documentation" for usage instructions
**More details:**
DataPlate() constructor accepts the following parameters:
env - Environment to retrieve the Data from ('dev' or 'prd').
access_key - Alternative method for supplying your access key.
dataplate_ur - Alternative method for supplying DataPlate Portal URI.
Get the access key from Dataplate Web-service portal (Navigate in Menu to "Private access key"):
This example shows how to run a query, and return results as Pandas DataFrame object:
```
from dataplate.client import DataPlate
dataplate = DataPlate()
df = dataplate.query_to_df('''
SELECT * FROM myTable WHERE `date`='20200218' AND hour=12
''')
```
For more instructions, please refer to the [DataPlate Github](https://github.com/Dataplate)
%package help
Summary: Development documents and examples for dataplate
Provides: python3-dataplate-doc
%description help
## Installation
pip install dataplate
## Description
This client communicates with DataPlate platform servers from within your Data-Science development environment
For more info: [DataPlate](http://dataplate.io)
See also our JupyterLab extension: [DataPlate-Lab](https://pypi.org/project/dataplate-lab/)
## Usage using our open-source
First:
Install [DataPlate Portal Web service](./../webapp/README.md) and navigate to "API Documentation" for usage instructions
**More details:**
DataPlate() constructor accepts the following parameters:
env - Environment to retrieve the Data from ('dev' or 'prd').
access_key - Alternative method for supplying your access key.
dataplate_ur - Alternative method for supplying DataPlate Portal URI.
Get the access key from Dataplate Web-service portal (Navigate in Menu to "Private access key"):
This example shows how to run a query, and return results as Pandas DataFrame object:
```
from dataplate.client import DataPlate
dataplate = DataPlate()
df = dataplate.query_to_df('''
SELECT * FROM myTable WHERE `date`='20200218' AND hour=12
''')
```
For more instructions, please refer to the [DataPlate Github](https://github.com/Dataplate)
%prep
%autosetup -n dataplate-1.0.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-dataplate -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 1.0.1-1
- Package Spec generated