%global _empty_manifest_terminate_build 0
Name: python-buildflaskapp
Version: 0.3.5
Release: 1
Summary: A flask app generator package
License: Freely Distributable
URL: https://github.com/askyourkode/buildflaskapp
Source0: https://mirrors.aliyun.com/pypi/web/packages/04/c7/ab507c694d44f7445f5accc82d045159a727357b5b76dc02b548628c44bd/buildflaskapp-0.3.5.tar.gz
BuildArch: noarch
Requires: python3-tabulate
%description
-d | $ buildflaskapp app_name -d | debugger mode on
-sl3 | $ buildflaskapp app_name -sl3 | sqlite3 mode on
-cj | $ buildflaskapp app_name -cj | import style.css and app.js
-bs | $ buildflaskapp app_name -bs | import bootstrap cdn
-jq | $ buildflaskapp app_name -jq | import jQuery cdn
-gsap | $ buildflaskapp app_name -gsap | import GSAP cdn
-fa | $ buildflaskapp app_name -fa | import Font Awesome cdn
-dc | $ buildflaskapp app_name -dc | containerize app in docker
Below is a list of arguments you can pass when building your flask application.
##### Enable Debug Mode
You can enable debug mode on while creating your flask app by using the option **-d** or **--debugger**
```
$ buildflaskapp app_name -d
```
##### Enable SQLite3 Mode
You can set sqlite3 configuration while creating your flask app by using the option **-sl3** or **--sqlite3**
```
$ buildflaskapp app_name -sl3
```
##### Import style.css and app.js
You can import stylesheet and javascript file automatically while creating the app using **-cj** or **--css-js** option
```
$ buildflaskapp app_name -cj
```
##### Import bootstrap CDN
You can import bootstrap automatically via the CDN using **-bs** or **--bootstrap** option
```
$ buildflaskapp app_name -bs
```
##### Import jQuery CDN
You can import jQuery automatically via the CDN using **-jq** or **--jquery** option
```
$ buildflaskapp app_name -jq
```
##### Import Gsap CDN
You can import Gsap automatically via the CDN using **-gsap** or **--gsap** option
```
$ buildflaskapp app_name -gsap
```
##### Import Font Awesome CDN
You can import Font Awesome automatically via the CDN using **-fa** or **--font-awesome** option
```
$ buildflaskapp app_name -fa
```
##### Create Dockerfile and docker-compose script
You can push the app to a docker container instead of running it locally. Simply use **-dc** or **--docker-container** option. Please note that the image generated in Dockerfile is *python:3.7-alpine*. You might want to change this to the non-alpine version for big projects
```
$ buildflaskapp app_name -dC
```
### Features
- [x] Manual(--help)
- [x] Debug option on (-d)
- [x] SQLite3 option on (-sl3)
- [x] Include Stylesheet and Script (-cj)
- [x] Push app to docker container (-dc)
- [x] Import bootstrap css library (-bs)
- [x] Import jQuery library (-jq)
- [x] Import gsap js library (-gsap)
- [x] Import font awesome library (-fa)
- [ ] Import zurb foundations library (-zb)
- [ ] Import angular js library (-an)
- [ ] Deploy on heroku (-hK)
Feel free to create issue in case something is not working :)
%package -n python3-buildflaskapp
Summary: A flask app generator package
Provides: python-buildflaskapp
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-buildflaskapp
-d | $ buildflaskapp app_name -d | debugger mode on
-sl3 | $ buildflaskapp app_name -sl3 | sqlite3 mode on
-cj | $ buildflaskapp app_name -cj | import style.css and app.js
-bs | $ buildflaskapp app_name -bs | import bootstrap cdn
-jq | $ buildflaskapp app_name -jq | import jQuery cdn
-gsap | $ buildflaskapp app_name -gsap | import GSAP cdn
-fa | $ buildflaskapp app_name -fa | import Font Awesome cdn
-dc | $ buildflaskapp app_name -dc | containerize app in docker
Below is a list of arguments you can pass when building your flask application.
##### Enable Debug Mode
You can enable debug mode on while creating your flask app by using the option **-d** or **--debugger**
```
$ buildflaskapp app_name -d
```
##### Enable SQLite3 Mode
You can set sqlite3 configuration while creating your flask app by using the option **-sl3** or **--sqlite3**
```
$ buildflaskapp app_name -sl3
```
##### Import style.css and app.js
You can import stylesheet and javascript file automatically while creating the app using **-cj** or **--css-js** option
```
$ buildflaskapp app_name -cj
```
##### Import bootstrap CDN
You can import bootstrap automatically via the CDN using **-bs** or **--bootstrap** option
```
$ buildflaskapp app_name -bs
```
##### Import jQuery CDN
You can import jQuery automatically via the CDN using **-jq** or **--jquery** option
```
$ buildflaskapp app_name -jq
```
##### Import Gsap CDN
You can import Gsap automatically via the CDN using **-gsap** or **--gsap** option
```
$ buildflaskapp app_name -gsap
```
##### Import Font Awesome CDN
You can import Font Awesome automatically via the CDN using **-fa** or **--font-awesome** option
```
$ buildflaskapp app_name -fa
```
##### Create Dockerfile and docker-compose script
You can push the app to a docker container instead of running it locally. Simply use **-dc** or **--docker-container** option. Please note that the image generated in Dockerfile is *python:3.7-alpine*. You might want to change this to the non-alpine version for big projects
```
$ buildflaskapp app_name -dC
```
### Features
- [x] Manual(--help)
- [x] Debug option on (-d)
- [x] SQLite3 option on (-sl3)
- [x] Include Stylesheet and Script (-cj)
- [x] Push app to docker container (-dc)
- [x] Import bootstrap css library (-bs)
- [x] Import jQuery library (-jq)
- [x] Import gsap js library (-gsap)
- [x] Import font awesome library (-fa)
- [ ] Import zurb foundations library (-zb)
- [ ] Import angular js library (-an)
- [ ] Deploy on heroku (-hK)
Feel free to create issue in case something is not working :)
%package help
Summary: Development documents and examples for buildflaskapp
Provides: python3-buildflaskapp-doc
%description help
-d | $ buildflaskapp app_name -d | debugger mode on
-sl3 | $ buildflaskapp app_name -sl3 | sqlite3 mode on
-cj | $ buildflaskapp app_name -cj | import style.css and app.js
-bs | $ buildflaskapp app_name -bs | import bootstrap cdn
-jq | $ buildflaskapp app_name -jq | import jQuery cdn
-gsap | $ buildflaskapp app_name -gsap | import GSAP cdn
-fa | $ buildflaskapp app_name -fa | import Font Awesome cdn
-dc | $ buildflaskapp app_name -dc | containerize app in docker
Below is a list of arguments you can pass when building your flask application.
##### Enable Debug Mode
You can enable debug mode on while creating your flask app by using the option **-d** or **--debugger**
```
$ buildflaskapp app_name -d
```
##### Enable SQLite3 Mode
You can set sqlite3 configuration while creating your flask app by using the option **-sl3** or **--sqlite3**
```
$ buildflaskapp app_name -sl3
```
##### Import style.css and app.js
You can import stylesheet and javascript file automatically while creating the app using **-cj** or **--css-js** option
```
$ buildflaskapp app_name -cj
```
##### Import bootstrap CDN
You can import bootstrap automatically via the CDN using **-bs** or **--bootstrap** option
```
$ buildflaskapp app_name -bs
```
##### Import jQuery CDN
You can import jQuery automatically via the CDN using **-jq** or **--jquery** option
```
$ buildflaskapp app_name -jq
```
##### Import Gsap CDN
You can import Gsap automatically via the CDN using **-gsap** or **--gsap** option
```
$ buildflaskapp app_name -gsap
```
##### Import Font Awesome CDN
You can import Font Awesome automatically via the CDN using **-fa** or **--font-awesome** option
```
$ buildflaskapp app_name -fa
```
##### Create Dockerfile and docker-compose script
You can push the app to a docker container instead of running it locally. Simply use **-dc** or **--docker-container** option. Please note that the image generated in Dockerfile is *python:3.7-alpine*. You might want to change this to the non-alpine version for big projects
```
$ buildflaskapp app_name -dC
```
### Features
- [x] Manual(--help)
- [x] Debug option on (-d)
- [x] SQLite3 option on (-sl3)
- [x] Include Stylesheet and Script (-cj)
- [x] Push app to docker container (-dc)
- [x] Import bootstrap css library (-bs)
- [x] Import jQuery library (-jq)
- [x] Import gsap js library (-gsap)
- [x] Import font awesome library (-fa)
- [ ] Import zurb foundations library (-zb)
- [ ] Import angular js library (-an)
- [ ] Deploy on heroku (-hK)
Feel free to create issue in case something is not working :)
%prep
%autosetup -n buildflaskapp-0.3.5
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-buildflaskapp -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 0.3.5-1
- Package Spec generated