%global _empty_manifest_terminate_build 0
Name: python-colourmap
Version: 1.1.14
Release: 1
Summary: Python package colourmap generates an N unique colors from the specified input colormap.
License: MIT License
URL: https://erdogant.github.io/colourmap
Source0: https://mirrors.aliyun.com/pypi/web/packages/9c/ae/7a7ae7ba44c164e2790dc76dd8d06712af7ddcc8c8ee6dde0dea2db96df8/colourmap-1.1.14.tar.gz
BuildArch: noarch
Requires: python3-matplotlib
Requires: python3-numpy
%description
# colourmap
[](https://img.shields.io/pypi/pyversions/colourmap)
[](https://pypi.org/project/colourmap/)
[](https://github.com/erdogant/colourmap/blob/master/LICENSE)
[](https://github.com/erdogant/colourmap/network)
[](https://github.com/erdogant/colourmap/issues)
[](http://www.repostatus.org/#active)
[](https://pepy.tech/project/colourmap)
[](https://pepy.tech/project/colourmap)
[](https://erdogant.github.io/colourmap/)
*`` Colourmap`` generates an unique lit of RGB and HEX colors for the specified input list.
#
**⭐️ Star this repo if you like it ⭐️**
#
### [Documentation pages](https://erdogant.github.io/colourmap/)
On the [documentation pages](https://erdogant.github.io/colourmap/) you can find more information about ``colourmap`` with examples.
#
##### Install colourmap from PyPI
```bash
pip install colourmap # normal install
pip install -U colourmap # update if needed
```
### Import colourmap package
```python
from colourmap import colourmap
```
#### Quick example
Use the documentation pages for more detailed usage. Some of the most used functionalities are linked below.
```python
from colourmap import colourmap
# Create N colors
c = colourmap.generate(10)
# From list
c_rgb, c_dict = colourmap.fromlist([1,1,2,2,3,1,2,3])
# to HEX
c_hex = colourmap.rgb2hex(c_rgb)
```
#
#### [Example: Generate N unique colors from a specific colormap](https://erdogant.github.io/colourmap/pages/html/Examples.html#)
#
#### [Example: Generate unique colors based on input labels](https://erdogant.github.io/colourmap/pages/html/Examples.html#create-color-based-on-input-labels)
#
#### [Example: Create unique colors based on seaborn or matplotlib](https://erdogant.github.io/colourmap/pages/html/Examples.html#color-generated-by-seaborn-and-matplotlib)
#
#### [Example: Conversion RGB to HEX](https://erdogant.github.io/colourmap/pages/html/Examples.html#convert-rgb-to-hex)
#
#### [Example: Conversion HEX to RGB](https://erdogant.github.io/colourmap/pages/html/Examples.html#convert-rgb-to-hex)
#
#### [Example: Create a linear gradient between colors](https://erdogant.github.io/colourmap/pages/html/Examples.html#linear-gradient-between-two-colors)
### Maintainer
* Erdogan Taskesen, github: [erdogant](https://github.com/erdogant)
* Contributions are welcome.
* For citations, please use the citation at the right side panel.
* If you wish to buy me a Coffee for this work, it is very appreciated :)
%package -n python3-colourmap
Summary: Python package colourmap generates an N unique colors from the specified input colormap.
Provides: python-colourmap
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-colourmap
# colourmap
[](https://img.shields.io/pypi/pyversions/colourmap)
[](https://pypi.org/project/colourmap/)
[](https://github.com/erdogant/colourmap/blob/master/LICENSE)
[](https://github.com/erdogant/colourmap/network)
[](https://github.com/erdogant/colourmap/issues)
[](http://www.repostatus.org/#active)
[](https://pepy.tech/project/colourmap)
[](https://pepy.tech/project/colourmap)
[](https://erdogant.github.io/colourmap/)
*`` Colourmap`` generates an unique lit of RGB and HEX colors for the specified input list.
#
**⭐️ Star this repo if you like it ⭐️**
#
### [Documentation pages](https://erdogant.github.io/colourmap/)
On the [documentation pages](https://erdogant.github.io/colourmap/) you can find more information about ``colourmap`` with examples.
#
##### Install colourmap from PyPI
```bash
pip install colourmap # normal install
pip install -U colourmap # update if needed
```
### Import colourmap package
```python
from colourmap import colourmap
```
#### Quick example
Use the documentation pages for more detailed usage. Some of the most used functionalities are linked below.
```python
from colourmap import colourmap
# Create N colors
c = colourmap.generate(10)
# From list
c_rgb, c_dict = colourmap.fromlist([1,1,2,2,3,1,2,3])
# to HEX
c_hex = colourmap.rgb2hex(c_rgb)
```
#
#### [Example: Generate N unique colors from a specific colormap](https://erdogant.github.io/colourmap/pages/html/Examples.html#)
#
#### [Example: Generate unique colors based on input labels](https://erdogant.github.io/colourmap/pages/html/Examples.html#create-color-based-on-input-labels)
#
#### [Example: Create unique colors based on seaborn or matplotlib](https://erdogant.github.io/colourmap/pages/html/Examples.html#color-generated-by-seaborn-and-matplotlib)
#
#### [Example: Conversion RGB to HEX](https://erdogant.github.io/colourmap/pages/html/Examples.html#convert-rgb-to-hex)
#
#### [Example: Conversion HEX to RGB](https://erdogant.github.io/colourmap/pages/html/Examples.html#convert-rgb-to-hex)
#
#### [Example: Create a linear gradient between colors](https://erdogant.github.io/colourmap/pages/html/Examples.html#linear-gradient-between-two-colors)
### Maintainer
* Erdogan Taskesen, github: [erdogant](https://github.com/erdogant)
* Contributions are welcome.
* For citations, please use the citation at the right side panel.
* If you wish to buy me a Coffee for this work, it is very appreciated :)
%package help
Summary: Development documents and examples for colourmap
Provides: python3-colourmap-doc
%description help
# colourmap
[](https://img.shields.io/pypi/pyversions/colourmap)
[](https://pypi.org/project/colourmap/)
[](https://github.com/erdogant/colourmap/blob/master/LICENSE)
[](https://github.com/erdogant/colourmap/network)
[](https://github.com/erdogant/colourmap/issues)
[](http://www.repostatus.org/#active)
[](https://pepy.tech/project/colourmap)
[](https://pepy.tech/project/colourmap)
[](https://erdogant.github.io/colourmap/)
*`` Colourmap`` generates an unique lit of RGB and HEX colors for the specified input list.
#
**⭐️ Star this repo if you like it ⭐️**
#
### [Documentation pages](https://erdogant.github.io/colourmap/)
On the [documentation pages](https://erdogant.github.io/colourmap/) you can find more information about ``colourmap`` with examples.
#
##### Install colourmap from PyPI
```bash
pip install colourmap # normal install
pip install -U colourmap # update if needed
```
### Import colourmap package
```python
from colourmap import colourmap
```
#### Quick example
Use the documentation pages for more detailed usage. Some of the most used functionalities are linked below.
```python
from colourmap import colourmap
# Create N colors
c = colourmap.generate(10)
# From list
c_rgb, c_dict = colourmap.fromlist([1,1,2,2,3,1,2,3])
# to HEX
c_hex = colourmap.rgb2hex(c_rgb)
```
#
#### [Example: Generate N unique colors from a specific colormap](https://erdogant.github.io/colourmap/pages/html/Examples.html#)
#
#### [Example: Generate unique colors based on input labels](https://erdogant.github.io/colourmap/pages/html/Examples.html#create-color-based-on-input-labels)
#
#### [Example: Create unique colors based on seaborn or matplotlib](https://erdogant.github.io/colourmap/pages/html/Examples.html#color-generated-by-seaborn-and-matplotlib)
#
#### [Example: Conversion RGB to HEX](https://erdogant.github.io/colourmap/pages/html/Examples.html#convert-rgb-to-hex)
#
#### [Example: Conversion HEX to RGB](https://erdogant.github.io/colourmap/pages/html/Examples.html#convert-rgb-to-hex)
#
#### [Example: Create a linear gradient between colors](https://erdogant.github.io/colourmap/pages/html/Examples.html#linear-gradient-between-two-colors)
### Maintainer
* Erdogan Taskesen, github: [erdogant](https://github.com/erdogant)
* Contributions are welcome.
* For citations, please use the citation at the right side panel.
* If you wish to buy me a Coffee for this work, it is very appreciated :)
%prep
%autosetup -n colourmap-1.1.14
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-colourmap -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 1.1.14-1
- Package Spec generated