%global _empty_manifest_terminate_build 0
Name: python-requests-xml
Version: 0.2.3
Release: 1
Summary: XML Parsing for humans.
License: MIT
URL: https://github.com/erinxocon/requests-xml
Source0: https://mirrors.aliyun.com/pypi/web/packages/e4/6f/50c80681e25473ebf4750d7a8c8781afd147f9820faae3430487bbce5bda/requests-xml-0.2.3.tar.gz
BuildArch: noarch
Requires: python3-requests
Requires: python3-pyquery
Requires: python3-fake-useragent
Requires: python3-parse
Requires: python3-w3lib
Requires: python3-xmljson
%description
This library intends to make parsing XML as
simple and intuitive as possible. **Requests-XML** is related
to the amazing `Requests-HTML `_
and delivers the same quality of user experience — with support for our beloved XML documents.
When using this library you automatically get:
- *XPath Selectors*, for the *brave* at heart.
- *Simple Search/Find* for the *faint* at heart.
- XML to JSON conversion thanks to `xmljson `_.
- Mocked user-agent (like a real web browser).
- Connection–pooling and cookie persistence.
- The Requests experience you know and love, with magical XML parsing abilities.
%package -n python3-requests-xml
Summary: XML Parsing for humans.
Provides: python-requests-xml
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-requests-xml
This library intends to make parsing XML as
simple and intuitive as possible. **Requests-XML** is related
to the amazing `Requests-HTML `_
and delivers the same quality of user experience — with support for our beloved XML documents.
When using this library you automatically get:
- *XPath Selectors*, for the *brave* at heart.
- *Simple Search/Find* for the *faint* at heart.
- XML to JSON conversion thanks to `xmljson `_.
- Mocked user-agent (like a real web browser).
- Connection–pooling and cookie persistence.
- The Requests experience you know and love, with magical XML parsing abilities.
%package help
Summary: Development documents and examples for requests-xml
Provides: python3-requests-xml-doc
%description help
This library intends to make parsing XML as
simple and intuitive as possible. **Requests-XML** is related
to the amazing `Requests-HTML `_
and delivers the same quality of user experience — with support for our beloved XML documents.
When using this library you automatically get:
- *XPath Selectors*, for the *brave* at heart.
- *Simple Search/Find* for the *faint* at heart.
- XML to JSON conversion thanks to `xmljson `_.
- Mocked user-agent (like a real web browser).
- Connection–pooling and cookie persistence.
- The Requests experience you know and love, with magical XML parsing abilities.
%prep
%autosetup -n requests-xml-0.2.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-requests-xml -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 0.2.3-1
- Package Spec generated