%global _empty_manifest_terminate_build 0
Name: python-napari-imaris-loader
Version: 0.1.8
Release: 1
Summary: Napari plugin for loading Bitplane imaris files '.ims'
License: BSD-3-Clause
URL: https://github.com/AlanMWatson/napari-imaris-loader
Source0: https://mirrors.aliyun.com/pypi/web/packages/b9/da/93b4b1c29a58b23e3a640781db8d0a0f4951ff7eecae27cb96c214c170ee/napari-imaris-loader-0.1.8.tar.gz
BuildArch: noarch
Requires: python3-napari[all]
Requires: python3-napari-plugin-engine
Requires: python3-imaris-ims-file-reader
Requires: python3-numpy
Requires: python3-h5py
Requires: python3-dask
%description
This [napari] plugin was generated with [Cookiecutter] using with [@napari]'s [cookiecutter-napari-plugin] template.
## Installation
You can install `napari-imaris-loader` via [pip]:
pip install napari-imaris-loader
## Change Log:
##### v0.1.2:
**Fixed:** Issue where .ims files containing a single color 2D image would not open.
**Fixed:** Issue where using the widget to change resolutions while in 3D rendering would cause a crash. Now the viewer is automatically forced into 2D rendering mode when the widget is used.
**Dependency change:** The loader is now dependent in a separate package for loading IMS files. https://pypi.org/project/imaris-ims-file-reader/
**v0.1.3:**
Documentation
**v0.1.4:**
Add napari to install requirements for plugin compatibility
**v0.1.5:**
Changes to napari:
- now requires napari[all] upon install.
- requires >=v0.1.5 of imaris-ims-file-reader
**v0.1.6:**
- Fix issue #7 where contrastLimits possibly unbound in reader
**v0.1.7:**
- For squeeze_output=False when opening .ims file for Napari compatibility
**v0.1.8:**
- Add automatic determination of contrast_limits
- Fix bug in squeeze_output
## Contributing
Contributions are very welcome. Tests can be run with [tox], please ensure
the coverage at least stays the same before you submit a pull request.
## License
Distributed under the terms of the [BSD-3] license,
"napari-imaris-loader" is free and open source software
## Issues
If you encounter any problems, please [file an issue] along with a detailed description.
[napari]: https://github.com/napari/napari
[Cookiecutter]: https://github.com/audreyr/cookiecutter
[@napari]: https://github.com/napari
[MIT]: http://opensource.org/licenses/MIT
[BSD-3]: http://opensource.org/licenses/BSD-3-Clause
[GNU GPL v3.0]: http://www.gnu.org/licenses/gpl-3.0.txt
[GNU LGPL v3.0]: http://www.gnu.org/licenses/lgpl-3.0.txt
[Apache Software License 2.0]: http://www.apache.org/licenses/LICENSE-2.0
[Mozilla Public License 2.0]: https://www.mozilla.org/media/MPL/2.0/index.txt
[cookiecutter-napari-plugin]: https://github.com/napari/cookiecutter-napari-plugin
[file an issue]: https://github.com/AlanMWatson/napari-imaris-loader/issues
[napari]: https://github.com/napari/napari
[tox]: https://tox.readthedocs.io/en/latest/
[pip]: https://pypi.org/project/pip/
[PyPI]: https://pypi.org/
%package -n python3-napari-imaris-loader
Summary: Napari plugin for loading Bitplane imaris files '.ims'
Provides: python-napari-imaris-loader
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-napari-imaris-loader
This [napari] plugin was generated with [Cookiecutter] using with [@napari]'s [cookiecutter-napari-plugin] template.
## Installation
You can install `napari-imaris-loader` via [pip]:
pip install napari-imaris-loader
## Change Log:
##### v0.1.2:
**Fixed:** Issue where .ims files containing a single color 2D image would not open.
**Fixed:** Issue where using the widget to change resolutions while in 3D rendering would cause a crash. Now the viewer is automatically forced into 2D rendering mode when the widget is used.
**Dependency change:** The loader is now dependent in a separate package for loading IMS files. https://pypi.org/project/imaris-ims-file-reader/
**v0.1.3:**
Documentation
**v0.1.4:**
Add napari to install requirements for plugin compatibility
**v0.1.5:**
Changes to napari:
- now requires napari[all] upon install.
- requires >=v0.1.5 of imaris-ims-file-reader
**v0.1.6:**
- Fix issue #7 where contrastLimits possibly unbound in reader
**v0.1.7:**
- For squeeze_output=False when opening .ims file for Napari compatibility
**v0.1.8:**
- Add automatic determination of contrast_limits
- Fix bug in squeeze_output
## Contributing
Contributions are very welcome. Tests can be run with [tox], please ensure
the coverage at least stays the same before you submit a pull request.
## License
Distributed under the terms of the [BSD-3] license,
"napari-imaris-loader" is free and open source software
## Issues
If you encounter any problems, please [file an issue] along with a detailed description.
[napari]: https://github.com/napari/napari
[Cookiecutter]: https://github.com/audreyr/cookiecutter
[@napari]: https://github.com/napari
[MIT]: http://opensource.org/licenses/MIT
[BSD-3]: http://opensource.org/licenses/BSD-3-Clause
[GNU GPL v3.0]: http://www.gnu.org/licenses/gpl-3.0.txt
[GNU LGPL v3.0]: http://www.gnu.org/licenses/lgpl-3.0.txt
[Apache Software License 2.0]: http://www.apache.org/licenses/LICENSE-2.0
[Mozilla Public License 2.0]: https://www.mozilla.org/media/MPL/2.0/index.txt
[cookiecutter-napari-plugin]: https://github.com/napari/cookiecutter-napari-plugin
[file an issue]: https://github.com/AlanMWatson/napari-imaris-loader/issues
[napari]: https://github.com/napari/napari
[tox]: https://tox.readthedocs.io/en/latest/
[pip]: https://pypi.org/project/pip/
[PyPI]: https://pypi.org/
%package help
Summary: Development documents and examples for napari-imaris-loader
Provides: python3-napari-imaris-loader-doc
%description help
This [napari] plugin was generated with [Cookiecutter] using with [@napari]'s [cookiecutter-napari-plugin] template.
## Installation
You can install `napari-imaris-loader` via [pip]:
pip install napari-imaris-loader
## Change Log:
##### v0.1.2:
**Fixed:** Issue where .ims files containing a single color 2D image would not open.
**Fixed:** Issue where using the widget to change resolutions while in 3D rendering would cause a crash. Now the viewer is automatically forced into 2D rendering mode when the widget is used.
**Dependency change:** The loader is now dependent in a separate package for loading IMS files. https://pypi.org/project/imaris-ims-file-reader/
**v0.1.3:**
Documentation
**v0.1.4:**
Add napari to install requirements for plugin compatibility
**v0.1.5:**
Changes to napari:
- now requires napari[all] upon install.
- requires >=v0.1.5 of imaris-ims-file-reader
**v0.1.6:**
- Fix issue #7 where contrastLimits possibly unbound in reader
**v0.1.7:**
- For squeeze_output=False when opening .ims file for Napari compatibility
**v0.1.8:**
- Add automatic determination of contrast_limits
- Fix bug in squeeze_output
## Contributing
Contributions are very welcome. Tests can be run with [tox], please ensure
the coverage at least stays the same before you submit a pull request.
## License
Distributed under the terms of the [BSD-3] license,
"napari-imaris-loader" is free and open source software
## Issues
If you encounter any problems, please [file an issue] along with a detailed description.
[napari]: https://github.com/napari/napari
[Cookiecutter]: https://github.com/audreyr/cookiecutter
[@napari]: https://github.com/napari
[MIT]: http://opensource.org/licenses/MIT
[BSD-3]: http://opensource.org/licenses/BSD-3-Clause
[GNU GPL v3.0]: http://www.gnu.org/licenses/gpl-3.0.txt
[GNU LGPL v3.0]: http://www.gnu.org/licenses/lgpl-3.0.txt
[Apache Software License 2.0]: http://www.apache.org/licenses/LICENSE-2.0
[Mozilla Public License 2.0]: https://www.mozilla.org/media/MPL/2.0/index.txt
[cookiecutter-napari-plugin]: https://github.com/napari/cookiecutter-napari-plugin
[file an issue]: https://github.com/AlanMWatson/napari-imaris-loader/issues
[napari]: https://github.com/napari/napari
[tox]: https://tox.readthedocs.io/en/latest/
[pip]: https://pypi.org/project/pip/
[PyPI]: https://pypi.org/
%prep
%autosetup -n napari-imaris-loader-0.1.8
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-napari-imaris-loader -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 0.1.8-1
- Package Spec generated