%global _empty_manifest_terminate_build 0
Name: python-Avena
Version: 1.7
Release: 1
Summary: Avena is an image processing library and command-line tool.
License: ISC
URL: https://bitbucket.org/eliteraspberries/avena
Source0: https://mirrors.aliyun.com/pypi/web/packages/0f/3d/bb5a647f021d586890395f252f7b2fc03adc6b983792988fbf1f940f040f/Avena-1.7.tar.gz
BuildArch: noarch
%description
Avena requires:
- `Python `__ (version 2 or 3);
- the `Python Imaging
Library `__ (PIL) or
`Pillow `__;
- `NumPy `__;
- `pyglet `__;
- and `docopt `__.
Install Avena with `pip `__:
pip install avena
%package -n python3-Avena
Summary: Avena is an image processing library and command-line tool.
Provides: python-Avena
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-Avena
Avena requires:
- `Python `__ (version 2 or 3);
- the `Python Imaging
Library `__ (PIL) or
`Pillow `__;
- `NumPy `__;
- `pyglet `__;
- and `docopt `__.
Install Avena with `pip `__:
pip install avena
%package help
Summary: Development documents and examples for Avena
Provides: python3-Avena-doc
%description help
Avena requires:
- `Python `__ (version 2 or 3);
- the `Python Imaging
Library `__ (PIL) or
`Pillow `__;
- `NumPy `__;
- `pyglet `__;
- and `docopt `__.
Install Avena with `pip `__:
pip install avena
%prep
%autosetup -n Avena-1.7
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-Avena -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 1.7-1
- Package Spec generated