%global _empty_manifest_terminate_build 0
Name: python-gaphor
Version: 2.18.1
Release: 1
Summary: Gaphor is the simple modeling tool written in Python.
License: Apache Software License
URL: https://gaphor.org/
Source0: https://mirrors.aliyun.com/pypi/web/packages/29/0e/65a45aa686e9db2d90e3fa4dabbba3a546c29424dc1c3bae62073ee015b7/gaphor-2.18.1.tar.gz
BuildArch: noarch
Requires: python3-PyGObject
Requires: python3-babel
Requires: python3-better-exceptions
Requires: python3-furo
Requires: python3-gaphas
Requires: python3-generic
Requires: python3-jedi
Requires: python3-myst-nb
Requires: python3-pycairo
Requires: python3-pydot
Requires: python3-pygit2
Requires: python3-pyobjc-framework-cocoa
Requires: python3-sphinx
Requires: python3-sphinx-copybutton
Requires: python3-sphinx-intl
Requires: python3-tinycss2
%description
[![Build](https://github.com/gaphor/gaphor/actions/workflows/full-build.yml/badge.svg)](https://github.com/gaphor/gaphor/actions/workflows/full-build.yml?query=branch%3Amain)
[![Hypothesis Tests](https://github.com/gaphor/gaphor/actions/workflows/hypothesis-test.yml/badge.svg)](https://github.com/gaphor/gaphor/actions/workflows/hypothesis-test.yml?query=branch%3Amain)
[![Docs build state](https://readthedocs.org/projects/gaphor/badge/?version=latest)](https://docs.gaphor.org)
[![PyPI](https://img.shields.io/pypi/v/gaphor.svg)](https://pypi.org/project/gaphor)
[![PyPI - Downloads](https://img.shields.io/pypi/dm/gaphor)](https://pypistats.org/packages/gaphor)
[![Matrix](https://img.shields.io/badge/chat-on%20Matrix-success)](https://app.element.io/#/room/#gaphor_Lobby:gitter.im)
[![Maintainability](https://api.codeclimate.com/v1/badges/f00974f5d7fe69fe4ecd/maintainability)](https://codeclimate.com/github/gaphor/gaphor/maintainability)
[![Test Coverage](https://api.codeclimate.com/v1/badges/f00974f5d7fe69fe4ecd/test_coverage)](https://codeclimate.com/github/gaphor/gaphor/test_coverage)
[![Translation Status](https://hosted.weblate.org/widgets/gaphor/-/gaphor/svg-badge.svg)](https://hosted.weblate.org/engage/gaphor)
[![Sourcery](https://img.shields.io/badge/Sourcery-enabled-brightgreen)](https://sourcery.ai)
[![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/ambv/black)
[![standard-readme compliant](https://img.shields.io/badge/readme%20style-standard-brightgreen.svg)](https://github.com/RichardLitt/standard-readme)
[![All Contributors](https://img.shields.io/badge/all_contributors-32-brightgreen.svg)](#contributors)
Gaphor is a UML and SysML modeling application written in Python.
It is designed to be easy to use, while still being powerful. Gaphor implements a fully-compliant UML 2 data model, so it is much more than a picture drawing tool. You can use Gaphor to quickly visualize different aspects of a system as well as create complete, highly complex models.
## π Table of Contents
- [π Table of Contents](#-table-of-contents)
- [π Background](#-background)
- [πΎ Install](#-install)
- [π¦ Usage](#-usage)
- [β₯ Contributing](#-contributing)
- [π Translations](#-translations)
- [βΏοΈ Code of Conduct](#οΈ-code-of-conduct)
- [Β©οΈ License](#οΈ-license)
## π Background
Gaphor is a UML and SysML modeling application written in Python. We designed
it to be easy to use, while still being powerful. Gaphor implements a
fully-compliant UML 2 data model, so it is much more than a picture drawing
tool. You can use Gaphor to quickly visualize different aspects of a system as
well as create complete, highly complex models.
Gaphor is designed around the following principles:
- Simplicity: The application should be easy to use. Only some basic knowledge of UML or SysML is required.
- Consistency: UML is a graphical modeling language, so all modeling is done in a diagram.
- Workability: The application should not bother the user every time they do something non-UML-ish.
Gaphor is a GUI application. It has a modern [GTK](https://gtk.org)-based interface and uses
[Cairo](https://www.cairographics.org/) for consistent rendering.
Gaphor is a library.
You can use it from [scripts and Jupyter notebooks](https://docs.gaphor.org/en/latest/scripting.html)
and interact with models programmatically.
Non-Goals:
- Generating UML diagrams from source code. [pynsource](https://github.com/abulka/pynsource) or [pyreverse](https://github.com/pylint-dev/pylint/tree/main/pylint/pyreverse) might be what you are looking for.
- Generating source code from diagrams or creating other concrete executable artifacts including use of fUML or ALF.
Although it would be possible to incorporate these features, these aren't the
goals of this project. However, if these are important capabilities for you,
you may be able to extend Gaphor by creating a
[plugin](https://docs.gaphor.org/en/latest/service_oriented.html#example-plugin).
## πΎ Install
You can find [the latest version](https://gaphor.org/download) on the
[gaphor.org website](https://gaphor.org/download). Gaphor ships installers for
macOS and Windows. Those can be found there. The Python package is also
[available on PyPI](https://pypi.org/project/gaphor/).
All releases are available on
[GitHub](https://github.com/gaphor/gaphor/releases/).
If you want to start developing on Gaphor, have a look at the [Installation
section of our Tech docs](https://docs.gaphor.org/en/latest/).
## π¦ Usage
If using Gaphor for the first time you will be presented with a greeter dialog
at startup in which you can select one of 5 models available to you to work in:
- **Generic:** (or blank) template
- **UML:** *Unified Modeling Language* template
- **SysML:** *Systems Modeling Language* template
- **RAAML:** *Risk Analysis and Assessment Modeling language* template
- **C4 Model:** *a lean graphical notation technique for modelling the architecture of software systems* template
After you select a template, the main Gaphor Window will load, and you will be
ready to start modeling. Gaphor will automatically select the correct profile
based on the template that you selected, but you can also select other modeling
profiles if needed by clicking on the button next to the Profile dropdown menu
at the top of your window.
To select an element you want to place, for example a Class, click on the icon
in the Toolbox and then again on the diagram. This will place a new Class item
on the diagram and add a new Class to the model (it shows up in the Navigation).
The selected tool will reset itself to the Pointer tool if the option ''Diagram
β Reset tool'' is selected.
Portions of the toolbox may also be collapsed depending on the type of diagram
you are modeling with. You can expand the collapsed portions of the toolbox if
needed.
If you want to know more, please read our documentation on https://docs.gaphor.org.
## β₯ Contributing
Thanks goes to these wonderful people ([emoji key](https://github.com/kentcdodds/all-contributors#emoji-key)):
This project follows the
[all-contributors](https://github.com/kentcdodds/all-contributors)
specification. Contributions of any kind are welcome!
1. Check for open issues or open a fresh issue to start a discussion
around a feature idea or a bug. There is a
[first-timers-only](https://github.com/gaphor/gaphor/issues?utf8=%E2%9C%93&q=is%3Aissue+is%3Aopen+label%3Afirst-timers-only)
tag for issues that should be ideal for people who are not very
familiar with the codebase yet.
2. Fork [the repository](https://github.com/gaphor/gaphor) on
GitHub to start making your changes to the **main** branch (or
branch off of it).
3. Write a test which shows that the bug was fixed or that the feature
works as expected.
4. Send a pull request and bug the maintainers until it gets merged and
published. :smile:
See [the contributing guide](CONTRIBUTING.md)!
### π Translations
Translation of Gaphor is mostly done using
[Weblate](https://hosted.weblate.org/projects/gaphor/gaphor/).
For the Linux Flatpak, the desktop entry comment string can be translated at our
[Flatpak
repository](https://github.com/flathub/org.gaphor.Gaphor/blob/master/share/org.gaphor.Gaphor.desktop).
Thank you so much for your effort in helping us keep it available in many
languages!
### βΏοΈ Code of Conduct
We value your participation and want everyone to have an enjoyable and
fulfilling experience. As a [GNOME Circle](https://circle.gnome.org/) project,
all participants are expected to follow the GNOME [Code of
Conduct](https://wiki.gnome.org/Foundation/CodeOfConduct), and to show respect,
understanding, and consideration to one another. Thank you for helping make this
a welcoming, friendly community for everyone.
## Β©οΈ License
Copyright Β© Arjan Molenaar and Dan Yeaw
Licensed under the [Apache License v2](LICENSE.txt).
Summary: You can do what you like with Gaphor, as long as you include the
required notices. This permissive license contains a patent license from the
contributors of the code.
%package -n python3-gaphor
Summary: Gaphor is the simple modeling tool written in Python.
Provides: python-gaphor
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-gaphor
[![Build](https://github.com/gaphor/gaphor/actions/workflows/full-build.yml/badge.svg)](https://github.com/gaphor/gaphor/actions/workflows/full-build.yml?query=branch%3Amain)
[![Hypothesis Tests](https://github.com/gaphor/gaphor/actions/workflows/hypothesis-test.yml/badge.svg)](https://github.com/gaphor/gaphor/actions/workflows/hypothesis-test.yml?query=branch%3Amain)
[![Docs build state](https://readthedocs.org/projects/gaphor/badge/?version=latest)](https://docs.gaphor.org)
[![PyPI](https://img.shields.io/pypi/v/gaphor.svg)](https://pypi.org/project/gaphor)
[![PyPI - Downloads](https://img.shields.io/pypi/dm/gaphor)](https://pypistats.org/packages/gaphor)
[![Matrix](https://img.shields.io/badge/chat-on%20Matrix-success)](https://app.element.io/#/room/#gaphor_Lobby:gitter.im)
[![Maintainability](https://api.codeclimate.com/v1/badges/f00974f5d7fe69fe4ecd/maintainability)](https://codeclimate.com/github/gaphor/gaphor/maintainability)
[![Test Coverage](https://api.codeclimate.com/v1/badges/f00974f5d7fe69fe4ecd/test_coverage)](https://codeclimate.com/github/gaphor/gaphor/test_coverage)
[![Translation Status](https://hosted.weblate.org/widgets/gaphor/-/gaphor/svg-badge.svg)](https://hosted.weblate.org/engage/gaphor)
[![Sourcery](https://img.shields.io/badge/Sourcery-enabled-brightgreen)](https://sourcery.ai)
[![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/ambv/black)
[![standard-readme compliant](https://img.shields.io/badge/readme%20style-standard-brightgreen.svg)](https://github.com/RichardLitt/standard-readme)
[![All Contributors](https://img.shields.io/badge/all_contributors-32-brightgreen.svg)](#contributors)
Gaphor is a UML and SysML modeling application written in Python.
It is designed to be easy to use, while still being powerful. Gaphor implements a fully-compliant UML 2 data model, so it is much more than a picture drawing tool. You can use Gaphor to quickly visualize different aspects of a system as well as create complete, highly complex models.
## π Table of Contents
- [π Table of Contents](#-table-of-contents)
- [π Background](#-background)
- [πΎ Install](#-install)
- [π¦ Usage](#-usage)
- [β₯ Contributing](#-contributing)
- [π Translations](#-translations)
- [βΏοΈ Code of Conduct](#οΈ-code-of-conduct)
- [Β©οΈ License](#οΈ-license)
## π Background
Gaphor is a UML and SysML modeling application written in Python. We designed
it to be easy to use, while still being powerful. Gaphor implements a
fully-compliant UML 2 data model, so it is much more than a picture drawing
tool. You can use Gaphor to quickly visualize different aspects of a system as
well as create complete, highly complex models.
Gaphor is designed around the following principles:
- Simplicity: The application should be easy to use. Only some basic knowledge of UML or SysML is required.
- Consistency: UML is a graphical modeling language, so all modeling is done in a diagram.
- Workability: The application should not bother the user every time they do something non-UML-ish.
Gaphor is a GUI application. It has a modern [GTK](https://gtk.org)-based interface and uses
[Cairo](https://www.cairographics.org/) for consistent rendering.
Gaphor is a library.
You can use it from [scripts and Jupyter notebooks](https://docs.gaphor.org/en/latest/scripting.html)
and interact with models programmatically.
Non-Goals:
- Generating UML diagrams from source code. [pynsource](https://github.com/abulka/pynsource) or [pyreverse](https://github.com/pylint-dev/pylint/tree/main/pylint/pyreverse) might be what you are looking for.
- Generating source code from diagrams or creating other concrete executable artifacts including use of fUML or ALF.
Although it would be possible to incorporate these features, these aren't the
goals of this project. However, if these are important capabilities for you,
you may be able to extend Gaphor by creating a
[plugin](https://docs.gaphor.org/en/latest/service_oriented.html#example-plugin).
## πΎ Install
You can find [the latest version](https://gaphor.org/download) on the
[gaphor.org website](https://gaphor.org/download). Gaphor ships installers for
macOS and Windows. Those can be found there. The Python package is also
[available on PyPI](https://pypi.org/project/gaphor/).
All releases are available on
[GitHub](https://github.com/gaphor/gaphor/releases/).
If you want to start developing on Gaphor, have a look at the [Installation
section of our Tech docs](https://docs.gaphor.org/en/latest/).
## π¦ Usage
If using Gaphor for the first time you will be presented with a greeter dialog
at startup in which you can select one of 5 models available to you to work in:
- **Generic:** (or blank) template
- **UML:** *Unified Modeling Language* template
- **SysML:** *Systems Modeling Language* template
- **RAAML:** *Risk Analysis and Assessment Modeling language* template
- **C4 Model:** *a lean graphical notation technique for modelling the architecture of software systems* template
After you select a template, the main Gaphor Window will load, and you will be
ready to start modeling. Gaphor will automatically select the correct profile
based on the template that you selected, but you can also select other modeling
profiles if needed by clicking on the button next to the Profile dropdown menu
at the top of your window.
To select an element you want to place, for example a Class, click on the icon
in the Toolbox and then again on the diagram. This will place a new Class item
on the diagram and add a new Class to the model (it shows up in the Navigation).
The selected tool will reset itself to the Pointer tool if the option ''Diagram
β Reset tool'' is selected.
Portions of the toolbox may also be collapsed depending on the type of diagram
you are modeling with. You can expand the collapsed portions of the toolbox if
needed.
If you want to know more, please read our documentation on https://docs.gaphor.org.
## β₯ Contributing
Thanks goes to these wonderful people ([emoji key](https://github.com/kentcdodds/all-contributors#emoji-key)):
This project follows the
[all-contributors](https://github.com/kentcdodds/all-contributors)
specification. Contributions of any kind are welcome!
1. Check for open issues or open a fresh issue to start a discussion
around a feature idea or a bug. There is a
[first-timers-only](https://github.com/gaphor/gaphor/issues?utf8=%E2%9C%93&q=is%3Aissue+is%3Aopen+label%3Afirst-timers-only)
tag for issues that should be ideal for people who are not very
familiar with the codebase yet.
2. Fork [the repository](https://github.com/gaphor/gaphor) on
GitHub to start making your changes to the **main** branch (or
branch off of it).
3. Write a test which shows that the bug was fixed or that the feature
works as expected.
4. Send a pull request and bug the maintainers until it gets merged and
published. :smile:
See [the contributing guide](CONTRIBUTING.md)!
### π Translations
Translation of Gaphor is mostly done using
[Weblate](https://hosted.weblate.org/projects/gaphor/gaphor/).
For the Linux Flatpak, the desktop entry comment string can be translated at our
[Flatpak
repository](https://github.com/flathub/org.gaphor.Gaphor/blob/master/share/org.gaphor.Gaphor.desktop).
Thank you so much for your effort in helping us keep it available in many
languages!
### βΏοΈ Code of Conduct
We value your participation and want everyone to have an enjoyable and
fulfilling experience. As a [GNOME Circle](https://circle.gnome.org/) project,
all participants are expected to follow the GNOME [Code of
Conduct](https://wiki.gnome.org/Foundation/CodeOfConduct), and to show respect,
understanding, and consideration to one another. Thank you for helping make this
a welcoming, friendly community for everyone.
## Β©οΈ License
Copyright Β© Arjan Molenaar and Dan Yeaw
Licensed under the [Apache License v2](LICENSE.txt).
Summary: You can do what you like with Gaphor, as long as you include the
required notices. This permissive license contains a patent license from the
contributors of the code.
%package help
Summary: Development documents and examples for gaphor
Provides: python3-gaphor-doc
%description help
[![Build](https://github.com/gaphor/gaphor/actions/workflows/full-build.yml/badge.svg)](https://github.com/gaphor/gaphor/actions/workflows/full-build.yml?query=branch%3Amain)
[![Hypothesis Tests](https://github.com/gaphor/gaphor/actions/workflows/hypothesis-test.yml/badge.svg)](https://github.com/gaphor/gaphor/actions/workflows/hypothesis-test.yml?query=branch%3Amain)
[![Docs build state](https://readthedocs.org/projects/gaphor/badge/?version=latest)](https://docs.gaphor.org)
[![PyPI](https://img.shields.io/pypi/v/gaphor.svg)](https://pypi.org/project/gaphor)
[![PyPI - Downloads](https://img.shields.io/pypi/dm/gaphor)](https://pypistats.org/packages/gaphor)
[![Matrix](https://img.shields.io/badge/chat-on%20Matrix-success)](https://app.element.io/#/room/#gaphor_Lobby:gitter.im)
[![Maintainability](https://api.codeclimate.com/v1/badges/f00974f5d7fe69fe4ecd/maintainability)](https://codeclimate.com/github/gaphor/gaphor/maintainability)
[![Test Coverage](https://api.codeclimate.com/v1/badges/f00974f5d7fe69fe4ecd/test_coverage)](https://codeclimate.com/github/gaphor/gaphor/test_coverage)
[![Translation Status](https://hosted.weblate.org/widgets/gaphor/-/gaphor/svg-badge.svg)](https://hosted.weblate.org/engage/gaphor)
[![Sourcery](https://img.shields.io/badge/Sourcery-enabled-brightgreen)](https://sourcery.ai)
[![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/ambv/black)
[![standard-readme compliant](https://img.shields.io/badge/readme%20style-standard-brightgreen.svg)](https://github.com/RichardLitt/standard-readme)
[![All Contributors](https://img.shields.io/badge/all_contributors-32-brightgreen.svg)](#contributors)
Gaphor is a UML and SysML modeling application written in Python.
It is designed to be easy to use, while still being powerful. Gaphor implements a fully-compliant UML 2 data model, so it is much more than a picture drawing tool. You can use Gaphor to quickly visualize different aspects of a system as well as create complete, highly complex models.
## π Table of Contents
- [π Table of Contents](#-table-of-contents)
- [π Background](#-background)
- [πΎ Install](#-install)
- [π¦ Usage](#-usage)
- [β₯ Contributing](#-contributing)
- [π Translations](#-translations)
- [βΏοΈ Code of Conduct](#οΈ-code-of-conduct)
- [Β©οΈ License](#οΈ-license)
## π Background
Gaphor is a UML and SysML modeling application written in Python. We designed
it to be easy to use, while still being powerful. Gaphor implements a
fully-compliant UML 2 data model, so it is much more than a picture drawing
tool. You can use Gaphor to quickly visualize different aspects of a system as
well as create complete, highly complex models.
Gaphor is designed around the following principles:
- Simplicity: The application should be easy to use. Only some basic knowledge of UML or SysML is required.
- Consistency: UML is a graphical modeling language, so all modeling is done in a diagram.
- Workability: The application should not bother the user every time they do something non-UML-ish.
Gaphor is a GUI application. It has a modern [GTK](https://gtk.org)-based interface and uses
[Cairo](https://www.cairographics.org/) for consistent rendering.
Gaphor is a library.
You can use it from [scripts and Jupyter notebooks](https://docs.gaphor.org/en/latest/scripting.html)
and interact with models programmatically.
Non-Goals:
- Generating UML diagrams from source code. [pynsource](https://github.com/abulka/pynsource) or [pyreverse](https://github.com/pylint-dev/pylint/tree/main/pylint/pyreverse) might be what you are looking for.
- Generating source code from diagrams or creating other concrete executable artifacts including use of fUML or ALF.
Although it would be possible to incorporate these features, these aren't the
goals of this project. However, if these are important capabilities for you,
you may be able to extend Gaphor by creating a
[plugin](https://docs.gaphor.org/en/latest/service_oriented.html#example-plugin).
## πΎ Install
You can find [the latest version](https://gaphor.org/download) on the
[gaphor.org website](https://gaphor.org/download). Gaphor ships installers for
macOS and Windows. Those can be found there. The Python package is also
[available on PyPI](https://pypi.org/project/gaphor/).
All releases are available on
[GitHub](https://github.com/gaphor/gaphor/releases/).
If you want to start developing on Gaphor, have a look at the [Installation
section of our Tech docs](https://docs.gaphor.org/en/latest/).
## π¦ Usage
If using Gaphor for the first time you will be presented with a greeter dialog
at startup in which you can select one of 5 models available to you to work in:
- **Generic:** (or blank) template
- **UML:** *Unified Modeling Language* template
- **SysML:** *Systems Modeling Language* template
- **RAAML:** *Risk Analysis and Assessment Modeling language* template
- **C4 Model:** *a lean graphical notation technique for modelling the architecture of software systems* template
After you select a template, the main Gaphor Window will load, and you will be
ready to start modeling. Gaphor will automatically select the correct profile
based on the template that you selected, but you can also select other modeling
profiles if needed by clicking on the button next to the Profile dropdown menu
at the top of your window.
To select an element you want to place, for example a Class, click on the icon
in the Toolbox and then again on the diagram. This will place a new Class item
on the diagram and add a new Class to the model (it shows up in the Navigation).
The selected tool will reset itself to the Pointer tool if the option ''Diagram
β Reset tool'' is selected.
Portions of the toolbox may also be collapsed depending on the type of diagram
you are modeling with. You can expand the collapsed portions of the toolbox if
needed.
If you want to know more, please read our documentation on https://docs.gaphor.org.
## β₯ Contributing
Thanks goes to these wonderful people ([emoji key](https://github.com/kentcdodds/all-contributors#emoji-key)):
This project follows the
[all-contributors](https://github.com/kentcdodds/all-contributors)
specification. Contributions of any kind are welcome!
1. Check for open issues or open a fresh issue to start a discussion
around a feature idea or a bug. There is a
[first-timers-only](https://github.com/gaphor/gaphor/issues?utf8=%E2%9C%93&q=is%3Aissue+is%3Aopen+label%3Afirst-timers-only)
tag for issues that should be ideal for people who are not very
familiar with the codebase yet.
2. Fork [the repository](https://github.com/gaphor/gaphor) on
GitHub to start making your changes to the **main** branch (or
branch off of it).
3. Write a test which shows that the bug was fixed or that the feature
works as expected.
4. Send a pull request and bug the maintainers until it gets merged and
published. :smile:
See [the contributing guide](CONTRIBUTING.md)!
### π Translations
Translation of Gaphor is mostly done using
[Weblate](https://hosted.weblate.org/projects/gaphor/gaphor/).
For the Linux Flatpak, the desktop entry comment string can be translated at our
[Flatpak
repository](https://github.com/flathub/org.gaphor.Gaphor/blob/master/share/org.gaphor.Gaphor.desktop).
Thank you so much for your effort in helping us keep it available in many
languages!
### βΏοΈ Code of Conduct
We value your participation and want everyone to have an enjoyable and
fulfilling experience. As a [GNOME Circle](https://circle.gnome.org/) project,
all participants are expected to follow the GNOME [Code of
Conduct](https://wiki.gnome.org/Foundation/CodeOfConduct), and to show respect,
understanding, and consideration to one another. Thank you for helping make this
a welcoming, friendly community for everyone.
## Β©οΈ License
Copyright Β© Arjan Molenaar and Dan Yeaw
Licensed under the [Apache License v2](LICENSE.txt).
Summary: You can do what you like with Gaphor, as long as you include the
required notices. This permissive license contains a patent license from the
contributors of the code.
%prep
%autosetup -n gaphor-2.18.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-gaphor -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 2.18.1-1
- Package Spec generated