%global _empty_manifest_terminate_build 0
Name: python-quoter
Version: 1.6.8
Release: 1
Summary: Powerful way to construct text, HTML, and XML, plus a kick-ass join
License: Apache License 2.0
URL: https://bitbucket.org/jeunice/quoter
Source0: https://mirrors.aliyun.com/pypi/web/packages/87/8d/8e0d730e4382517f1b25937dd6d36a5ddf77225fc3d4039178df03a1d3c5/quoter-1.6.8.zip
BuildArch: noarch
%description
from quoter import *
print single('this') # 'this'
print double('that') # "that"
print backticks('ls -l') # `ls -l`
print braces('curlycue') # {curlycue}
print braces('curlysue', padding=1)
# { curlysue }
Cute...but way too simple to be useful, right? Read on!
Let's try something more complicated, where the output has to be
intelligently based on context. Here's a taste of quoting some HTML
content::
print html.p("A para", ".focus")
print html.img('.large', src='file.jpg')
print html.br()
print html.comment("content ends here")
Yields::
A para
This goes well beyond "simply wrapping some text with other text." The
output format varies widely, correctly interpreting CSS Selector-based
controls, using void/self-closing elements where needed, and using
specialized markup such as the comment format when needed. The HTML quoter
and its companion XML quoter are competitive in power and simplicity with
bespoke markup-generating packages.
(A similar generator for Markdown is also newly included, though it's a the
"demonsration" rather than "use in production code" stage.)
Finally, ``quoter`` provides a drop-dead simple, highly functional,
``join`` function::
mylist = list("ABCD")
print join(mylist)
print join(mylist, sep=" | ", endcaps=braces)
print join(mylist, sep=" | ", endcaps=braces.but(padding=1))
print and_join(mylist)
print and_join(mylist[:2])
print and_join(mylist[:3])
print and_join(mylist, quoter=double, lastsep=" and ")
Yields::
A, B, C, D
{A | B | C | D}
{ A | B | C | D }
A and B
A, B, and C
A, B, C, and D
"A", "B", "C" and "D"
Which shows a range of separators, separation styles (both Oxford and
non-Oxford commas), endcaps, padding, and individual item quoting. I daresay
you will not find a more flexible or configurable ``join`` function
*anywhere* else, in any programming language, at any price.
And if you like any particular style of formatting, make it your own::
>>> my_join = join.but(sep=" | ", endcaps=braces.but(padding=1))
>>> print my_join(mylist)
{ A | B | C | D }
Now you have a convenient specialized formatter to your own specifications.
See `the rest of the story
at Read the Docs `_.
%package -n python3-quoter
Summary: Powerful way to construct text, HTML, and XML, plus a kick-ass join
Provides: python-quoter
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-quoter
from quoter import *
print single('this') # 'this'
print double('that') # "that"
print backticks('ls -l') # `ls -l`
print braces('curlycue') # {curlycue}
print braces('curlysue', padding=1)
# { curlysue }
Cute...but way too simple to be useful, right? Read on!
Let's try something more complicated, where the output has to be
intelligently based on context. Here's a taste of quoting some HTML
content::
print html.p("A para", ".focus")
print html.img('.large', src='file.jpg')
print html.br()
print html.comment("content ends here")
Yields::
A para
This goes well beyond "simply wrapping some text with other text." The
output format varies widely, correctly interpreting CSS Selector-based
controls, using void/self-closing elements where needed, and using
specialized markup such as the comment format when needed. The HTML quoter
and its companion XML quoter are competitive in power and simplicity with
bespoke markup-generating packages.
(A similar generator for Markdown is also newly included, though it's a the
"demonsration" rather than "use in production code" stage.)
Finally, ``quoter`` provides a drop-dead simple, highly functional,
``join`` function::
mylist = list("ABCD")
print join(mylist)
print join(mylist, sep=" | ", endcaps=braces)
print join(mylist, sep=" | ", endcaps=braces.but(padding=1))
print and_join(mylist)
print and_join(mylist[:2])
print and_join(mylist[:3])
print and_join(mylist, quoter=double, lastsep=" and ")
Yields::
A, B, C, D
{A | B | C | D}
{ A | B | C | D }
A and B
A, B, and C
A, B, C, and D
"A", "B", "C" and "D"
Which shows a range of separators, separation styles (both Oxford and
non-Oxford commas), endcaps, padding, and individual item quoting. I daresay
you will not find a more flexible or configurable ``join`` function
*anywhere* else, in any programming language, at any price.
And if you like any particular style of formatting, make it your own::
>>> my_join = join.but(sep=" | ", endcaps=braces.but(padding=1))
>>> print my_join(mylist)
{ A | B | C | D }
Now you have a convenient specialized formatter to your own specifications.
See `the rest of the story
at Read the Docs `_.
%package help
Summary: Development documents and examples for quoter
Provides: python3-quoter-doc
%description help
from quoter import *
print single('this') # 'this'
print double('that') # "that"
print backticks('ls -l') # `ls -l`
print braces('curlycue') # {curlycue}
print braces('curlysue', padding=1)
# { curlysue }
Cute...but way too simple to be useful, right? Read on!
Let's try something more complicated, where the output has to be
intelligently based on context. Here's a taste of quoting some HTML
content::
print html.p("A para", ".focus")
print html.img('.large', src='file.jpg')
print html.br()
print html.comment("content ends here")
Yields::
A para
This goes well beyond "simply wrapping some text with other text." The
output format varies widely, correctly interpreting CSS Selector-based
controls, using void/self-closing elements where needed, and using
specialized markup such as the comment format when needed. The HTML quoter
and its companion XML quoter are competitive in power and simplicity with
bespoke markup-generating packages.
(A similar generator for Markdown is also newly included, though it's a the
"demonsration" rather than "use in production code" stage.)
Finally, ``quoter`` provides a drop-dead simple, highly functional,
``join`` function::
mylist = list("ABCD")
print join(mylist)
print join(mylist, sep=" | ", endcaps=braces)
print join(mylist, sep=" | ", endcaps=braces.but(padding=1))
print and_join(mylist)
print and_join(mylist[:2])
print and_join(mylist[:3])
print and_join(mylist, quoter=double, lastsep=" and ")
Yields::
A, B, C, D
{A | B | C | D}
{ A | B | C | D }
A and B
A, B, and C
A, B, C, and D
"A", "B", "C" and "D"
Which shows a range of separators, separation styles (both Oxford and
non-Oxford commas), endcaps, padding, and individual item quoting. I daresay
you will not find a more flexible or configurable ``join`` function
*anywhere* else, in any programming language, at any price.
And if you like any particular style of formatting, make it your own::
>>> my_join = join.but(sep=" | ", endcaps=braces.but(padding=1))
>>> print my_join(mylist)
{ A | B | C | D }
Now you have a convenient specialized formatter to your own specifications.
See `the rest of the story
at Read the Docs `_.
%prep
%autosetup -n quoter-1.6.8
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-quoter -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 1.6.8-1
- Package Spec generated