%global _empty_manifest_terminate_build 0
Name: python-PyVuka
Version: 0.1.0.82
Release: 1
Summary: A General Purpose Global Data Analysis Package
License: Free For Educational Use
URL: https://github.com/bostonautolytics/pyvuka
Source0: https://mirrors.aliyun.com/pypi/web/packages/38/38/fdb467e244e6385a00db46422eb2c308974bdbaef4ad9b7b9085c05803aa/PyVuka-0.1.0.82.tar.gz
BuildArch: noarch
Requires: python3-asteval
Requires: python3-chardet
Requires: python3-lmfit
Requires: python3-matplotlib
Requires: python3-numpy
Requires: python3-pack64
Requires: python3-Pillow
Requires: python3-psutil
Requires: python3-PyQt5
Requires: python3-scipy
Requires: python3-xlrd
Requires: python3-XlsxWriter
%description
# PyVuka
PyVuka is a command line based and scriptable data fitting program. This software can be used for global and unlinked fitting of custom data models, data transforms, plotting, reading, and writing files. Custom python-native modules can also be written and will be automatically imported upon deposition in the Modules directory.
This project has been supported by the Institute of Protein Innovation, Boston AutoLytics, Adimab, Microgradient Fluidics, UMass Medical School, and the University of Pennsylvania
## Installation
pip install PyVuka
## Example as PyVuka as a python Library
#### Code
```python
import PyVuka.ModuleLink.toPyVuka as pyvuka # use PyVuka code base as a library
pvk = pyvuka.initialize_instance() # initialize pyvuka
buffer = pvk.new_buffer() # create new data buffer
buffer.data.x.set([0,1,2,3,4,5,6,7,8,9]) # populate x and y data vectors
buffer.data.y.set([0,0.5,1.75,3.5,4,4.85,6.2,7.1,7.9,9.3])
buffer.plot.axis.x.title.set("random int") # add axes titles
buffer.plot.axis.y.title.set("random float")
pvk.add_buffer_to_datamatrix(buffer) # add buffer to data matrix
pvk.run_pyvuka_command('fun 27 0') # select function 27 (Y=mx+b) ; in app mode type 'fun' to see list of available functions
pvk.run_pyvuka_command('ap 1 1 1 1') # alter parameters of function 27. "For buffer 1 through buffer 1, slope guess = 1, y-intercept guess = 1"
pvk.run_pyvuka_command('fit 100') # fit all data in matrix with function 27, use maximum of 100 iterations
pvk.show_plot(1) # Show plot of buffer 1 on screen and save to drive
pvk.save_plot(1, "test.png")
```
#### Ouput
## Example of using PyVuka as a command line program
#### Code
```python
import PyVuka.app as app # Use Pyvuka as a command line app
app.start()
```
#### Ouput
## License
Copyright (c) 2020 BostonAutoLytics LLC
Permission is hereby granted, free of charge, to any person obtaining a copy
of this software and associated documentation files (the "Software"), to use
this software freely for personal and research use ONLY. This license does
NOT PERMIT uses including resale, modify, merge, publish, distribute,
sublicense, and/or selling copies in part or in-whole of this software.
Re-sale or inclusion in commercial software is subject to licensing agreements
made with Boston AutoLytics, LLC.
For more information e-mail info@BostonAutoLytics.com
PERSONAL USE:
This software may be used and modified without restriction.
RESEARCH USE:
If this software is used to generate results published in an
academic journal or similar professional publication, please cite in-line
with the version number being used. Example: "Data was fit with a 2:1 binding
model using the python package PyVuka v.1.0 (Boston AutoLytics, LLC)". This
software may be included in-whole or in-part within publicly available and
non-commercial distributions. Inclusion in products that are sold require
a licensing agreement (contact: info@BostonAutoLytics.com).
COMMERCIAL USE:
PROHIBITED WITHOUT LICENSING AGREEMENT. Contact: info@BostonAutoLytics.com
The above copyright notice and this permission notice shall be included in all
copies or substantial portions of the Software.
THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
SOFTWARE.
%package -n python3-PyVuka
Summary: A General Purpose Global Data Analysis Package
Provides: python-PyVuka
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-PyVuka
# PyVuka
PyVuka is a command line based and scriptable data fitting program. This software can be used for global and unlinked fitting of custom data models, data transforms, plotting, reading, and writing files. Custom python-native modules can also be written and will be automatically imported upon deposition in the Modules directory.
This project has been supported by the Institute of Protein Innovation, Boston AutoLytics, Adimab, Microgradient Fluidics, UMass Medical School, and the University of Pennsylvania
## Installation
pip install PyVuka
## Example as PyVuka as a python Library
#### Code
```python
import PyVuka.ModuleLink.toPyVuka as pyvuka # use PyVuka code base as a library
pvk = pyvuka.initialize_instance() # initialize pyvuka
buffer = pvk.new_buffer() # create new data buffer
buffer.data.x.set([0,1,2,3,4,5,6,7,8,9]) # populate x and y data vectors
buffer.data.y.set([0,0.5,1.75,3.5,4,4.85,6.2,7.1,7.9,9.3])
buffer.plot.axis.x.title.set("random int") # add axes titles
buffer.plot.axis.y.title.set("random float")
pvk.add_buffer_to_datamatrix(buffer) # add buffer to data matrix
pvk.run_pyvuka_command('fun 27 0') # select function 27 (Y=mx+b) ; in app mode type 'fun' to see list of available functions
pvk.run_pyvuka_command('ap 1 1 1 1') # alter parameters of function 27. "For buffer 1 through buffer 1, slope guess = 1, y-intercept guess = 1"
pvk.run_pyvuka_command('fit 100') # fit all data in matrix with function 27, use maximum of 100 iterations
pvk.show_plot(1) # Show plot of buffer 1 on screen and save to drive
pvk.save_plot(1, "test.png")
```
#### Ouput
## Example of using PyVuka as a command line program
#### Code
```python
import PyVuka.app as app # Use Pyvuka as a command line app
app.start()
```
#### Ouput
## License
Copyright (c) 2020 BostonAutoLytics LLC
Permission is hereby granted, free of charge, to any person obtaining a copy
of this software and associated documentation files (the "Software"), to use
this software freely for personal and research use ONLY. This license does
NOT PERMIT uses including resale, modify, merge, publish, distribute,
sublicense, and/or selling copies in part or in-whole of this software.
Re-sale or inclusion in commercial software is subject to licensing agreements
made with Boston AutoLytics, LLC.
For more information e-mail info@BostonAutoLytics.com
PERSONAL USE:
This software may be used and modified without restriction.
RESEARCH USE:
If this software is used to generate results published in an
academic journal or similar professional publication, please cite in-line
with the version number being used. Example: "Data was fit with a 2:1 binding
model using the python package PyVuka v.1.0 (Boston AutoLytics, LLC)". This
software may be included in-whole or in-part within publicly available and
non-commercial distributions. Inclusion in products that are sold require
a licensing agreement (contact: info@BostonAutoLytics.com).
COMMERCIAL USE:
PROHIBITED WITHOUT LICENSING AGREEMENT. Contact: info@BostonAutoLytics.com
The above copyright notice and this permission notice shall be included in all
copies or substantial portions of the Software.
THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
SOFTWARE.
%package help
Summary: Development documents and examples for PyVuka
Provides: python3-PyVuka-doc
%description help
# PyVuka
PyVuka is a command line based and scriptable data fitting program. This software can be used for global and unlinked fitting of custom data models, data transforms, plotting, reading, and writing files. Custom python-native modules can also be written and will be automatically imported upon deposition in the Modules directory.
This project has been supported by the Institute of Protein Innovation, Boston AutoLytics, Adimab, Microgradient Fluidics, UMass Medical School, and the University of Pennsylvania
## Installation
pip install PyVuka
## Example as PyVuka as a python Library
#### Code
```python
import PyVuka.ModuleLink.toPyVuka as pyvuka # use PyVuka code base as a library
pvk = pyvuka.initialize_instance() # initialize pyvuka
buffer = pvk.new_buffer() # create new data buffer
buffer.data.x.set([0,1,2,3,4,5,6,7,8,9]) # populate x and y data vectors
buffer.data.y.set([0,0.5,1.75,3.5,4,4.85,6.2,7.1,7.9,9.3])
buffer.plot.axis.x.title.set("random int") # add axes titles
buffer.plot.axis.y.title.set("random float")
pvk.add_buffer_to_datamatrix(buffer) # add buffer to data matrix
pvk.run_pyvuka_command('fun 27 0') # select function 27 (Y=mx+b) ; in app mode type 'fun' to see list of available functions
pvk.run_pyvuka_command('ap 1 1 1 1') # alter parameters of function 27. "For buffer 1 through buffer 1, slope guess = 1, y-intercept guess = 1"
pvk.run_pyvuka_command('fit 100') # fit all data in matrix with function 27, use maximum of 100 iterations
pvk.show_plot(1) # Show plot of buffer 1 on screen and save to drive
pvk.save_plot(1, "test.png")
```
#### Ouput
## Example of using PyVuka as a command line program
#### Code
```python
import PyVuka.app as app # Use Pyvuka as a command line app
app.start()
```
#### Ouput
## License
Copyright (c) 2020 BostonAutoLytics LLC
Permission is hereby granted, free of charge, to any person obtaining a copy
of this software and associated documentation files (the "Software"), to use
this software freely for personal and research use ONLY. This license does
NOT PERMIT uses including resale, modify, merge, publish, distribute,
sublicense, and/or selling copies in part or in-whole of this software.
Re-sale or inclusion in commercial software is subject to licensing agreements
made with Boston AutoLytics, LLC.
For more information e-mail info@BostonAutoLytics.com
PERSONAL USE:
This software may be used and modified without restriction.
RESEARCH USE:
If this software is used to generate results published in an
academic journal or similar professional publication, please cite in-line
with the version number being used. Example: "Data was fit with a 2:1 binding
model using the python package PyVuka v.1.0 (Boston AutoLytics, LLC)". This
software may be included in-whole or in-part within publicly available and
non-commercial distributions. Inclusion in products that are sold require
a licensing agreement (contact: info@BostonAutoLytics.com).
COMMERCIAL USE:
PROHIBITED WITHOUT LICENSING AGREEMENT. Contact: info@BostonAutoLytics.com
The above copyright notice and this permission notice shall be included in all
copies or substantial portions of the Software.
THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
SOFTWARE.
%prep
%autosetup -n PyVuka-0.1.0.82
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-PyVuka -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 0.1.0.82-1
- Package Spec generated