%global _empty_manifest_terminate_build 0
Name: python-geodata
Version: 1.7.1
Release: 1
Summary: Provide a place lookup gazeteer based on files from geonames.org
License: MIT
URL: https://github.com/corb555/Geodata
Source0: https://mirrors.aliyun.com/pypi/web/packages/d1/80/a11bd9a8702c513944222ba28a6806c601cbb213d23e7780d659fb4bb55d/geodata-1.7.1.tar.gz
BuildArch: noarch
Requires: python3-unidecode
Requires: python3-phonetics
Requires: python3-rapidfuzz
%description
# Geodata
Geodata provides a placename lookup gazeteer utilizing a local database using the 20M entry geonames.org data.
## Features
* Builds a local sqlite3 database of geoname.org data.
* Provides powerful search routines
* Word search
* Wildcard search
* Phonetic search using Double Metaphone
* Search by feature type. E.g. all mountains starting with Be in Germany
[See User Guide Wiki for details](https://github.com/corb555/Geodata/wiki/User-Guide)
%package -n python3-geodata
Summary: Provide a place lookup gazeteer based on files from geonames.org
Provides: python-geodata
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-geodata
# Geodata
Geodata provides a placename lookup gazeteer utilizing a local database using the 20M entry geonames.org data.
## Features
* Builds a local sqlite3 database of geoname.org data.
* Provides powerful search routines
* Word search
* Wildcard search
* Phonetic search using Double Metaphone
* Search by feature type. E.g. all mountains starting with Be in Germany
[See User Guide Wiki for details](https://github.com/corb555/Geodata/wiki/User-Guide)
%package help
Summary: Development documents and examples for geodata
Provides: python3-geodata-doc
%description help
# Geodata
Geodata provides a placename lookup gazeteer utilizing a local database using the 20M entry geonames.org data.
## Features
* Builds a local sqlite3 database of geoname.org data.
* Provides powerful search routines
* Word search
* Wildcard search
* Phonetic search using Double Metaphone
* Search by feature type. E.g. all mountains starting with Be in Germany
[See User Guide Wiki for details](https://github.com/corb555/Geodata/wiki/User-Guide)
%prep
%autosetup -n geodata-1.7.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-geodata -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 1.7.1-1
- Package Spec generated