%global _empty_manifest_terminate_build 0
Name: python-temple
Version: 1.4.8
Release: 1
Summary: Templated project management
License: BSD 3-Clause
URL: https://github.com/CloverHealth/temple
Source0: https://mirrors.aliyun.com/pypi/web/packages/3a/aa/53bd9edc448e90fa5eb50eed661056bb79bb546ff10f73d8a1564fa11454/temple-1.4.8.tar.gz
BuildArch: noarch
Requires: python3-click
Requires: python3-cookiecutter
Requires: python3-pyyaml
Requires: python3-requests
%description
`View the temple docs here `_.
A quick start and installation overview is provied below.
%package -n python3-temple
Summary: Templated project management
Provides: python-temple
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-temple
`View the temple docs here `_.
A quick start and installation overview is provied below.
%package help
Summary: Development documents and examples for temple
Provides: python3-temple-doc
%description help
`View the temple docs here `_.
A quick start and installation overview is provied below.
%prep
%autosetup -n temple-1.4.8
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-temple -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Jun 08 2023 Python_Bot - 1.4.8-1
- Package Spec generated