%global _empty_manifest_terminate_build 0
Name: python-bayoo-docx
Version: 0.2.20
Release: 1
Summary: Create and update Microsoft Word .docx files.
License: The MIT License (MIT) Copyright (c) 2019 Obay Daba, https://github.com/bayoog forked from https://github.com/python-openxml/python-docx Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions: The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software. THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
URL: https://github.com/BayooG/bayooo-docx
Source0: https://mirrors.aliyun.com/pypi/web/packages/4e/ea/297732e5b94d29254434fb210b4a58b759e7145a872983d011dd4d0e9803/bayoo-docx-0.2.20.tar.gz
BuildArch: noarch
Requires: python3-lxml
%description
Bayoo-docx
Python library forked from `python-docx `_.
The main purpose of the fork was to add implementation for comments and footnotes to the library
Installation
Use the package manager `pip `_ to install bayoo-docx.
`pip install bayoo-docx`
Usage
::
import docx
document = docx.Document()
paragraph1 = document.add_paragraph('text') # create new paragraph
comment = paragraph.add_comment('comment',author='Obay Daba',initials= 'od') # add a comment on the entire paragraph
paragraph2 = document.add_paragraph('text') # create another paragraph
run = paragraph2.add_run('texty') add a run to the paragraph
run.add_comment('comment') # add a comment only for the run text
paragraph.add_footnote('footnote text') # add a footnote
License
`MIT `_
.. :changelog:
#Release History BayooG/bayoo-docx forked from (python-openxmm/python-docx)
0.2.8 (2020-05-02)
- add comments implementation on a run level
- fix issue with comments date (comments dates are set to current date)
0.2.4 (2019-9-4)
- loop over all the document chieldern (Paragraphs, Tables, Sections) with the right order `document.elements`
- addons to Paragraph Object (delete, heading_level, merge_paragraph )
- Add low-level implementation for comments part
- Add oxml element for element and sub-elements
- Add add_comment() method for docx.text.Paragraph
- Add low-level implementation for footnotes part
- Add oxml element for element and sub-elements
- Add add_footnote() method for docx.text.Paragraph
%package -n python3-bayoo-docx
Summary: Create and update Microsoft Word .docx files.
Provides: python-bayoo-docx
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-bayoo-docx
Bayoo-docx
Python library forked from `python-docx `_.
The main purpose of the fork was to add implementation for comments and footnotes to the library
Installation
Use the package manager `pip `_ to install bayoo-docx.
`pip install bayoo-docx`
Usage
::
import docx
document = docx.Document()
paragraph1 = document.add_paragraph('text') # create new paragraph
comment = paragraph.add_comment('comment',author='Obay Daba',initials= 'od') # add a comment on the entire paragraph
paragraph2 = document.add_paragraph('text') # create another paragraph
run = paragraph2.add_run('texty') add a run to the paragraph
run.add_comment('comment') # add a comment only for the run text
paragraph.add_footnote('footnote text') # add a footnote
License
`MIT `_
.. :changelog:
#Release History BayooG/bayoo-docx forked from (python-openxmm/python-docx)
0.2.8 (2020-05-02)
- add comments implementation on a run level
- fix issue with comments date (comments dates are set to current date)
0.2.4 (2019-9-4)
- loop over all the document chieldern (Paragraphs, Tables, Sections) with the right order `document.elements`
- addons to Paragraph Object (delete, heading_level, merge_paragraph )
- Add low-level implementation for comments part
- Add oxml element for element and sub-elements
- Add add_comment() method for docx.text.Paragraph
- Add low-level implementation for footnotes part
- Add oxml element for element and sub-elements
- Add add_footnote() method for docx.text.Paragraph
%package help
Summary: Development documents and examples for bayoo-docx
Provides: python3-bayoo-docx-doc
%description help
Bayoo-docx
Python library forked from `python-docx `_.
The main purpose of the fork was to add implementation for comments and footnotes to the library
Installation
Use the package manager `pip `_ to install bayoo-docx.
`pip install bayoo-docx`
Usage
::
import docx
document = docx.Document()
paragraph1 = document.add_paragraph('text') # create new paragraph
comment = paragraph.add_comment('comment',author='Obay Daba',initials= 'od') # add a comment on the entire paragraph
paragraph2 = document.add_paragraph('text') # create another paragraph
run = paragraph2.add_run('texty') add a run to the paragraph
run.add_comment('comment') # add a comment only for the run text
paragraph.add_footnote('footnote text') # add a footnote
License
`MIT `_
.. :changelog:
#Release History BayooG/bayoo-docx forked from (python-openxmm/python-docx)
0.2.8 (2020-05-02)
- add comments implementation on a run level
- fix issue with comments date (comments dates are set to current date)
0.2.4 (2019-9-4)
- loop over all the document chieldern (Paragraphs, Tables, Sections) with the right order `document.elements`
- addons to Paragraph Object (delete, heading_level, merge_paragraph )
- Add low-level implementation for comments part
- Add oxml element for element and sub-elements
- Add add_comment() method for docx.text.Paragraph
- Add low-level implementation for footnotes part
- Add oxml element for element and sub-elements
- Add add_footnote() method for docx.text.Paragraph
%prep
%autosetup -n bayoo-docx-0.2.20
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-bayoo-docx -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Jun 09 2023 Python_Bot - 0.2.20-1
- Package Spec generated