%global _empty_manifest_terminate_build 0
Name: python-ffmpy3
Version: 0.2.4
Release: 1
Summary: A simple asynchronous Python wrapper for ffmpeg
License: MIT
URL: https://github.com/wchill/ffmpy3
Source0: https://mirrors.aliyun.com/pypi/web/packages/77/4c/acd9dd8efb0907bacab30176ab443e552b10dd8b7a8dc5f82e4e43fe5277/ffmpy3-0.2.4.tar.gz
BuildArch: noarch
%description
ffmpy3 is a fork of ffmpy, a simplistic `FFmpeg `_ command line wrapper. ffmpy implements a Pythonic interface for executing FFmpeg via command line and uses Python's `subprocess `_ module for synchronous execution. Asynchronous execution using `yield from` or `await` is also supported using Python's `asyncio.subprocess `_ module.
%package -n python3-ffmpy3
Summary: A simple asynchronous Python wrapper for ffmpeg
Provides: python-ffmpy3
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-ffmpy3
ffmpy3 is a fork of ffmpy, a simplistic `FFmpeg `_ command line wrapper. ffmpy implements a Pythonic interface for executing FFmpeg via command line and uses Python's `subprocess `_ module for synchronous execution. Asynchronous execution using `yield from` or `await` is also supported using Python's `asyncio.subprocess `_ module.
%package help
Summary: Development documents and examples for ffmpy3
Provides: python3-ffmpy3-doc
%description help
ffmpy3 is a fork of ffmpy, a simplistic `FFmpeg `_ command line wrapper. ffmpy implements a Pythonic interface for executing FFmpeg via command line and uses Python's `subprocess `_ module for synchronous execution. Asynchronous execution using `yield from` or `await` is also supported using Python's `asyncio.subprocess `_ module.
%prep
%autosetup -n ffmpy3-0.2.4
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-ffmpy3 -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Jun 09 2023 Python_Bot - 0.2.4-1
- Package Spec generated