%global _empty_manifest_terminate_build 0
Name: python-cobalt
Version: 7.0.0
Release: 1
Summary: A lightweight library for working with Akoma Ntoso Act documents
License: GNU Lesser General Public License v3 (LGPLv3)
URL: https://github.com/laws-africa/cobalt
Source0: https://mirrors.aliyun.com/pypi/web/packages/1d/93/dc16b1286389e2cc2fef2e3aa869c3971a260400d555d5032a189af53c68/cobalt-7.0.0.tar.gz
BuildArch: noarch
Requires: python3-iso8601
Requires: python3-lxml
Requires: python3-nose
Requires: python3-flake8
Requires: python3-Sphinx
Requires: python3-nose
Requires: python3-flake8
%description
Cobalt is a lightweight Python library for working with `Akoma Ntoso `_ documents.
It makes it easy to work with Akoma Ntoso documents, metadata and FRBR URIs.
It is lightweight because most operations are done on the XML document directly without intermediate
objects. You still need to understand how Akoma Ntoso works.
Read the `full documentation at cobalt.readthedocs.io `_.
%package -n python3-cobalt
Summary: A lightweight library for working with Akoma Ntoso Act documents
Provides: python-cobalt
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-cobalt
Cobalt is a lightweight Python library for working with `Akoma Ntoso `_ documents.
It makes it easy to work with Akoma Ntoso documents, metadata and FRBR URIs.
It is lightweight because most operations are done on the XML document directly without intermediate
objects. You still need to understand how Akoma Ntoso works.
Read the `full documentation at cobalt.readthedocs.io `_.
%package help
Summary: Development documents and examples for cobalt
Provides: python3-cobalt-doc
%description help
Cobalt is a lightweight Python library for working with `Akoma Ntoso `_ documents.
It makes it easy to work with Akoma Ntoso documents, metadata and FRBR URIs.
It is lightweight because most operations are done on the XML document directly without intermediate
objects. You still need to understand how Akoma Ntoso works.
Read the `full documentation at cobalt.readthedocs.io `_.
%prep
%autosetup -n cobalt-7.0.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-cobalt -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Jun 09 2023 Python_Bot - 7.0.0-1
- Package Spec generated