%global _empty_manifest_terminate_build 0
Name: python-GReNaDIne
Version: 0.0.21
Release: 1
Summary: Data-Driven Gene Regulatory Network Inference
License: GNU General Public License (GPL)
URL: https://pypi.org/project/GReNaDIne/
Source0: https://mirrors.aliyun.com/pypi/web/packages/5c/9f/e4bfe40b8db8ff5cae684ada99cfd81b2ec299cfebc4719cecd8a555a633/GReNaDIne-0.0.21.tar.gz
BuildArch: noarch
Requires: python3-pandas
Requires: python3-numpy
Requires: python3-scikit-learn
Requires: python3-tqdm
Requires: python3-scipy
%description
# GReNaDIne: Gene Regulatory Network Data-driven Inference
This Python 3.7 package allows to infer Gene Regulatory Networks through several
Data-driven methods. Pre-processing and evaluation methods are also included.
### Dependencies
+ `pip install numpy` version 1.16.2
+ `pip install pandas` version 0.24.2
+ `pip install matplotlib` version 3.0.3
+ `pip install joblib` version 0.13.2
+ `pip install Cython` version 0.29.6
+ `pip install scikit-learn` version 0.20.3
+ `pip install networkx`
+ `pip install seaborn`
+ `pip install pot` version 0.5.1
POT is not included in the automatic dependencies install
You have to install it if you want to use columns_matrix_OT_norm() normalization function.
The other functions of the package do not need POT.
+ `pip install rpy2` version 3.0.2
rpy2 is not included in the automatic dependencies install
You have to install it if you want to use DEseq2() normalization function.
The other functions of the package do not need rpy2.
### Installation:
`pip install GReNaDIne`
### Docker Image
`docker run speignier/grenadine`
### Documentation:
[grenadine.readthedocs.io](https://grenadine.readthedocs.io/en/latest/)
### Tutorials:
Check the jupyter notebook tutorials located in the __tutorial__ folder
+ `Infer_dream5_E_coli_GRN_using_GENIE3.ipynb` to infer GRNs using the GENIE3 method (random forest regression)
+ `Infer_dream5_E_coli_GRN_using_SVMs.ipynb` to infer GRNs using the SVM method (SVM classification)
### Authors:
For bug reports and feedback do not hesitate to contact the authors
+ Sergio Peignier: sergio.peignier AT insa-lyon.fr
+ Pauline Schmitt: pauline.schmitt AT insa-lyon.fr
### Maintainer:
+ Sergio Peignier: sergio.peignier AT insa-lyon.fr
%package -n python3-GReNaDIne
Summary: Data-Driven Gene Regulatory Network Inference
Provides: python-GReNaDIne
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-GReNaDIne
# GReNaDIne: Gene Regulatory Network Data-driven Inference
This Python 3.7 package allows to infer Gene Regulatory Networks through several
Data-driven methods. Pre-processing and evaluation methods are also included.
### Dependencies
+ `pip install numpy` version 1.16.2
+ `pip install pandas` version 0.24.2
+ `pip install matplotlib` version 3.0.3
+ `pip install joblib` version 0.13.2
+ `pip install Cython` version 0.29.6
+ `pip install scikit-learn` version 0.20.3
+ `pip install networkx`
+ `pip install seaborn`
+ `pip install pot` version 0.5.1
POT is not included in the automatic dependencies install
You have to install it if you want to use columns_matrix_OT_norm() normalization function.
The other functions of the package do not need POT.
+ `pip install rpy2` version 3.0.2
rpy2 is not included in the automatic dependencies install
You have to install it if you want to use DEseq2() normalization function.
The other functions of the package do not need rpy2.
### Installation:
`pip install GReNaDIne`
### Docker Image
`docker run speignier/grenadine`
### Documentation:
[grenadine.readthedocs.io](https://grenadine.readthedocs.io/en/latest/)
### Tutorials:
Check the jupyter notebook tutorials located in the __tutorial__ folder
+ `Infer_dream5_E_coli_GRN_using_GENIE3.ipynb` to infer GRNs using the GENIE3 method (random forest regression)
+ `Infer_dream5_E_coli_GRN_using_SVMs.ipynb` to infer GRNs using the SVM method (SVM classification)
### Authors:
For bug reports and feedback do not hesitate to contact the authors
+ Sergio Peignier: sergio.peignier AT insa-lyon.fr
+ Pauline Schmitt: pauline.schmitt AT insa-lyon.fr
### Maintainer:
+ Sergio Peignier: sergio.peignier AT insa-lyon.fr
%package help
Summary: Development documents and examples for GReNaDIne
Provides: python3-GReNaDIne-doc
%description help
# GReNaDIne: Gene Regulatory Network Data-driven Inference
This Python 3.7 package allows to infer Gene Regulatory Networks through several
Data-driven methods. Pre-processing and evaluation methods are also included.
### Dependencies
+ `pip install numpy` version 1.16.2
+ `pip install pandas` version 0.24.2
+ `pip install matplotlib` version 3.0.3
+ `pip install joblib` version 0.13.2
+ `pip install Cython` version 0.29.6
+ `pip install scikit-learn` version 0.20.3
+ `pip install networkx`
+ `pip install seaborn`
+ `pip install pot` version 0.5.1
POT is not included in the automatic dependencies install
You have to install it if you want to use columns_matrix_OT_norm() normalization function.
The other functions of the package do not need POT.
+ `pip install rpy2` version 3.0.2
rpy2 is not included in the automatic dependencies install
You have to install it if you want to use DEseq2() normalization function.
The other functions of the package do not need rpy2.
### Installation:
`pip install GReNaDIne`
### Docker Image
`docker run speignier/grenadine`
### Documentation:
[grenadine.readthedocs.io](https://grenadine.readthedocs.io/en/latest/)
### Tutorials:
Check the jupyter notebook tutorials located in the __tutorial__ folder
+ `Infer_dream5_E_coli_GRN_using_GENIE3.ipynb` to infer GRNs using the GENIE3 method (random forest regression)
+ `Infer_dream5_E_coli_GRN_using_SVMs.ipynb` to infer GRNs using the SVM method (SVM classification)
### Authors:
For bug reports and feedback do not hesitate to contact the authors
+ Sergio Peignier: sergio.peignier AT insa-lyon.fr
+ Pauline Schmitt: pauline.schmitt AT insa-lyon.fr
### Maintainer:
+ Sergio Peignier: sergio.peignier AT insa-lyon.fr
%prep
%autosetup -n GReNaDIne-0.0.21
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-GReNaDIne -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Jun 09 2023 Python_Bot - 0.0.21-1
- Package Spec generated