%global _empty_manifest_terminate_build 0
Name: python-nlp-dataset-readers
Version: 0.1.7
Release: 1
Summary: Dataset Readers for NLP
License: Apache
URL: https://github.com/Riccorl/nlp-dataset-readers
Source0: https://mirrors.aliyun.com/pypi/web/packages/d9/a9/2396ce7251227dfd54139694d9bb4e207cd52984fc8b4a8c4b5be8164d83/nlp-dataset-readers-0.1.7.tar.gz
BuildArch: noarch
Requires: python3-conllu
Requires: python3-rich
%description
# Dataset Readers for NLP
Utility for easily parsing common datasets for NLP.
[![Upload to PyPi](https://github.com/Riccorl/nlp-dataset-readers/actions/workflows/python-publish-pypi.yml/badge.svg)](https://github.com/Riccorl/nlp-dataset-readers/actions/workflows/python-publish-pypi.yml)
[![PyPi Version](https://img.shields.io/github/v/release/Riccorl/nlp-dataset-readers)](https://github.com/Riccorl/nlp-dataset-readers/releases)
[![Code style: black](https://img.shields.io/badge/code%20style-black-000000)](https://github.com/psf/black)
## Installation
From [PyPI](https://pypi.org/project/nlp-dataset-readers):
```bash
pip install nlp-dataset-readers
```
From source:
```bash
git clone https://github.com/Riccorl/nlp-dataset-readers
cd nlp-dataset-readers
pip install -e .
```
## Class and Datasets
### Semantic Role Labeling
Dataset readers for
- [CoNLL-2009](https://ufal.mff.cuni.cz/conll2009-st/task-description.html)
- [CoNLL-2012](https://cemantix.org/conll/2012/data.html)
- [UniteD-SRL](https://github.com/SapienzaNLP/united-srl)
### Word Sense Disambiguation
Dataset readers for
- [WSD Evaluation Framework](http://lcl.uniroma1.it/wsdeval/)
- [XL-WSD](https://sapienzanlp.github.io/xl-wsd/)
### WiC
Dataset readers for
- [XL-WiC]()
- [MCL-WiC]()
## Usage
ToDo
%package -n python3-nlp-dataset-readers
Summary: Dataset Readers for NLP
Provides: python-nlp-dataset-readers
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-nlp-dataset-readers
# Dataset Readers for NLP
Utility for easily parsing common datasets for NLP.
[![Upload to PyPi](https://github.com/Riccorl/nlp-dataset-readers/actions/workflows/python-publish-pypi.yml/badge.svg)](https://github.com/Riccorl/nlp-dataset-readers/actions/workflows/python-publish-pypi.yml)
[![PyPi Version](https://img.shields.io/github/v/release/Riccorl/nlp-dataset-readers)](https://github.com/Riccorl/nlp-dataset-readers/releases)
[![Code style: black](https://img.shields.io/badge/code%20style-black-000000)](https://github.com/psf/black)
## Installation
From [PyPI](https://pypi.org/project/nlp-dataset-readers):
```bash
pip install nlp-dataset-readers
```
From source:
```bash
git clone https://github.com/Riccorl/nlp-dataset-readers
cd nlp-dataset-readers
pip install -e .
```
## Class and Datasets
### Semantic Role Labeling
Dataset readers for
- [CoNLL-2009](https://ufal.mff.cuni.cz/conll2009-st/task-description.html)
- [CoNLL-2012](https://cemantix.org/conll/2012/data.html)
- [UniteD-SRL](https://github.com/SapienzaNLP/united-srl)
### Word Sense Disambiguation
Dataset readers for
- [WSD Evaluation Framework](http://lcl.uniroma1.it/wsdeval/)
- [XL-WSD](https://sapienzanlp.github.io/xl-wsd/)
### WiC
Dataset readers for
- [XL-WiC]()
- [MCL-WiC]()
## Usage
ToDo
%package help
Summary: Development documents and examples for nlp-dataset-readers
Provides: python3-nlp-dataset-readers-doc
%description help
# Dataset Readers for NLP
Utility for easily parsing common datasets for NLP.
[![Upload to PyPi](https://github.com/Riccorl/nlp-dataset-readers/actions/workflows/python-publish-pypi.yml/badge.svg)](https://github.com/Riccorl/nlp-dataset-readers/actions/workflows/python-publish-pypi.yml)
[![PyPi Version](https://img.shields.io/github/v/release/Riccorl/nlp-dataset-readers)](https://github.com/Riccorl/nlp-dataset-readers/releases)
[![Code style: black](https://img.shields.io/badge/code%20style-black-000000)](https://github.com/psf/black)
## Installation
From [PyPI](https://pypi.org/project/nlp-dataset-readers):
```bash
pip install nlp-dataset-readers
```
From source:
```bash
git clone https://github.com/Riccorl/nlp-dataset-readers
cd nlp-dataset-readers
pip install -e .
```
## Class and Datasets
### Semantic Role Labeling
Dataset readers for
- [CoNLL-2009](https://ufal.mff.cuni.cz/conll2009-st/task-description.html)
- [CoNLL-2012](https://cemantix.org/conll/2012/data.html)
- [UniteD-SRL](https://github.com/SapienzaNLP/united-srl)
### Word Sense Disambiguation
Dataset readers for
- [WSD Evaluation Framework](http://lcl.uniroma1.it/wsdeval/)
- [XL-WSD](https://sapienzanlp.github.io/xl-wsd/)
### WiC
Dataset readers for
- [XL-WiC]()
- [MCL-WiC]()
## Usage
ToDo
%prep
%autosetup -n nlp-dataset-readers-0.1.7
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-nlp-dataset-readers -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Jun 09 2023 Python_Bot - 0.1.7-1
- Package Spec generated